Installing Karmic 20090917 on Acer Aspire One freezes on detecting filesystems

Bug #432497 reported by Marc Tardif on 2009-09-18
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
Undecided
Unassigned

Bug Description

When attempting to installing Karmic 20090917 from the alternate image on an Acer Aspire One, the installer freezes on: detecting filesystems. Trying to install from the desktop image also never completes. I have attached the syslog from the system for further information.

Marc Tardif (cr3) wrote :
Ronald McCollam (fader) on 2009-09-18
tags: added: pcert
Marc Tardif (cr3) on 2009-09-18
affects: checkbox → linux

The interesting bits I'm seeing in the syslog are pasted below. It seems like the SSD drive is starting to go bad or has gone bad. The reason I also believe this is because Stefan has the same exact system with an SSD drive and has been able to install and run the latest Karmic without issue. Was this working relatively recently?

Sep 18 09:28:43 kernel: [ 40.956494] ata2.00: configured for UDMA/66
Sep 18 09:28:43 kernel: [ 40.956510] ata2: EH complete
Sep 18 09:28:43 kernel: [ 40.958525] ata2.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
Sep 18 09:28:43 kernel: [ 40.958538] ata2.00: BMDMA stat 0x5
Sep 18 09:28:43 kernel: [ 40.958566] ata2.00: cmd c8/00:00:00:00:00/00:00:00:00:00/e0 tag 0 dma 131072 in
Sep 18 09:28:43 kernel: [ 40.958573] res 51/44:00:00:00:00/00:00:00:00:00/e0 Emask 0x9 (media error)
Sep 18 09:28:43 kernel: [ 40.958586] ata2.00: status: { DRDY ERR }
Sep 18 09:28:43 kernel: [ 40.958596] ata2.00: error: { UNC ABRT }

Changed in linux (Ubuntu):
status: New → Incomplete
Marc Tardif (cr3) wrote :

I received the Aspire One from someone else, and it hasn't been able to install since I received it. However, UNR was installed on the netbook originally, so I suspect it worked at some point.

It'd be good if we could eliminate this being a hw issue before we dig in any further. Do you have an extra drive you could swap in to test with?

Marc Tardif (cr3) wrote :

I do not have an extra drive because the one in the Aspire One uses an old formfactor with a zif socket on the side, whereas most SSD cards nowadays have connectors directly on the card. So, I have ordered a new card at the beginning of the week which should arrive shortly.

Btw it's not a kernel trouble - I've made a vanilla kernel, but ssubj hasn't gone. Strange.
And 9.04 works fine (that's where I'm writing this).
First I decided it's my HDD's problem (I got same errors when it was uncorrectly firmwared), but it's not - Jaunty shows nice performance. Neither update nor my searches had no effect. Dunno what todo =(
P.S.: I got re-firmwared my SSD for a couple of times to make these bugs go-go away, but unsuccessful.
P.P.S.: When I firmware my SSD, the DOS program that make it tells me, that there are 69 bads on it. Guess it may be a reason, if some program tries to access ALL block on the disks. And another thought is that some program (maybe GRUB2 - can anyone check it??) tries to make access to first couple of sectors and - ta da!!
And there's another thing to know: this happens even when gparted is launched. And status message, that is been shown that terrible time is: "Searching disks for partitions". SO, guess, there's the reason. Somewhere there!

Andrew Simpson (andrew-simpson) wrote :

This bug has been marked as a duplicate of bug #445852. However it is not related to bug #445852, because of the following reasons:

- Bug #445852 is caused by a lost interrupt. This bug is being caused by media errors.

- Bug #445852 results in a HSM violation. This bug gives a media error response. Looking at the syslog there are also plenty of other media errors as well.

- Bug #445852 is recovered by soft reset of the drive. This bug can not be recovered as such and the drive has to be hard reset.

- This bug is occurring in the Intel SSD drive originally fitted to the early Acer Aspire One. Bug #445852 has been reported in literally every (!) netbook SSD, other than the Intel SSD (I have an AA1 with an Intel drive too, so I have firsthand experience).

I agree with Andrew Simpson. It's not clear that this is a duplicate of bug #445852.

I have the SSD in question, the SSDPAMM0008G1, with my Acer Aspire One. I first successfully installed UNR 9.04. I then tried to install UNR 9.10, and received hundreds of the errors noted above: DRDY ERR, UNC ABRT, and "media error." From what I can tell, I never received any HSM errors.

I probably tried about a half-dozen times to reinstall 9.10, always failing when it came to partitioning and formatting. I was convinced that my SSD was failing, and I was about to return my netbook to the seller (I just bought it used) and complain about a defective item.

Then, I tried a hint in the other bug about zeroing the disk with dd: dd if=/dev/zero of=/dev/sda bs=1M

After doing that, I reinstalled UNR 9.04, which went without a hitch. I have been using it for about two days since then, and I have not seen a single error like those above in my dmesg.

From my point of view, UNR 9.10 is unusable on this SSD because of this bug. I am also now terrified to upgrade to 9.10 through the package manager, or for that matter to upgrade the kernel or ATA drivers because I worry this bug will reappear. It is particularly nasty because people affected become convinced their SSD is faulty, when it is really not. Smartctl reports my drive has had less than 100 hours of power-on time.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments