no backlight support for laptop (hal depreciation regression)

Reported by Schmirrwurst on 2009-06-10
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Linux
Expired
Medium
Mactel Support
Undecided
Unassigned
X.Org X server
Confirmed
Medium
gnome-power
Invalid
Undecided
Unassigned
nvidia-graphics-drivers-180 (Ubuntu)
Medium
Unassigned
Nominated for Karmic by John Haitas
xorg-server (Ubuntu)
Undecided
Unassigned
Nominated for Karmic by John Haitas

Bug Description

Binary package hint: devicekit-power

A lot of laptop have no backlight (brightness support) because of missing kernel support, and waiting for fix in hal...
In fact, the utility smartdimmer, in main repository, is providing everything need : a get and set method for backlight...

As hal will be depreciated, it would be nice, if it could be fixed in devicekit... and people having vaios, samsung and so could after a couple of years have full power management !

ProblemType: Bug
Architecture: amd64
Date: Wed Jun 10 23:54:32 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia
Package: libdevkit-power-gobject1 008-1
ProcEnviron:
 LANGUAGE=
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
SourcePackage: devicekit-power
Uname: Linux 2.6.30-8-generic x86_64

Schmirrwurst (schmirrwurst) wrote :
John Haitas (jhaitas) wrote :

I can confirm this for Santa Rosa MacBook (MacBook4,1)

summary: - no backlight support for geforce video card >8
+ no backlight support for laptop

This is a hal depreciation regression

summary: - no backlight support for laptop
+ no backlight support for laptop (hal depreciation regression)
Martin Pitt (pitti) on 2009-07-22
affects: devicekit-power (Ubuntu) → gnome-power-manager (Ubuntu)
Changed in gnome-power-manager (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Schmirrwurst (schmirrwurst) wrote :

If this has to be fixed in gnome-power-manager, which package is repsponsible for kde ??
I've seen that the kde power management is still relying on hal-power under karmic....

Schmirrwurst [2009-07-22 17:30 -0000]:
> If this has to be fixed in gnome-power-manager, which package is
> repsponsible for kde ?? I've seen that the kde power management is
> still relying on hal-power under karmic....

Well, it really needs to be fixed in X.org (the XBACKLIGHT extension),
in hal, DevKit, or anywhere else there is simply no way to get it
right (if you consider multi-monitor setups, xrandr configurations,
etc., and also the fact that X.org _also_ controls the backlight in
some way).

Please see
http://lists.freedesktop.org/archives/devkit-devel/2009-July/000268.html

for some details.

Is it the case that Ubuntu 9.10 might not support brightness hot keys
on my laptop? If so, this is a serious regression from Jaunty.

On Wed, Jul 22, 2009 at 1:10 PM, Martin Pitt<email address hidden> wrote:
> Schmirrwurst [2009-07-22 17:30 -0000]:
>> If this has to be fixed in gnome-power-manager, which package is
>> repsponsible for kde ??  I've seen that the kde power management is
>> still relying on hal-power under karmic....
>
> Well, it really needs to be fixed in X.org (the XBACKLIGHT extension),
> in hal, DevKit, or anywhere else there is simply no way to get it
> right (if you consider multi-monitor setups, xrandr configurations,
> etc., and also the fact that X.org _also_ controls the backlight in
> some way).
>
> Please see
> http://lists.freedesktop.org/archives/devkit-devel/2009-July/000268.html
>
> for some details.
>
> --
> no backlight support for laptop (hal depreciation regression)
> https://bugs.launchpad.net/bugs/385723
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
John Haitas
<email address hidden>

Schmirrwurst (schmirrwurst) wrote :

Martin,

I've red the thread you mentioned, and I found out in it, that it should be fixed in xbacklight, but this could take quite a long time... and there is need of a fallback solution !

How many years do people experiencing that problem (on hp, samsung, sony, mac laptop...) are going to wait to have their laptop properly working ? Even Microsoft is shipping a new software, are tell the user they have to wait 2 years until another project close the gap...

I can understand that it is the right way, but how can we get a fallback solution for karmic ???

Martin Pitt (pitti) wrote :

Adding xorg task, where the support should land according to David Zeuten, Richard Hughes, and Kay Sievers (see http://lists.freedesktop.org/archives/devkit-devel/2009-July/000268.html). Once xbacklight covers these platforms, g-p-m/KDE etc. should "just work".

affects: xorg (Ubuntu) → xorg-server (Ubuntu)
Changed in xorg-server (Ubuntu):
status: New → Triaged
Martin Pitt (pitti) wrote :

The hal support for smartdimmer isn't going away anytime soon, so for these platforms it's perhaps possible to add back the gnome-power-manager support for it. That's why there is a gnome-power-manager task here.

But I see no chance of devkit-power ever getting support for smartdimmer. The entire idea of smartdimmer is a hack, device drivers belong into kernel just as any other backlight interface the kernel offers. If X.org merges the smartdimmer logic in its xbacklight support, that's fine of course.

This shouldn't affect KDE at all at the moment. KDE 4 uses hal.

I've a sony vaio with geforce 8400M GT, and I've no support for backlight, no laptop_panel in hal, no entry in /sys/class/backlight

I've reported the bug in hal, in devicekit, in kernel, by nvidia...

In fact, a lot of people are affected with this problem on laptops from hp, samsung, sony and mac.

-Hal is deprieciated
-devicekit won't fix some device specific issue
-nvidia is not supporting backlight, as every manufaturer is managing it differently
-kernel team is not reacting

I'm waiting already 2 years for a solution ! I hope to have it fixed for karmic, if not, we all are to wait 6 other month !

Martin Pitt (hal/devicekit developper) said he could make it work if xorg could fix it in xbacklight...
There is already the utility smartdimmer (or nvclock) that is able to set or get backlight, it could be possible to use that code...

As written on http://lists.freedesktop.org/archives/devkit-devel/2009-July/000268.html, https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/385723/comments/5, https://bugs.launchpad.net/ubuntu/+source/gnome-power-manager/+bug/385723/comments/9, this is not really a gnome-power-manager problem really.

The entire idea of smartdimmer is a hack, device drivers belong into kernel just as any other backlight interface the kernel offers. If X.org merges the smartdimmer logic in its xbacklight support, that's fine of course.

The hal support for smartdimmer isn't going away anytime soon, so for these platforms it's perhaps possible to add back the gnome-power-manager support for it. (We could use this bug for tracking that.)

Note that the smartdimmer addition to hal itself is also an Ubuntuism and was rejected upstream for similar reasons (http://lists.freedesktop.org/pipermail/hal/2009-January/012859.html, should go into the kernel).

Oops, sorry, this was linked from a g-p-m Ubuntu bug, so I saw too late that this is actually filed against X.org, so my previous comment is not entirely relevant. Sorry for the confusion.

This is not a bug in xbacklight, but in the nVidia driver.

Do xbacklight needs to have the nvidia driver in use to work ? is it communicating through the driver ?

I know from nvidia that they won't support backlight in the driver because the manufacturer are managing backlight differently...
(if it is another issue, do it has been reported somewhere by nvidia ?)

smartdimmer and nvclock are working even without having the driver installed. Could it be possible to change xbacklight the same way for the nvidia cards that are making problems ?

Martin Pitt (pitti) on 2009-07-23
Changed in gnome-power:
importance: Unknown → Undecided
status: Unknown → New
Schmirrwurst (schmirrwurst) wrote :

Martin, I'm not sure to have understood everything :

You said "hal support for smartdimmer isn't going away anytime soon", but for me hal never manage to get my backlight to work, In one bug report in LP, I know a change has been made for nvidia user, to use smartdimmer, but this is not working for user that do not have laptop_panel in lshal.. like me
That's why I opened that bug report :
https://bugs.launchpad.net/hal/+bug/345531

If hal would be fixed, it would mean that everything could be fine under gnome and kde ?

How fast could it be to make hal work without laptop_panel ?

I've already opened a bug for xbacklight... (and still nothing from kernel team)

Changed in linux:
status: Unknown → Incomplete
Changed in xorg-server:
status: Unknown → Confirmed
Martin Pitt (pitti) wrote :

> You said "hal support for smartdimmer isn't going away anytime soon", but for me hal never manage to get my
> backlight to work,

Ah, right, I remember. That was a different bug then.

affects: gnome-power-manager (Ubuntu) → nvidia-graphics-drivers-180 (Ubuntu)
Martin Pitt (pitti) wrote :

So it's not a smartdimmer problem; X.org upstream says it's a bug in the nvidia driver.

Changed in xorg-server (Ubuntu):
status: Triaged → Invalid
Changed in gnome-power:
status: New → Invalid
Schmirrwurst (schmirrwurst) wrote :

smartdimmer/nvclock work also without having the nvidia driver installed ! So I think it could be fixed in hal anyway...

I don't know if xbacklight needs to have the nvidia driver in use, perhaps that's why they said it is a nvidia driver issue...

John Haitas (jhaitas) wrote :

I am experiencing this problem with an Intel chipset.... the nvidia driver can't be the issue...

Changed in xorg-server:
status: Confirmed → Invalid

Then changing product from xrandr to dirver/nvidia...

Changed in xorg-server:
status: Invalid → Confirmed
Bryce Harrington (bryce) on 2009-08-13
tags: added: karmic
John Haitas (jhaitas) wrote :

This is still a problem as of Karmic Beta 1 ...

I am inclined to open a new bug as this one has received little attention...

Guillaume (guillaume-zin) wrote :

Hello,

I wrote a driver for the nVidia backlight, see here: http://www.nvnews.net/vbulletin/showthread.php?t=143025

Guillaume

John Haitas (jhaitas) wrote :

Installing the 'pommed' package fixed this for me on my MacBook 4,1

Robert Hooker (sarvatt) wrote :

Can you try adding this line:

Option "RegistryDwords" "EnableBrightnessControl=1"

to your /etc/X11/xorg.conf at the bottom of the device section?

Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Triaged → Incomplete
Mario Schwalbe (schwalbe) wrote :

@Robert Hooker: Unfortunately the option doesn't work on my machine (MacBook Pro 4,1).

However, there's a kernel driver available since early 2009 in the Mactel repository (https://launchpad.net/~mactel-support/+archive/ppa/+packages), that isn't specific to Apple machines and is known to work on my machines (might not auto-load). Also works on Lucid and can be used with pommed as well.

Schmirrwurst (schmirrwurst) wrote :

Doesn't work for me either

Mario Schwalbe (schwalbe) wrote :

@Schmirrwurst: What doesn't work on your machine? The suggested option (EnableBrightnessControl) or the suggested driver (nvidia_bl) ?

John Haitas (jhaitas) wrote :

One workaround (until this is fixed) is to install 'pommed'

sudo apt-get install pommed

Architecture: amd64
DistroRelease: Ubuntu 10.04
DkmsStatus:
 virtualbox-ose, 3.1.4, 2.6.32-17-generic, x86_64: installed
 virtualbox-ose, 3.1.4, 2.6.32-16-generic, x86_64: installed
 bcmwl, 5.60.48.36+bdcom, 2.6.32-17-generic, x86_64: installed
 bcmwl, 5.60.48.36+bdcom, 2.6.32-16-generic, x86_64: installed
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
MachineType: Apple Inc. MacBook4,1
NonfreeKernelModules: wl
Package: nvidia-graphics-drivers-180 (not installed)
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.32-17-generic root=UUID=2c01ea54-354b-4561-840b-f369f979feb0 ro quiet splash
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-17.26-generic 2.6.32.10+drm33.1
Tags: lucid lucid
Uname: Linux 2.6.32-17-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 02/09/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB41.88Z.00C1.B00.0802091535
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F22788A9
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 2
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22788A9
dmi.modalias: dmi:bvnAppleInc.:bvrMB41.88Z.00C1.B00.0802091535:bd02/09/08:svnAppleInc.:pnMacBook4,1:pvr1.0:rvnAppleInc.:rnMac-F22788A9:rvrPVT:cvnAppleInc.:ct2:cvrMac-F22788A9:
dmi.product.name: MacBook4,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
glxinfo: Error: [Errno 2] No such file or directory
system:
 distro: Ubuntu
 codename: lucid
 architecture: x86_64
 kernel: 2.6.32-17-generic

tags: added: apport-collected

apport information

apport information

apport information

Mario Schwalbe (schwalbe) wrote :

@John Haitas: Maybe I should clarify a few things.

(1) The original bug report mentions smartdimmer, Nvidia, and Geforce. Thus, the bug seems to be related to Nvidia graphics. The driver nvidia_bl in the mactel repository, which isn't specific to Apple machines, it is just there, might help. As well as the mentioned X.org option (EnableBrightnessControl) which is to be used with the Nvidia proprietary graphics driver.

(2) Your machine (MacBook4,1) incorporates an Intel graphics adapter. So the suggestions obviously won't help. (And pommed isn't necessary, but useful anyway.) For your machine, you might try mbp_nvidia_bl instead. This one is Apple-specific, but despite its name not restricted to MacBook Pros. Afaik, the upstream version (and thus, karmic and lucid) doesn't support your machine yet, but my patches have been accepted recently, so it might work when lucid gets released. In the meantime you might try the patched version in present the mactel PPA.

(3) Finally, what's this report about? Nvidia? Intel? ATI? Device Kit?

ciao,
Mario

Schmirrwurst (schmirrwurst) wrote :

For me on sony fz, EnableBrightnessControl isn't working with the glx drivers...
The nvidia_bl isn't working for me (I tried karmic version, there is no lucid one), and in the description, it is supposed to support only NV40 and <, not NV50 like my geforce 8...

The report is about missing backlight support in ubuntu for nvidia glx. Nvidia won't do anything, hal either, so that ubuntu users are missing backlight control since 5 years, and there is no real solution for the moment...

Smartdimmer is now able to set and get backlight information for those cards, but is not yet used by ubuntu for backlight management. a nvidia_bl module is probably the right way, because devicekit is rejecting the idea to write a specific code to use smartdimmer for nvidia hw... But I think if on the side from ubuntu nothing is to be done, than ubuntu users will have to live without backlight support for again 5 years or more... and quite a lot of notebooks are shiped with nv hw.... not only mac but also sony, samsung, dell, acer...

John Haitas (jhaitas) wrote :

@Mario Schwalbe

I hopped on this bug thinking it regarded laptop hot keys.

The workaround on my MacBook4,1 is to install the 'pommed' package.

Seems as if I should file a new bug specific to Apple hardware - as 'pommed' is the fix.

Schmirrwurst (schmirrwurst) wrote :

The module written by Guillaume is working for me :
https://bugs.launchpad.net/linux/+bug/385723/comments/16

How could we integrate it to ubuntu, in order to have it working out of the box, when installing ubuntu ?

Mario Schwalbe (schwalbe) wrote :

@Schmirrwurst: This wasn't Guillaume, but me. Apart from his changes, the upstream version is in the Mactel prepository (https://launchpad.net/~mactel-support/+archive/ppa/+packages) package nvidia-bl-dkms. Or does it not work for you. If it doesn't, please report the problem.

Konstantin Maslov (conma) wrote :

@Mario Schwalbe: nvidia-bl-dkms 0.16.7 for lucid works for my sony vaio vgn-fz11sr.

On fresh Lucid. Just install the package, add line "nvidia-bl max_level=1026" to /etc/modules and reboot. Does not work properly without parameter on my laptop. Parameters values that work are from 1024 to 1029 or so...

Just one thing more, I can not set full backlight with hotkeys (Fn+F5/F6), always one step lower. If I press BrightnessUp key many many times Smartdimmer still shows 95, the maximum is 100, "cat /sys/class/backlight/bla-bla-bla" is one step lower the maximum too. All other backlight functions work just fine.

The problem on VAIOs is that there is no laptop_panel device in hal with proprietary nvidia driver. There are some scripts to manage backlight through Smartdimmer on VAIOs and Smartdimmer works fine in latest Ubuntu distros. But these scripts do not work because hal does not recognize laptop_panel device.

Backlight management works fine with nouveau driver but this driver has no 3D acceleration yet.

Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in linux:
importance: Unknown → Medium
Changed in xorg-server:
importance: Unknown → Medium
Bryce Harrington (bryce) on 2012-02-04
Changed in nvidia-graphics-drivers-180 (Ubuntu):
status: Incomplete → Confirmed
Changed in linux:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.