i8042 error - keyboard does not work (kernel patch provided)

Bug #31879 reported by dave_rodgman on 2006-02-18
10
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux-source-2.6.15 (Ubuntu)
Medium
Unassigned

Bug Description

On bootup, the keyboard doesn't work - I get the following error message immediately after "decompressing kernel"

i8042.c: Can't read CTR while initializing i8042.

After that, I have no (regular, not usb) keyboard. This problem is discussed here - apparently something to do with legacy USB support in the BIOS.

http://<email address hidden>/567230.html

I've tried many boot options, including - nosmp, usb-handoff, acpi=off, and all the i8042.xxx ones. None of them help (usb-handoff is said to work, but is unsupported in the latest dapper kernel). Reverting to kernel 2.6.12 fixes it. Also tried fiddling with USB options in the BIOS. Disabling USB works, but obviously it kills my mouse.

Hardware: 2xAthlon 2800 on GA7ZNMH motherboard, non-usb keyboard.

The following patch works for me:

--- linux-2.6.15/drivers/usb/host/pci-quirks.c 2006-01-14 20:45:29.000000000 +0000
+++ linux-2.6.15-keyboard-patch/drivers/usb/host/pci-quirks.c 2006-01-14 22:02:14.000000000 +0000
@@ -172,6 +172,7 @@

 static void __devinit quirk_usb_handoff_ohci(struct pci_dev *pdev)
 {
+#ifdef COMMENTTHISREGIONOUTTOENABLEKEYBOARD
        void __iomem *base;
        int wait_time;
        u32 control;
@@ -212,6 +213,7 @@
        writel(~(u32)0, base + OHCI_INTRSTATUS);

        iounmap(base);
+#endif
 }

 static void __devinit quirk_usb_disable_ehci(struct pci_dev *pdev)

Changed in linux-meta:
status: Unconfirmed → Fix Committed
Changed in linux-source-2.6.15:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers