[hardy] iwl3945/iwl4965 + wpasupplicant fails to connect to university network. regression from gutsy (ipw3945+wpasupplicant)

Reported by ubuntu_demon on 2008-04-22
34
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
High
linux (Ubuntu)
Undecided
Unassigned
Nominated for Hardy by apolloFER

Bug Description

[hardy] iwl3945/iwl4965 + wpasupplicant fails to connect to university network. regression from gutsy (ipw3945+wpasupplicant) which worked fine.

wpa_supplicant.conf :

network={
ssid="MAASnet"
key_mgmt=IEEE8021X
wep_key0=67521641120849428492308341
phase2="auth=MSCHAPV2"
identity="" #fill in
password="" #fill in
}

Here's a part of the output from running ""sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i wlan0 -D wext -d"" which might be relevant :

EAPOL: Setting dynamic WEP key: unicast keyidx 3 len 13
wpa_driver_wext_set_key: alg=1 key_idx=3 set_tx=128 seq_len=0 key_len=13
ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
EAPOL: Failed to set WEP key to the driver.

I'ts probably not a microcode error because I followed :
http://www.intellinuxwireless.org/?n=fw_error_report and I'm not seeing "Microcode SW error detected" in my dmesg.

People with similar issues (my university uses different network settings and I'm getting different error messages) :
https://bugs.launchpad.net/linux/+bug/209920
https://bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/199275/
https://bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/207446
http://brainstorm.ubuntu.com/idea/6281/
http://ubuntuforums.org/showpost.php?p=4695238&postcount=14
http://ubuntuforums.org/showpost.php?p=4754224&postcount=15
http://ubuntuforums.org/showthread.php?t=753200
http://ubuntuforums.org/showpost.php?p=4747104&postcount=4

Similar but different upstream bugs (my university uses different network settings and I'm getting different error messages) :
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1507
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1522

upstream bug with similar error messages (ioctl[SIOCSIWENCODEEXT]: Invalid argument) but different network settings :
http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1339

I've seen the same problem (not being able to connect to this particular network) with iwl4965 (laptop of someone else).

ubuntu_demon (ubuntu-demon) wrote :
ubuntu_demon (ubuntu-demon) wrote :
ubuntu_demon (ubuntu-demon) wrote :
ubuntu_demon (ubuntu-demon) wrote :

I made a small mistake. I referred to my wireless interface as eth1 (which it was called in gutsy using ipw3945) but it's now called wlan0 in hardy.

instead of :
"sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i eth1 -D wext -d"

I ran :
"sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i wlan0 -D wext -d"

description: updated
description: updated
description: updated
description: updated
description: updated
description: updated
ubuntu_demon (ubuntu-demon) wrote :
description: updated
description: updated
description: updated
description: updated
description: updated
ubuntu_demon (ubuntu-demon) wrote :

I got different errors including :
ioctl[SIOCSIWSCAN] Device or resource busy
when I tried the following :

sudo modprobe -r iwl3945
create a file name iwl3945 in /etc/modprobe.d/ with :
========
alias wlan0 iwl3945
options iwl3945 disable_hw_scan=1
========
sudo modprobe iwl3945

taken from http://ubuntuforums.org/showthread.php?t=733054

ubuntu_demon (ubuntu-demon) wrote :

I installed linux-backport-modules-hardy-generic and now I also have led_class as a module but it didn't solve the problem.

Changed in linux:
status: Unknown → Confirmed
ubuntu_demon (ubuntu-demon) wrote :

More output of : sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i wlan0 -D wext -dd

After trying
sudo modprobe -r iwl3945 ; sudo modprobe iwl3945 disable_hw_scan=1

Notice that there's different errors then when not using "disable_hw_scan=1"

ubuntu_demon (ubuntu-demon) wrote :

The network I'm trying to connect to isn't hidden.

If I try booting from the livecd, pressing F6 and typing iwl3945.disable_hw_scan=1 at the end of the line I'm getting something like :
"unknow boot option ....... ignoring"

Matt Zimmerman (mdz) wrote :

Does it work if you use network-manager as a frontend for wpasupplicant?

ubuntu_demon (ubuntu-demon) wrote :

What about including the ipw3945 module in Ubuntu as an option ? It's possible see : http://james.colannino.org/downloads.html

ubuntu_demon (ubuntu-demon) wrote :

After a reboot and using
sudo modprobe -r iwl3945 ; sudo modprobe iwl3945 disable_hw_scan=1

I'm seeing both errors in one run :

ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWSCAN] Device or resource busy

ubuntu_demon (ubuntu-demon) wrote :

I couldn't get Hardy's network manager to connect to my university's wireless network (or I haven't been able to figure out the correct settings for network-manager).

I have always used wpasupplicant to connect to my university's network because networkmanager couldn't connect to it in Edgy.

I'm currently in #ubuntu-kernel

ubuntu_demon (ubuntu-demon) wrote :

having linux-backport-modules-hardy-generic installed and modprobing iwl3945 gives me the following srcversion.

sudo modinfo iwl3945 | grep srcversion gives :
srcversion: FDE2E62843DE3ED112A50C3

description: updated

I can confirm ubuntu_demon's findings

Changed in linux:
status: New → Confirmed
tkahn6 (tkahn6) wrote :

This is a necessity.

MSCHAPV2 with OPEN Algorithm security is widely used on college campuses and businesses.

Poor support for these specific settings keep me and others from spreading Ubuntu to other potential users.

I second the idea that ipw3945 drivers be an option if detected on the system.

On the forums, it has been observed that this is an important issue and should be given a high status of importance.

Thanks Ubuntu Devs! Congrats on another successful release!

ubuntu_demon (ubuntu-demon) wrote :

Maybe it's good to know that I helped maastaliwatschu to connect to our university's network. He used the same wpasupplicant.conf as I did which worked fine in Gutsy but not for Hardy. He also has an intel 3945 wireless chipset. The modinfo of iwl3945 he submitted is after installing the newest iwl3945 from linux-backport-modules-hardy-generic. Both using the standard iwl3945 and the newer one from linux-backport-modules-hardy-generic he got the same errors I did :

ioctl[SIOCSIWENCODEEXT]: Invalid argument
Driver did not support SIOCSIWENCODEEXT
EAPOL: Failed to set WEP key to the driver.

description: updated
Yong Wang (yong-y-wang) wrote :

Dear Tyler, could you pls run "modprobe iwl3945 debug=0x43fff" and post your dmesg output when connecting to MSCHAPV2 with OPEN Algorithm security? If so, it will be of great help.

description: updated
ubuntu_demon (ubuntu-demon) wrote :

I can use a wpa2 network with wpasupplicant using the hardy live cd (iwl3945+wpasupplicant). But I can't connect to this mschapv2 university network.

Jaco (jacotb) wrote :

I got ipw3945 to work on the 2.6.24 kernel using this patch: http://james.colannino.org/downloads.html

ubuntu_demon (ubuntu-demon) wrote :

I got my university's wireless network to work with windows intel 3945 driver + ndiswrapper + wpasupplicant (same settings)+wext. So it's definitely a bug in iwl3945.

Yann (lostec) wrote :

iwl driver does not show as mature as previous ipw driver. It would be nice, for a LTS, to add the possibility of using "old" but good ipw driver in restricted drivers manager.

iwl driver have poor sensibility (lots of ap's seen in windows laptop at the same place not seen in Hardy, 98% signal strenght versus 80% close to the AP and so on).

iwl does not suspend correctly (hangs just after disabling PCI irq for 3945 ABG device... just before syncing disks: Bad for FS).

Anyway, Hardy is a real deception comming from Dapper: Eye candy, but lot of little problems for a LTS version due to the integration of non mature elements (iwl, but also pulseaudio...).

I hope fixes soon indeed... or I'll leave ubuntu after more thant 2 years.

Changed in linux:
status: Confirmed → In Progress
ubuntu_demon (ubuntu-demon) wrote :

I've seen the same problem (not being able to connect to this particular network) with iwl4965 (laptop of someone else).

description: updated
description: updated
Alberto (apedraza) wrote :

Same problem on an HP 8710w system. Trying to connet to a corporate WPA2/EAP TLS network using certficates used to work on gutsy.. Now, it is very difficult to make it work. The driver is very flaky. I connect to the same network from an older laptop that uses an IBM card and I have no problems.

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

I just tried the liveCD of the Intrepid Alpha 5. No joy, Leap still does not work.
The error messages are a bit different, though - dmesg reports 'authenticating' *3, then I get an authentication timed out message (sorry, no log to post here).

Earlier dmesg looked like:

[ 181.688106] wlan0: RX authentication from 00:11:92:5a:d4:90 (alg=128 transaction=2 status=13)
[ 181.688113] wlan0: AP denied authentication (auth_alg=128 code=13)

Changed in linux:
status: In Progress → Invalid
smeashy (smeashy) on 2008-10-01
Changed in linux:
status: Invalid → Unknown
Changed in linux:
status: Unknown → In Progress
Alberto (apedraza) wrote :

Its the drivers... I had the same problem until I downloaded and compiled an updated driver from intellinuxwireless.org

After that, I can connect without any problems to a WPA2 EAP TLS network. Before I did this, it was really difficult to connect to this network.

apolloFER (apollofer) wrote :

It's the same here... iwl won't connect to 802.1X wireless (also University). I had to inject ipw3945 driver so I could have full wireless functionality. iwl3945 is still very buggy and not good enough to be used as the only driver. It would be nice if ipw could be added to Intrepid as a restricted driver or something similar.

DoDoENT (dodoentertainment) wrote :

ApolloFER, please download the intrepid beta, and try connecting to FERwlan from the live session. Some have reported that connection works (although lousy) by user-compiling the latest compat-wireless drivers on hardy. These should be included in 2.6.27 kernel in intrepid.

I'd like to add a note that the Ubuntu kernel team is working on a backport right now to provide an updated wireless stack (iwlwifi included) for Intrepid. It would be good to watch for this and test when available for those testing Intrepid and still having issues. Thanks.

DoDoENT (dodoentertainment) wrote :
Download full text (7.7 KiB)

After the applying the latest update of backport modules, my laptop lost the ability to resume correctly from suspend after being suspended with WLAN turned on. After resume, I see the desktop, I can move the mouse and open the menus, but whenever I start any of the programs (even if I try to open the folder), nothing happens. Network manager also cannot connect to my WLAN after resume. By pressing the ctrl+alt+f1 and logging to the tty and trying to kill the gdm (or anything else), console freezes on "sudo" command. By pressing the ctrl+alt+backspace in desktop, X cannot start anymore (computer freezes) - then I have to do a hard reboot. Now I'll try to delete the package from my system and I'll notify you if the issue gets fixed.

Here is the changelog of the last update of bacport-modules:

linux-backports-modules-2.6.24 (2.6.24-21.27) hardy-proposed; urgency=low

  [Tim Gardner]

  * Update to use compat-wireless-2.6-old
  * iwlwifi backport from Intel
  * Fix symbol collision issues with the iwlwifi backport
  * Fix compat-wireless build warnings.
  * Add LUM header dependencies.
  * Updated to compat-wireless-old cd7615b4e5ad9793c20fb19cdd4e7525e9dd07b7
  * Munge the ucode file names used by the iwlwifi drivers.
  * Disable IWL modules in compat-wireless, use Intel's backported drivers instead
    since the versions in compat-wireless don't work with NetworkManager.
    Should also fix suspend crash.
    - LP: #251252

 -- Tim Gardner <email address hidden> Tue, 09 Sep 2008 08:26:34 -0600

linux-backports-modules-2.6.24 (2.6.24-21.26) hardy-proposed; urgency=low

  [Stefan Bader]

  * Add backported wacom driver (v1.48)
    - LP: #218087
  * Improve printchanges target

 -- Stefan Bader <email address hidden> Mon, 18 Aug 2008 16:53:32 -0400

linux-backports-modules-2.6.24 (2.6.24-21.25) hardy-proposed; urgency=low

  [Tim Gardner]

  * Backport b44 ethernet since it depends on ssb
    - LP: #251538

 -- Tim Gardner <email address hidden> Fri, 15 Aug 2008 08:55:21 -0600

linux-backports-modules-2.6.24 (2.6.24-21.24) hardy-proposed; urgency=low

  [Tim Gardner]

  * Use a macro for the wireless-testing git tree tag.
  * Update compat-wireless to master-2008-07-28
  * Added iwlwifi-5000-ucode

 -- Tim Gardner <email address hidden> Mon, 11 Aug 2008 21:11:36 -0600

linux-backports-modules-2.6.24 (2.6.24-20.23) hardy-proposed; urgency=low

  [Upstream Kernel Changes]

  * Update Apple mutli-touch to 0.58, fixes some
    initialization issues.
    Bug: #250838

 -- Tim Gardner <email address hidden> Sun, 03 Aug 2008 23:41:57 -0600

linux-backports-modules-2.6.24 (2.6.24-20.22) hardy-proposed; urgency=low

  [Tim Gardner]

  * Fix i4965 firmware name (forgot the '-lbm' on the end of the name)

 -- Tim Gardner <email address hidden> Sun, 03 Aug 2008 23:25:09 -0600

linux-backports-modules-2.6.24 (2.6.24-20.21) hardy-proposed; urgency=low

  [Tim Gardner]

  * Munged compat-wireless symbols and module names so as not to conflict with
    kernel/lum package symbols.
    Synced compat-wireless to master-2008-07-28
    - LP: #252630

 -- Tim Gardner <email address hidden> Tue, 29 Jul 2008 14:44:50 -...

Read more...

DoDoENT (dodoentertainment) wrote :

I've deleted the linux-backports-modules-2.6.24 package, and resume from suspend now works again, although Network manager requires more than 30 seconds to detect that the WLAN is present in the system and initialize the connection. ipw3945 took less to do the same thing...

For those running Intrepid, please try installing the linux-backports-modules-intrepid package as it most recently pulled in an updated version of the compat-wireless stack:

https://edge.launchpad.net/ubuntu/+source/linux-backports-modules-2.6.27

linux-backports-modules-2.6.27 (2.6.27-7.3) intrepid; urgency=low

  [Tim Gardner]

  * Added iwlwifi firmware
  * Added the upstream compat-wireless-2.6 tree.
  * Updated compat-wireless to wireless-testing tag master-2008-10-14
  * Set CONFIG_WIRELESS_OLD_REGULATORY=y by default.

Changed in linux:
status: In Progress → Fix Released
Amit Kucheria (amitk) wrote :

This bug report is being closed because we received no response to the previous inquiry for information. Please reopen if this is still an issue in the current Ubuntu release, Jaunty Jackalope 9.04 - http://www.ubuntu.com/getubuntu/download. If the issue remains in Jaunty, please test the latest upstream kernel build - https://wiki.ubuntu.com/KernelMainlineBuilds . To reopen the bug, click on the current status under the Status column and change the status back to "New". Thanks.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
status: Incomplete → Won't Fix
Changed in linux (Ubuntu):
status: Won't Fix → Incomplete

Since the iwl3945 driver does not offer the same functionality as the (depreciated) ipw3945, please explain why this is marked as 'won't fix'

Download full text (3.1 KiB)

Because the issue was fixed in Intrepid as far as I know (at least for me,
newer versions of iwl work without any issues). It was marked as "Fix
Released" some 6 months ago in May. Then someone changed it to "Won't Fix"
without any reason.

On Tue, Nov 24, 2009 at 11:10 PM, Duncan Lithgow
<email address hidden>wrote:

> Since the iwl3945 driver does not offer the same functionality as the
> (depreciated) ipw3945, please explain why this is marked as 'won't fix'
>
> --
> [hardy] iwl3945/iwl4965 + wpasupplicant fails to connect to university
> network. regression from gutsy (ipw3945+wpasupplicant)
> https://bugs.launchpad.net/bugs/220640
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in The Linux Kernel: Fix Released
> Status in “linux” package in Ubuntu: Incomplete
>
> Bug description:
> [hardy] iwl3945/iwl4965 + wpasupplicant fails to connect to university
> network. regression from gutsy (ipw3945+wpasupplicant) which worked fine.
>
> wpa_supplicant.conf :
>
> network={
> ssid="MAASnet"
> key_mgmt=IEEE8021X
> wep_key0=67521641120849428492308341
> phase2="auth=MSCHAPV2"
> identity="" #fill in
> password="" #fill in
> }
>
> Here's a part of the output from running ""sudo wpa_supplicant
> -c/etc/wpa_supplicant/wpa_supplicant.conf -i wlan0 -D wext -d"" which might
> be relevant :
>
> EAPOL: Setting dynamic WEP key: unicast keyidx 3 len 13
> wpa_driver_wext_set_key: alg=1 key_idx=3 set_tx=128 seq_len=0 key_len=13
> ioctl[SIOCSIWENCODEEXT]: Invalid argument
> Driver did not support SIOCSIWENCODEEXT
> EAPOL: Failed to set WEP key to the driver.
>
> I'ts probably not a microcode error because I followed :
> http://www.intellinuxwireless.org/?n=fw_error_report and I'm not seeing
> "Microcode SW error detected" in my dmesg.
>
> People with similar issues (my university uses different network settings
> and I'm getting different error messages) :
> https://bugs.launchpad.net/linux/+bug/209920
> https://bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/199275/
> https://bugs.launchpad.net/ubuntu/+source/wpasupplicant/+bug/207446
> http://brainstorm.ubuntu.com/idea/6281/
> http://ubuntuforums.org/showpost.php?p=4695238&postcount=14
> http://ubuntuforums.org/showpost.php?p=4754224&postcount=15
> http://ubuntuforums.org/showthread.php?t=753200
> http://ubuntuforums.org/showpost.php?p=4747104&postcount=4
>
> Similar but different upstream bugs (my university uses different network
> settings and I'm getting different error messages) :
> http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1507
> http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1522
>
> upstream bug with similar error messages (ioctl[SIOCSIWENCODEEXT]: Invalid
> argument) but different network settings :
> http://www.intellinuxwireless.org/bugzilla/show_bug.cgi?id=1339
>
> I've seen the same problem (not being able to connect to this particular
> network) with iwl4965 (laptop of someone else).
>
>

--
Darko Ronić, univ. bacc. ing. comp.
Master Student, Computer Engineering
Faculty of Electrotechnic Engineering and Computing; Zagreb; Croatia
Mobile: +38598876963
E-mail: <email address hidden>
Web: http://www.kabuuum.ne...

Read more...

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux:
importance: Unknown → High
To post a comment you must log in.