System clock runs far too fast

Bug #17589 reported by Crispin Flowerday on 2005-05-29
86
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Baltix
Medium
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

I have a problem where my clock runs fast, I believe that it may be a kernel
2.6.10 problem, there are other similar reports at:

http://kerneltrap.org/node/4872
http://ubuntuforums.org/showthread.php?t=13197

Basically my clock gets over 2 minutes out over the day. There is nothing in the
syslog related to ntp after about 5 minutes from bootup.

(This maybe a kernel issue, but shouldn't ntp still keep the clock in sync ?)

I'm using hoary, with an nvidia nforce2 m'board

Matt Zimmerman (mdz) wrote :

ntpd can only compensate for a certain amount of drift (500 PPM I believe). I
have a system which is in a similar situation, and the problem needs to be
corrected at a lower level (getting the clock running at the proper frequency)
rather than by updating the clock more aggressively.

In my case, the hardware in question is a Soekris net4501:
http://www.soekris.com/net4501.htm

Chuck Short (zulcss) wrote :

Have you tried booting with apic=off as a boot parameter?

Matt Zimmerman (mdz) wrote :

I haven't. My test system is a 486; do they even have APICs?

Turning off APIC doesn't seem to help, my system is 5 seconds fast in about an
hour of uptime, and looking at the ntp logs, it has already corrected about 10
seconds of drift.

Matt Zimmerman (mdz) wrote :

*** Bug 19285 has been marked as a duplicate of this bug. ***

Chris Gilbert (disciple3d) wrote :

I have similar problem on an Acer Aspire 5021 laptop. In my case, the clock is
more than twice the speed, and it now thinks it's Friday :) This is worsened
because the ntpd is unable to sync the clock properly as well. I managed to fix
both problems by using the noapictimer kernel parameter. This occurs for me
both in Hoary and Breezy preview release though, using Kernels 2.6.10-5, 2.6.11
and 2.6.12-8 - whatever is causing it, it seems to be hanging on in there..

I have the same problem. I had Hoary running happy with no_timer_check as a
kernel option, and when I slashed, burned, and switched to Breezy, the problem
was back. Only this time, while any one of noapictimer, no_timer_check, or
noapic fixes the problem, they all cause my network to work only sporadically.

Not to be too spammy, but I think the double clock speed bug is a separate one
from this bug ID. This bug is showing system clock gaining minutes over a few
hours, while Chris Gilbert and myself are seeing the system clock running
literally twice as fast as it should. This seems to be associated with the 50%
CPU utilization at idle, too.

HPzv6130us laptop
AMD64
Tried both 2.6.12-i386 and k7; same behavior.

Michael Lynch (symgeosis) wrote :

I agree. The 2X clock issue seems related specifically to AMD hardware with ATI
graphics. (though I may be wrong)
A couple of seconds here and there seems entirely different than the clock
running twice as fast.

I had created a seperate bug report for the 2X clock issue though it was marked
as a duplicate of this one.

co (christopher-owen) wrote :

I am also having a 2x clock issue. My hardware is also amd64 but with an nvidia
graphics card.

(compaq presario SR1440UK)

Matt Zimmerman (mdz) wrote :

*** Bug 24116 has been marked as a duplicate of this bug. ***

Christian Borup (borup+ubuntu) wrote :

I'm also seeing double speed system clock.
hwclock does not seem to drift.

My system is:
  HP Pavilion a1018.dk
  amd64 3200+ 2.0 GHz
  nVidia GeForce 6200 graphics card

I'm using a 2.6.12-9-386 kernel, but the clock also seem to drift with a amd64
kernel.

Ben Collins (ben-collins) wrote :

This bug has been flagged because it is old and possibly inactive. It may or may
not be fixed in the latest release (Breezy Badger 5.10). It is being marked as
"NEEDSINFO". In two weeks time, if the bug is not updated back to "NEW" and
validated against Breezy, it will be closed.

This is needed in order to help manage the current bug list for the kernel. We
would like to fix all bugs, but need users to test and help with debugging.

If this change was in error for this bug, please respond and make the
appropriate change (or email <email address hidden> if you cannot make the
change).

Thanks for your help.

I still get this problem on my desktop machine with breezy

Christian Borup (borup+ubuntu) wrote :

I can confirm that the double speed system clock is still present om my amd64
box running Breezy.

I can also confirm this is Breezy on my laptop, see
https://wiki.ubuntu.com/LaptopTestingTeam/CompaqPresarioM2000 for info.

Note, that my problem is not double speed of the clock, I get approximately 5
minutes drift over the course of a day.

Ben Collins (ben-collins) wrote :

If possible, please upgrade to Dapper's 2.6.15-7 kernel. If you do not want to
upgrade to Dapper, then you can also wait for the Dapper Flight 2 CD's, which
are due out within the next few days.

Let me know if this bug still exists with this kernel.

I upgraded to Dapper and still get the same problems, being the time, music,
movies etc all running way too fast. I'm running the dapper 2.6.15-7-386 #1
PREEMPT Tue Dec 6 17:28:05 UTC 2005 i686 GNU/Linux kernel, if I pass noapic at
boot time the issue seems to go away.

I can confirm that on my system with 2.6.15-8-k7 the clock is still too fast, my
machine has bee up 2 hours 40 (and synced with ntpdate at startup), and despite
ntp running, is now 35 seconds fast.

I think there are actually 2 separate bugs here, mine which is the clock going
only a bit too fast, and another which causes it to go double speed, perhaps the
cases should be split out ?

Michael Lynch (symgeosis) wrote :

The double speed clock issue can be fixed with a proper BIOS upgrade. However
not all manufacturers have released the proper upgrades (and some might never).
Technically this isn't a kernel bug but a BIOS bug. Windows works, in all
liklihood, because of custom patches that have been applied to compensate for
this problem.

Chuck Short (zulcss) wrote :

I have a possible fix in my git archive.

Chuck, if you want me to test it, I'm more than happy to patch a kernel and test
it (dapper).

Chuck Short (zulcss) wrote :

Sure which flavour are you using?

chuck

I'm currently using 2.6.15-10-k7

Chuck Short (zulcss) wrote :

Crispin,

Ill build a kernel for you tonight and email you the location of the build.

Thanks
chuck

Chuck Short (zulcss) wrote :

Crispin,

Can you download it from the following URL:

http://zulinux.homelinux.net/ubuntu/kernel-test.

Thanks
chuck

Sadly, this doesn't seem to help, I have been running for about 2 hours, and in
that time the clock has drifted about 28 seconds.

Kernel version:

Linux version 2.6.15-11-k7 (chuck@homer) (gcc version 4.0.3 20051204
(prerelease) (Ubuntu 4.0.2-5ubuntu2)) #1 SMP PREEMPT Thu Jan 5 19:25:25 EST 2006

Ben Collins (ben-collins) wrote :

(In reply to comment #28)
> Sadly, this doesn't seem to help, I have been running for about 2 hours, and in
> that time the clock has drifted about 28 seconds.

Have you tried booting with disable_timer_pin_1?

Christian Borup (borup+ubuntu) wrote :

My clock still runs at double speed, even with the latest kernel Dapper.

However adding the boot parameters "noapic acpi=noirq" fixes the clock problem.

Matt Zimmerman (mdz) wrote :

The approximate drift on my system is:

Feb 10 07:44:05 soekris.alcor.net ntpd[4699]: time reset +3.107237 s
Feb 10 07:56:02 soekris.alcor.net ntpd[4699]: time reset +3.555953 s
Feb 10 08:11:10 soekris.alcor.net ntpd[4699]: time reset +3.117062 s
Feb 10 08:29:37 soekris.alcor.net ntpd[4699]: time reset +3.792346 s
Feb 10 08:46:51 soekris.alcor.net ntpd[4699]: time reset +3.404976 s
Feb 10 09:06:16 soekris.alcor.net ntpd[4699]: time reset +4.350930 s

(the same net4501 486-based system) Would it be useful to try disable_timer_pin_1 or another parameter on this hardware?

Chuck Short (zulcss) wrote :

Do you have a FSB Spread Spectrum in your BIOS setting?

Regards
Chuck

Changed in linux-source-2.6.15:
status: Confirmed → Needs Info

disable_timer_pin_1 on my system stops it booting - it hangs just after showing the splash screen.

I do have a FSB Spread Spectrum setting in my BIOS, it is set at 0.5

Changed in linux-source-2.6.15:
status: Needs Info → Unconfirmed
Phil Worrall (phil-w) wrote :

I can confirm this bug in dapper flight 5.

ubuntu 2.6.15-18-386
on an HP laptp (ze2355ea) AMD Turion 64

I have tried booting using the kernel parameters suggested above 'noapic acpi=noirq" and then with "noapic acpi=off" but neither seam to fix the problem.

"Do you have a FSB Spread Spectrum in your BIOS setting?"

No.

Matt Zimmerman (mdz) wrote :

Closing superfluous Ubuntu task; bug remains open against the correct package already

Matt Zimmerman (mdz) wrote :

This sounds similar to http://bugzilla.kernel.org/show_bug.cgi?id=5038 Could those of you experiencing this bug try some of the tests/workarounds there?

Booting with 'noapic' as mentioned in the kernel bug seems to solve the problem for me.

Andrew Pam (xanni) wrote :

I have the same problem running Dapper Drake on an Intel Core 2 Duo desktop (Asus P5WDG2 WS Pro motherboard) with Nvidia graphics on the latest 2.6.15-26-amd64-xeon kernel package 2.6.15-26.47

Andrew Pam (xanni) wrote :

Using the "notsc" kernel parameter seems to fix the problem.

pdecat (pdecat) wrote :

The clock of my Shuttle SN41G2/Athlon XP 3000+ desktop with Nvidia nForce2 chipset is running too fast: it gains about 3 seconds per 10 minutes (verified running 'ntpdate ntp.ubuntu.com' every 10 minutes).

I'm running Dapper Drake 6.06.1, kernel 2.6.15-27-k7, fully apt-get updated/upgraded.

The default tickadj is 10000.

Issuing the following commands fixes the clock speed :
> sudo tickadj 9950

On Tue, 2006-10-17 at 13:21 +0000, p2k wrote:
> The clock of my Shuttle SN41G2/Athlon XP 3000+ desktop with Nvidia
> nForce2 chipset is running too fast: it gains about 3 seconds per 10
> minutes (verified running 'ntpdate ntp.ubuntu.com' every 10 minutes).
>
> I'm running Dapper Drake 6.06.1, kernel 2.6.15-27-k7, fully apt-get
> updated/upgraded.
>
> The default tickadj is 10000.
>
> Issuing the following commands fixes the clock speed :
> > sudo tickadj 9950

I have the same problem with a VIA Samuel 2 (Cyrix C3) CPU on a VIA EPIA
motherboard. Kernel timekeeping was fine with the 2.4 kernel, but broke
with the 2.6 kernels. On that server I'm currently running kernel
2.6.16.29 with debian patches under debian stable, but have previously
run kernels from 2.6.8 onwards all of which have this problem. This
server is running ntpdate every 5 minutes and has gained 1.7 seconds
each time, which sounds the same as your report. I'll have to try
tickadj and see if it helps.

Regards,
 Andrew
--
mailto:<email address hidden> Andrew Pam
http://www.xanadu.com.au/ Chief Scientist, Xanadu
http://www.glasswings.com.au/ Partner, Glass Wings
http://www.sericyb.com.au/ Manager, Serious Cybernetics

Timo Aaltonen (tjaalton) wrote :

confirmed by upstream

Changed in linux-source-2.6.15:
status: Unconfirmed → Confirmed
Luis Mondesi (lemsx1) wrote :

I was having this problem with a computer and I did the following to get it under control:

$> cat /etc/ntp.conf | grep burst

server ntp.ubuntu.com burst iburst

server pool.ntp.org burst iburst

That sends 8 packets instead of just 1 to the ntpserver.

The real fix for this problem was replacing the CMOS battery in the motherboard. After that, ntp just work.

Martin Kalén (martin-kalen) wrote :

FYI p2k and others: on Shuttle motherboards the system clock frequency can suffer badly from CPU over-clocking. This is not specific to any operating system and was verified with a Shuttle SN45 under Ubuntu, Slackware and Windows XP. With CPU frequency settings set to "Aggressive" in BIOS, my clock was running way too fast (everything from a few seconds to fast per 1-10 minutes up to double speed with two second ticks per wall-clock second). Settings CPU speed to "Optimal" in BIOS solved the problem for me.

(CPU: AMD Sempron 2800+. Additional BIOS settings: ACPI=ON, MPS-level=1.4, Memory timings=Aggressive, C1 disconnect=AUTO.)

ubuntu_demon (ubuntu-demon) wrote :

My clock runs too fast since I upgraded to Hardy Heron. I have an intel Core Duo T2500.

lspci -nn :

00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller [8086:27d8] (rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 [8086:27d0] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 [8086:27d4] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 [8086:27c8] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 [8086:27c9] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 [8086:27ca] (rev 02)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 [8086:27cb] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller [8086:27cc] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev e2)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge [8086:27b9] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller [8086:27c4] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation 82801G (ICH7 Family) SMBus Controller [8086:27da] (rev 02)
01:04.0 CardBus bridge [0607]: O2 Micro, Inc. OZ601/6912/711E0 CardBus/SmartCardBus Controller [1217:6972] (rev 40)
01:0a.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link) [104c:8023]
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:4222] (rev 02)
04:00.0 Ethernet controller [0200]: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller [11ab:4362] (rev 20)

ubuntu_demon (ubuntu-demon) wrote :

I have never had this problem until I upgraded my Gutsy installation to Hardy.

I marked some bugs as (possible) duplicates of this bug.

ubuntu_demon (ubuntu-demon) wrote :

I never had this problem until I upgraded to Hardy. The workaround https://bugs.launchpad.net/ubuntu/+bug/155882/comments/5 works for me (I have an intel Core Duo T2500)

Changed in linux:
status: Confirmed → Fix Released

Beginning with the Hardy Heron 8.04 development cycle, all open Ubuntu kernel bugs need to be reported against the "linux" kernel package. We are automatically migrating this linux-source-2.6.15 kernel bug to the new "linux" package. We appreciate your patience and understanding as we make this transition. Also, if you would be interested in testing the upcoming Intrepid Ibex 8.10 release, it is available at http://www.ubuntu.com/testing . Please let us know your results. Thanks!

The Ubuntu Kernel Team is planning to move to the 2.6.27 kernel for the upcoming Intrepid Ibex 8.10 release. As a result, the kernel team would appreciate it if you could please test this newer 2.6.27 Ubuntu kernel. There are one of two ways you should be able to test:

1) If you are comfortable installing packages on your own, the linux-image-2.6.27-* package is currently available for you to install and test.

--or--

2) The upcoming Alpha5 for Intrepid Ibex 8.10 will contain this newer 2.6.27 Ubuntu kernel. Alpha5 is set to be released Thursday Sept 4. Please watch http://www.ubuntu.com/testing for Alpha5 to be announced. You should then be able to test via a LiveCD.

Please let us know immediately if this newer 2.6.27 kernel resolves the bug reported here or if the issue remains. More importantly, please open a new bug report for each new bug/regression introduced by the 2.6.27 kernel and tag the bug report with 'linux-2.6.27'. Also, please specifically note if the issue does or does not appear in the 2.6.26 kernel. Thanks again, we really appreicate your help and feedback.

am28111 (am28111) wrote :

With the latest kernel I still have this problem. The time corrects itself upon rebooting.

am28111 (am28111) wrote :

Upon further investigation, it seems that turning off Auto intelligent stepping in the Foxconn BIOS corrects the problem.

ubuntu_demon (ubuntu-demon) wrote :

For me using clock=pmtmr works as described here :
https://bugs.launchpad.net/ubuntu/+bug/155882/comments/5

am28111 did you try this ?

This bug report was marked as Confirmed a while ago but has not had any updated comments for quite some time. Please let us know if this issue remains in the current Ubuntu release, http://www.ubuntu.com/getubuntu/download . If the issue remains, click on the current status under the Status column and change the status back to "New". Thanks.

[This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Daniel Sandman (almehdi) wrote :

This is still a very current bug. I have had it since Intrepid and are now running Karmic Koala. I have a ATI 1959 Pro Graphic card and Intel dual core processor. I have a Asus P5W DH Deluxe motherboard. I have tried a couple of fixes without luck.

Changed in linux (Ubuntu):
status: Incomplete → New
daqron (daqron) wrote :

I am also experiencing this problem; it is new to me since upgrading to karmic. I am on an Intel P4 system. Not sure what other info is relevant but if anyone needs any info just let me know. Cheers.

eniton (fcinter) wrote :

Experiencing the same issue. I deployed Ubuntu server 9.10 to 20 servers. All servers sync the clock everyday, but the system clock in each would be seconds different with others. It's annoying and dangerous for our distributed computing model.

Kernel: 2.6.31-16 server x86_64

Boniek (boniek12p) on 2010-01-12
Changed in linux (Ubuntu):
status: New → Confirmed
Jeremy Foshee (jeremyfoshee) wrote :

removed Ben as the assignee.

eniton / daqron / revoltism,
    Would one of you please run:
apport-collect -p linux 17589

This will get me the relevant logging needed to get this in front of the Kernel Team.

Thanks in advance,

-JFo

Changed in linux (Ubuntu):
assignee: Ben Collins (ben-collins) → nobody
status: Confirmed → Incomplete
Neil Perry (nperry) wrote :

This has been fixed upstream in kernel version 2.6.26 onwards. Markinng as fix released.

If you need a fix for the bug in previous versions of Ubuntu, please follow the instructions for "How to request new packages" at https://help.ubuntu.com/community/UbuntuBackports#request-new-packages

Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux:
importance: Unknown → Medium
martyone (martynh3-mvp) wrote :

my bios clock runs too fast when I use Ubuntu 12.10 from USB drive. Is Ubuntu actually doing this? Dell already changed the motherboard and the problem continues.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.