linux 4.11.0-13.19 ADT test failure with linux 4.11.0-13.19

Bug #1709590 reported by Andy Whitcroft on 2017-08-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Unknown
linux (Ubuntu)
High
Colin Ian King
Andy Whitcroft (apw) wrote :

/tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/debian/build/build-generic/spl/include/linux/rwsem_compat.h:56:69: note: in definition of macro ‘spl_rwsem_unlock_irqrestore’
 #define spl_rwsem_unlock_irqrestore(lk, fl) spin_unlock_irqrestore(lk, fl)
                                                                     ^~
In file included from /tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/include/linux/seqlock.h:35:0,
                 from /tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/include/linux/time.h:5,
                 from /tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/include/linux/stat.h:18,
                 from /tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/include/linux/module.h:10,
                 from /tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/debian/build/build-generic/spl/include/sys/sysmacros.h:28,
                 from /tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/debian/build/build-generic/spl/include/sys/types.h:29,
                 from /tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/debian/build/build-generic/spl/include/sys/rwlock.h:28,
                 from /tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/debian/build/build-generic/spl/module/spl/spl-rwlock.c:27:
/tmp/autopkgtest.MP1SQz/build.pVt/linux-4.11.0/include/linux/spinlock.h:352:29: note: expected ‘spinlock_t * {aka struct spinlock *}’ but argument is of type ‘raw_spinlock_t * {aka struct raw_spinlock *}’
 static __always_inline void spin_unlock_irqrestore(spinlock_t *lock, unsigned long flags)
                             ^~~~~~~~~~~~~~~~~~~~~~

tags: added: kernel-adt-failure
Changed in linux (Ubuntu):
importance: Undecided → High
assignee: nobody → Colin Ian King (colin-king)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1709590

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → In Progress
Colin Ian King (colin-king) wrote :
Download full text (29.8 KiB)

This occurs with the new gcc-7 tool chain

make ARCH=x86 CROSS_COMPILE= KERNELVERSION=4.11.0-13-generic CONFIG_DEBUG_SECTION_MISMATCH=y KBUILD_BUILD_VERSION="19" LOCALVERSION= localver-extra= CFLAGS_MODULE="-DPKG_ABI=13" -C /home/king/build/artful/debian/build/build-generic/spl/module -j4
make[1]: Entering directory '/home/king/build/artful/debian/build/build-generic/spl/module'
make -C /home/king/build/artful/debian/build/build-generic SUBDIRS=`pwd` O=/home/king/build/artful/debian/build/build-generic CONFIG_SPL=m modules
make[2]: Entering directory '/home/king/build/artful/debian/build/build-generic'
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/splat/splat-ctl.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/spl/spl-proc.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/splat/splat-kmem.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/spl/spl-kmem.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/spl/spl-kmem-cache.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/spl/spl-vmem.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/spl/spl-thread.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/splat/splat-taskq.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/splat/splat-random.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/spl/spl-taskq.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/splat/splat-mutex.o
  CC [M] /home/king/build/artful/debian/build/build-generic/spl/module/spl/spl-rwlock.o
In file included from /home/king/build/artful/include/linux/seqlock.h:35:0,
                 from /home/king/build/artful/include/linux/time.h:5,
                 from /home/king/build/artful/include/linux/stat.h:18,
                 from /home/king/build/artful/include/linux/module.h:10,
                 from /home/king/build/artful/debian/build/build-generic/spl/include/sys/sysmacros.h:28,
                 from /home/king/build/artful/debian/build/build-generic/spl/include/sys/types.h:29,
                 from /home/king/build/artful/debian/build/build-generic/spl/include/sys/rwlock.h:28,
                 from /home/king/build/artful/debian/build/build-generic/spl/module/spl/spl-rwlock.c:27:
/home/king/build/artful/debian/build/build-generic/spl/include/sys/rwlock.h: In function ‘spl_rw_set_owner’:
/home/king/build/artful/debian/build/build-generic/spl/include/sys/rwlock.h:55:32: error: passing argument 1 of ‘spinlock_check’ from incompatible pointer type [-Werror=incompatible-pointer-types]
         spl_rwsem_lock_irqsave(&SEM(rwp)->wait_lock, flags);
                                ^
/home/king/build/artful/include/linux/spinlock.h:205:34: note: in definition of macro ‘raw_spin_lock_irqsave’
   flags = _raw_spin_lock_irqsave(lock); \
                                  ^~~~
/home/king/build/artful/debian/build/build-generic/spl/include/linux/rwsem_compat.h:55:46: note: in expansion of macro ‘spin_lock_irqsave’
 #define spl_rwsem_lock_irqsave(lk, fl) spin_lock_irqsave(lk, fl)
   ...

Colin Ian King (colin-king) wrote :

This fix is in the 4.12 Artful kernel (and SPL), so it builds OK with gcc 7.1; I've checked that out and that is fine.

Changed in linux:
status: Unknown → New
Changed in linux (Ubuntu):
status: In Progress → Won't Fix
Changed in linux:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.