Keyboard keys get stuck and repeat

Bug #124406 reported by Guy Gur-Ari on 2007-07-06
This bug affects 61 people
Affects Status Importance Assigned to Milestone
GNU Emacs
X.Org X server
In Progress
Gentoo Linux
linux (Ubuntu)
xorg-server (Ubuntu)

Bug Description

Keyboard keys such as the arrows, Alt-F4, PageUp/PageDown, etc. often get 'stuck' and continue being 'clicked' even after they are physically released. For example when clicking Alt-F4, sometimes it gets stuck so all the windows are closed instead of just one.

My configuration is Feisty + Xgl + Compiz Fusion. My previous configuration was Edgy + Xgl + Beryl, where this didn't happen. Others have reported the same problem without using either Xgl or Compiz.

The keyboard itself isn't the problem. When dual-booting to Windows, everything works fine. Also, the problem happens with two different keyboards (internal laptop, external USB).

My best guess is that the problem occurs at time of high system load. Somehow during these times the key-release signal gets lost and the key-press is repeated indefinitely. This happens more often with Compiz configurations because Compiz tends to increase system load. It also happens more often with power-hungry apps like Firefox and Acrobat Reader for similar reasons.

PS: When the keys would repeat all input devices would be locked up. ie. mouse won't move, clicks don't do anything, keyboard presses don't register. Then when it becomes unstuck, the mouse moves around and everything. Hope this helps.

See also this forum thread for other people with the same problem:

Thank you for your bug report. Compiz Fusion is not part of Feisty official packages so we can't support it, I'm closing this. If this happens with Feisty's default compiz or with the compiz fusion's official packages in Gutsy, please reopen.

Guy Gur-Ari (guygurari) wrote :

Someone reported the same problem and he's not using compiz. He is using fglrx, as am I. So I'm reopening. In the forums he says:

 thomascj: I'm having the exact same problem, and I'm not running xgl, or compiz fusion. I am, however, running fglrx. Turning off keyboard repeat fixed it -- but I do use the terminal and it really sucks having to press backspace that many times... Anyone else fixed this problem?

Taken from:

By the way, canceling key repeat and lowering key repeat rate seem to be a good workarounds for now.

JeDi (jeroen-dierckx) wrote :

I am having the same problem, and I don't have XGL or beryl enabled at all. I'm not sure, but I think the problem started occurring after the latest kernel update. I am running an up-to-date feisty kubuntu.

In my opinion, a solution has to be provided as soon as possible, as this almost makes my system unusable at the moment.


Guy Gur-Ari (guygurari) wrote :

Several people confirmed the problem who aren't using compiz fusion.

Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. JeDi seems to indicate that this started happening after a kernel update so it would be useful to know what kernel everyone is experiencing this with. Thanks in advance.

Guy Gur-Ari (guygurari) wrote :

For me the problem started when I upgraded from Edgy to Feisty on 22/6/07. Before that I was running the latest Edgy kernel, whatever it was.

Right now I'm running:
Linux thinkpad 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

Timo Wiren (timo-wiren) wrote :

I'm having the same problem with vanilla kernel and Feisty. I don't use XGL, Compiz or Beryl. The problem is quite new, started maybe 3 weeks ago.

Russ (ubuntu-bugs-thewarrens) wrote :

I also have this (very annoying) problem...

2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux
Using fglrx
Definitely happening when XGL & Beryl are running
Also happens hen running a session with no XGL but beryl-manager still running (runs every session)
Unclear at the moment if it still happens after I remember to close beryl-manager

xermán (xerman.soto) wrote :

This issue happens with Feisty with no desktop effects operative too. I am running Feisty and not just the keyboard, but also the mouse has weird behaviour at times. NO XGL and NO Beryl running

This does not happen all the time. Seems kind of random but everyday happens a couple of times at least. The issue starts, then stops after a while.


DLink KVM 2 port (server + desktop)
Wacom Graphire 4 at usb port
Bluetooth dongle at usb port
Asus MW221u screen
Asus T3P5G965 barebone
1 GB Ram
Intel Core2duo E6400
1HD sata 160
1HD sata 250
Microsoft Wireles Natural Multimedia Keyboard and mouse

bean77 (lydia-acheson) wrote :

I have this issue too.

Brian Murray (brian-murray) wrote :

The full output of the 'dmesg' command after experiencing this event from someone not using Xgl or Beryl, as they are not supported on Feisty, would be quite helpful in tracking down this issue.

Erkin Bahceci (cornelius1) wrote :

I'm using Xgl + Compiz Fusion on fglrx, and I see this issue once or twice a day (at least since May 2007) on Feisty. I attached the full dmesg log right after the problem appeared, if it helps. The stuck key combination was Alt-Tab this time. It happens with other keys too.
System info:
Linux flux 2.6.20-16-generic #2 SMP Thu Jun 7 20:19:32 UTC 2007 i686 GNU/Linux

Erkin Bahceci (cornelius1) wrote :

This was on a 2 year-old Dell Inspiron 6000, with a mobility radeon x300 card, a Pentium M 1.86GHz processor, ipw2200 wireless driver connected via wireless.

I was wondering if it could be related to something else (like NetworkManager) blocking the cpu for a while right when I press a key, so that the key release signal is processed late causing a repeated-key behavior until the key release signal gets through.

The problem appeared at 12:17 on Aug 31 and this is the part of /var/log/daemon.log around that time.

Aug 31 12:16:44 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 7
Aug 31 12:16:51 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 10
Aug 31 12:17:01 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 10
Aug 31 12:17:11 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 4
Aug 31 12:17:15 localhost dhclient: No DHCPOFFERS received.
Aug 31 12:17:15 localhost dhclient: No working leases in persistent database - sleeping.
Aug 31 12:17:32 localhost dhclient: DHCPREQUEST on eth1 to port 67
Aug 31 12:17:32 localhost dhclient: DHCPACK from
Aug 31 12:17:32 localhost NetworkManager: <information>^IDHCP daemon state is now 3 (renew) for interface eth1
Aug 31 12:17:32 localhost dhclient: bound to -- renewal in 1650 seconds.

Erkin Bahceci (cornelius1) wrote :

Same thing happened with mouse getting stuck this time at 13:22. It got stuck clicked on acroread. Acroread uses 100% when you click and hold on a document.

Aug 31 13:22:00 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 3
Aug 31 13:22:03 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 4
Aug 31 13:22:07 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 8
Aug 31 13:22:15 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 12
Aug 31 13:22:27 localhost dhclient: DHCPDISCOVER on eth0 to port 67 interval 4
Aug 31 13:22:31 localhost dhclient: No DHCPOFFERS received.

So the problem could very well be related to dhclient.

Erkin Bahceci (cornelius1) wrote :

BTW eth0 is my wired network card. I'll try disabling that altogether (since I almost never use it) and see if the problem still persists.

Erkin Bahceci (cornelius1) wrote :

Didn't help, it still happens. And I see instances of the problem where nothing appears on any log in System Log at the time of the incident.

Steve Perry (le-grimp) wrote :

I have a USB keyboard and I was experiencing this key-repeat problem on Feisty 2.6.20-16-generic with no Xgl or Compiz. After a while I noticed that whenever I had a key repeat, my USB mouse LED blinked as well. The key repeat occurrences were correlated with a message in dmesg like the following:

[16705.323399] usb 1-2: reset low speed USB device using uhci_hcd and address 3

When I unplugged the USB mouse (the device at address 3) and then plugged it back in, the messages stopped and I no longer experience the intermittent keyboard repeats.

This may be a different problem than cornelius is experiencing but the symptoms (key repeats on Feisty) were the same.

Benjamin (bvanheu) wrote :

Same problem here.

- PS/2 keyboard very old keyboard (even without special « windows » keys)
- Linux 2.6.20 (Ubuntu Feisty)
- X Window System Version 7.2.0
- I am using GNOME.

[36358.898597] atkbd.c: Unknown key released (translated set 2, code 0x7c on isa0060/serio0).
[36358.898605] atkbd.c: Use 'setkeycodes 7c <keycode>' to make it known.
[36379.013404] atkbd.c: Unknown key released (translated set 2, code 0xe0 on isa0060/serio0).
[36379.013412] atkbd.c: Use 'setkeycodes e060 <keycode>' to make it known.
[37631.831320] atkbd.c: Unknown key released (translated set 2, code 0x7c on isa0060/serio0).
[37631.831327] atkbd.c: Use 'setkeycodes 7c <keycode>' to make it known.

I suppose the keyboard is broken because it isn't sending the key-released signal.

Sorry for my english :)

Mike (0x656b694d) wrote :

The same problem here. Too annoying.

Keys stuck when they're "hot". I have never seen this bug initiated in a terminal window or any text area (only once, when i pressed space in the Google Reader to move to the next item and it started to read all items below the current, i switched with mouse to the terminal window and got spaces running there). Sometimes get cursor keys stuck.
We really miss KeyUp event.

- compiz-fusion
- Linux 2.6.20-16-386
- X Window System Version 7.2.0
- old good ps/2 keyboard

Mark Schwartzkopf (kappa962) wrote :

Same problem,it only began when I enabled the desktop effects via the System > Preferences menu. In order to get this to work, I installed Xgl as recommended in

However, I did not install Beryl or Fusion, so it would seem that the problem for me was either triggered by installing Xgl or by enabling the Desktop Effects in 7.04

naxu (naxu) wrote :

I saw this problem too. When the problem was active also processor load was above normal. I also have USB connected keyboard like someone else had. I also have usb dvb-t tuner Artec T14.

For some reason that tuner dongle was stuck and that caused extra traffic on usb bus. And that caused keys to stuck.

After removing and re-inserting Artec keyboard started to work normally.

Here is dmesg from situation:

.. lots of bulk message failed messages..
[ 1208.985627] dvb-usb: bulk message failed: -110 (1/0)
[ 1211.133604] dvb-usb: bulk message failed: -110 (1/0)
[ 1211.233218] usb 4-2: USB disconnect, address 2
[ 1211.233688] dvb-usb: Artec T14 - USB2.0 DVB-T successfully deinitialized and disconnected.
[ 1214.115975] usb 4-2: new high speed USB device using ehci_hcd and address 4
[ 1214.248214] usb 4-2: configuration #1 chosen from 1 choice
[ 1214.248353] dvb-usb: found a 'Artec T14 - USB2.0 DVB-T' in cold state, will try to load a firmware
[ 1214.319022] dvb-usb: downloading firmware from file 'dvb-usb-dibusb-'
[ 1214.385481] usb 4-2: USB disconnect, address 4
[ 1214.385508] dvb-usb: generic DVB-USB module successfully deinitialized and disconnected.
[ 1216.136202] usb 4-2: new high speed USB device using ehci_hcd and address 5
[ 1216.277266] usb 4-2: configuration #1 chosen from 1 choice
[ 1216.277682] dvb-usb: found a 'Artec T14 - USB2.0 DVB-T' in warm state.
[ 1216.277778] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[ 1216.281920] DVB: registering new adapter (Artec T14 - USB2.0 DVB-T).
[ 1216.283485] DVB: registering frontend 0 (DiBcom 3000MC/P)...
[ 1216.332777] MT2060: successfully identified (IF1 = 1220)
[ 1216.793610] input: IR-receiver inside an USB DVB receiver as /class/input/input8
[ 1216.793646] dvb-usb: schedule remote query interval to 150 msecs.
[ 1216.793651] dvb-usb: Artec T14 - USB2.0 DVB-T successfully initialized and connected.

2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
Kubuntu gutsy, no desk top effects.

coffeemug (coffeemug) wrote :

I can confirm that this happens on Gutsy final, with or without compiz. I also have an ATI card (with restricted drivers turned off).

txshtkckr (crf) wrote :

It is rather unpleasant to have to watch in horror as the Ctrl-W you hit to close a single firefox tab blows away the 20 others you still wanted to keep open. :)

Kubuntu Gutsy Final
fglrx + Xgl + compiz + fusion
Linux crflkf 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux
Nothing special reported in dmesg (just iptables drops)

At least where the keyboard is concerned, this only seems to involve things that are accelerators. That is, arrow keys get stuck, and Ctrl-W gets stuck, but an ordinary W never does.

Mircea Deaconu (mirceade) wrote :

Somewhat the same problem over here. But for me it seems to happen only in firefox. Page Up / Down, the arrow keys or the mouse scroll wheel gets stuck. Gutsy + fglrx + compiz fusion
Linux link 2.6.22-14-386 #1 Sun Oct 14 22:36:54 GMT 2007 i686 GNU/Linux.

Mircea Deaconu (mirceade) wrote :

Could this be related to xgl? Maybe the ati november driver (that will enable aixgl) will deny the need for a fix on this one.

Mike (0x656b694d) wrote :

not related to xgl (not totally sure), not related to Firefox, not related to ATI.

I run AIGLX, Opera, use nVidia card.

Get these repeats when switch applications with Alt+TAB.

f66336pb (spamme2) wrote :

I think it is a duplicate of 122118.

remitaylor (remi-remitaylor) wrote :

Same problem for me since Feisty. Upgraded from Edgy to Feisty and then had to move to a different distribution. Totally unusable. Booted a Gutsy LiveCD and the problem was still there. Booted the LiveCD again later and it appeared to be randomly gone so I installed Gutsy only to reboot back into keyboard hell. Totally unusabbbbbbbbbbbbbbbbbbbbbbbbbbble. ( <-- see what i mean? )

Does Ubuntu still have bounties? doesn't go anywhere anymore. I ( <-- again ) would *DEFINATELY* add to a bounty for this. I've been driving me crazy since Feisty was released. I'm really, really sad to have to leave Ubuntu with this machine again ....

Fujitsy Lifebook N6010, Intelllllllllllllllllllllllllllllllllllll Pentium 4, ATI Mobility Radeon 9700
Linux haruko 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Disabling 'Repeat Keys' doesn't work for me. When I do, instead of getting thissssssssssssssssssssssssssss, I get something like this:
the quick fox jum[ system pauses ]y dog

reference: ( full description & links to abunchof ubuntuforum threads with the same problem described )

kervel (frank-dekervel) wrote :

i'm also affected. on a thinkpad R51. most of the time it happens when i hit F12 to pop up yakuake (it keeps coming up and down and ...). happens very frequently, and i have the impression that, because of system load, the key release event gets to the X server too late so the x server thinks i'm holding the key down

remitaylor (remi-remitaylor) wrote :

kervel: i found another instance of this problem on a thinkpad (r40e) ... try adding this to your boot (grub) parameters ... ec_intr=0

might be a fluke, but after a few reboots ... i can still type (on gutsy, using liveCD)

i added acpi=off to my boot parameters. will post back if it stops working but ... i've tried putting the system under load and no repeats yet!

the quick brown fox jumps over the lazy dog :)

santho (thomas-knauth) wrote :

Boy, please somebody fix this. It's annoying. Running on a R52 Thinkpad, proprietary ATI drivers, standard Kubuntu install.

zak317 (sobomsawin) wrote :

Same problem here since Feisty... Upgraded to Xubuntu Gutsy recently and still have the "Sticky Keys of Death" bug...

I just watched my emails being deleted one by one till I found that my Del key was stucked.....

Some info:
Xubuntu Gutsy
Dell Inspiron 700m
Intel graphic card
Compiz with xgl enabled

Hope someone will find a fix soon!! Good luck!

Mircea Deaconu (mirceade) wrote :

Yeah! Unfortunately you're right Mike. Alt-Tab gets stuck for me too. So I guess it's a Compiz bug. Setting the package relation to Compiz. The title of the bug should also be changed. It happens in Gutsy too.

santho (thomas-knauth) wrote :

I am not running Compiz or any other fancy graphics stuff and have this problem. So I say it is _not_ related to Compiz.

remitaylor (remi-remitaylor) wrote :

Same here (happens *without* compiz). Including the LiveCD. For my hardware, it happens using Feisty or Gutsy, with or without effects (LiveCD can be used to reproduce).

I have a forum post ( where I've compiled a list of launchpad bugs that are likely duplicates of this, as well as forum threads, as well as some boot options I had tried and some I was going to try, but _using *acpi=off* seems to have worked for me_

I also opened a bounty for this, here - - currently at $250 (not sure if there's a way people can contribute). Anyone know how active the Ubuntu bounties are and how people can contribute? Even if it's just $5, I'm sure many of you would like to get this bug noticed and fixed.

[ assuming no bug fix that works for everyone shows itself soon, there's a very good chance I'll be throwing up a website dedicated to this bug where we can compile a list of fixes and the hardware setups they work for - as well as track launchpad bugs ... this needs to be fixed in 8.04. this has caused a lot of people a lot of frustration and has kept a number of people from being able to use Ubuntu ... i'll post back here when it's ready ]

I think this one is also the same problem:
I'm having the same problem since I upgraded to Gutsy last Sunday.

Cruncher (ubuntu-wkresse) wrote :

I'm the one that opened #158436, thanks lazyone. The main points and my setup are:
- many different key combinations are affected (1, 2, 3, ctrl-w, ...)
- not restricted to single application (Opera, xnview, ...)
- it *never* happened in Feisty for me, it started happening after upgrading to Gutsy
- I had Compiz installed in Feisty already (1:0.3.6-1ubuntu13), but never used it, since it does not work with nvidia-legacy drivers (did that change, btw?)
- currenty Compiz is installed (1:0.6.0+git20071008-0ubuntu1), but unused. I'll try uninstalling it and report back whether that changes anything.
- no xgl, no aiglx, no fglrx. nvidia-glx-legacy 1.0.7185+
- Feisty kernel: 2.6.20-16-generic. Gutsy kernel: 2.6.22-14-386
- AMD-Desktop, no Thinkpad.

Cruncher (ubuntu-wkresse) wrote :

Purged compiz from the system, but it did not fix the problem. I don't use *any* fancy 3D accelerated X, just plain old nvidia-glx-legacy (GeForce2 GTS/Pro).

Chad Johnson (chad-d-johnson) wrote :

Confirmed for me, too. This happened when I was using Firefox, right after I had typed a long response in some forum...and now it's gone :( . VERY annoying. This happened in Fiesty and possibly Edgy as well.

* Ubuntu Gutsy
* ATI x1100 with standard proprietary fglrx drivers installed
* Acer Aspire 5050 laptop (using its keyboard)
* I was getting a "Composite extension is not available" error when enabling desktop effects, and installing xserver-xgl per this thread helped:

I have a desktop running an nVidia 8800GTS with the most recent nVidia drivers installed, but I don't recall this happening there. This DID happen on another (MSI) laptop I had which had an ATI x1600 mobility video card.

I appreciate the efforts with Compiz/Xgl/Beryl/Compiz-Fusion. Hope this gets fixed.

positivek (anonyhole) wrote :

This happens for me occasionally as well. I use the web browser a lot (Firefox). While I haven't lost "original work" due to this bug, I have lost work in web browsing. As mentioned above, I will use Ctrl-w to close a browser tab and many more that I wanted open will close. When using Ctrl-n to open a new window, I will get 20+ windows opened, bringing the system to a grinding slowdown while I frantically tap on keys (Ctrl) to register the keyup to stop the key repeat.

Machine: Compal CL56 laptop
Video: ATI Mobility Radeon 9600 (M10)
Graphics & desktop software: proprietary (restricted) drivers turned on; fglrx; xserver-xgl; compiz
Linux distro: Ubuntu 7.10 (Gutsy)
uname -a: Linux machname 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux
Firefox: Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20071022 Ubuntu/7.10 (gutsy) Firefox/

Thanks, all!

Guy Gur-Ari (guygurari) on 2007-11-10
description: updated
Guy Gur-Ari (guygurari) on 2007-11-10
description: updated
MrAnt (mrant0) on 2008-03-19
description: updated
Timo Aaltonen (tjaalton) on 2008-04-07
Changed in linux:
assignee: nobody → ubuntu-kernel-team
Changed in xorg-server:
status: New → Invalid
Changed in linux:
status: Unknown → Confirmed
Changed in emacs:
status: New → Invalid
Tim Gardner (timg-tpi) on 2009-04-14
Changed in linux (Ubuntu):
assignee: nobody → Tim Gardner (timg-tpi)
importance: High → Medium
status: Triaged → In Progress
Tim Gardner (timg-tpi) on 2009-04-14
Changed in linux (Ubuntu):
assignee: Tim Gardner (timg-tpi) → nobody
status: In Progress → Fix Released
Anders Kaseorg (andersk) on 2009-04-14
Changed in linux (Ubuntu Jaunty):
assignee: nobody → timg-tpi
status: Fix Released → In Progress
Anders Kaseorg (andersk) on 2009-04-14
tags: removed: cft-2.6.27 fixed-2.6.27
Changed in linux (Ubuntu Jaunty):
assignee: Tim Gardner (timg-tpi) → nobody
status: In Progress → Incomplete
Changed in linux (Ubuntu):
status: Incomplete → Won't Fix
Changed in linux (Ubuntu Jaunty):
status: Incomplete → Won't Fix
Changed in xorg-server (Ubuntu):
status: Invalid → New
Changed in xorg-server:
status: Unknown → In Progress
Bryce Harrington (bryce) on 2010-05-05
Changed in xorg-server (Ubuntu):
status: New → Incomplete
tags: added: needs-retested-on-lucid-by-june
Bryce Harrington (bryce) on 2010-05-21
tags: added: feisty gutsy
Changed in xorg-server:
importance: Unknown → Medium
Changed in xorg-server:
importance: Medium → Unknown
Changed in linux:
importance: Unknown → High
summary: - Keyboard keys get stuck and repeat (Feisty, Gutsy)
+ Keyboard keys get stuck and repeat
tags: added: maverick natty
Bryce Harrington (bryce) on 2011-03-19
Changed in xorg-server (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Medium
Changed in xorg-server:
importance: Unknown → Medium
Bryce Harrington (bryce) on 2011-03-21
Changed in xorg-server (Ubuntu):
status: Confirmed → Incomplete
tags: removed: natty
Bryce Harrington (bryce) on 2011-04-28
Changed in xorg-server (Ubuntu):
importance: Medium → Wishlist
status: Incomplete → Triaged
Changed in hundredpapercuts:
status: New → Invalid
Bryce Harrington (bryce) on 2011-05-11
Changed in xorg-server (Ubuntu):
assignee: nobody → Bryce Harrington (bryce)
Bryce Harrington (bryce) on 2011-05-12
Changed in xorg-server (Ubuntu):
status: Triaged → Won't Fix
Bryce Harrington (bryce) on 2011-07-16
Changed in xorg-server (Ubuntu):
assignee: Bryce Harrington (bryce) → nobody
310 comments hidden view all 383 comments
Marius B. Kotsbak (mariusko) wrote :

I guess Canonical should exclude their own bugmails from their vacation message service....

new4u (new4u) wrote :

To me, this happens as well, using Lucid Lynx 64 bit. Even if the PS/2-keyboard is unplugged, the key which decided to get stuck keeps repeating.

What I would like to point out:

It only happens when tpying in forms displayed of Firefox (so NOT during any other application of Ubuntu), and then there on certain forms: when trying to write an email in Outlook 2010 webmail, or when writing a comment on the launchpad page, the key repeating error almost reroducably happens.(This is why I needed to write this mail in Gedit and copy it conscutively into launchpad).

On the contrary, it does e.g. not happen in GMail - so maybe there is an interference between some applications and firefox and Ubuntu.

Despite I turned off the repetition in the preferences -> Keyboard settings -> General -> Repeat keystrokes when being pressed, the keyboard keeps stuck in the Firefox forms as mentioned above.

My Hardware:

Asus P7P55D
Intel i5 750
ATI HD 4600
USB-Logitech Mouse
PS/2 Fujitsu Siemens Keyboard
Xonard D2X Soundcard
Pinnacle PCI TV Card

I'm gueesing about a motherboard issue. I'm going to change it an try.

Moritz Winter (winter-moritz) wrote :

Im still experiencing this in 11.10 and removing gnome-applet-sensors or the unity counterpart (see comment #151) works for me.

Moritz Winter (winter-moritz) wrote :

^^ Sorry, its comment #157

Wojciech Musial (wmusial) wrote :

I also experienced the exact symptoms of the bug, combined with a bunch of other problems (sound crackling, system freezes).

This workaround fixed it all together for me (ubuntu 10.04, 2.6.32-36-generic):

 in /etc/default/grub change line


to be

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash clocksource=jiffies"

Then enter sudo update-grub and reboot. See if your problems are gone.

Unfortunately that triggered another bug: hd-audio0 eats up 20% of my cpu, but that's another story.

Cinquero (cinquero) wrote :

Ubuntu Precise yesterday showed similar symptoms: numlock LED was insanely blinking, at times no keyboard input was possible on two of three connected keyboards, and additionally, the mouse cursor was being dragged down.

Maybe this is related to:


tags: added: oneiric precise
new4u (new4u) wrote :

It is still in 12.10. :(

no longer affects: hundredpapercuts
essl (essl-main) wrote :

Hmmm... Just noticed that I don't have it anymore...

Dell XPS 17
openSuSE 12.2
Linux xps 3.4.11-2.16-desktop #1 SMP PREEMPT Wed Sep 26 17:05:00 UTC 2012 (259fc87) x86_64 x86_64 x86_64 GNU/Linux
KDE Platform Version 4.8.5 (4.8.5) "release 2"
X.Org X Server 1.12.3

Daniel J Blueman (watchmaker) wrote :

I've been observing this happen once a week across a wide range of x86 systems with USB keyboards in the last (5?) years.

Since I've observed it in the virtual terminal and have never observed this with PS/2 keyboards, I suspect there is an event race condition in the USB input stack, eg a missing write barrier.

When I increase system latency, it looks like there's more chance of it happening, so this feels like MMIO write ordering causing a lost key up event.

new4u (new4u) wrote :

In 13.04 (beta) 64bit it occurs more frequently again than I noticed it in 12.10. This last time it even occured in a Win7-guest in Virtualbox.

Almost same hardware as before, just graphics & soundcard changed.

My Hardware:
Asus P7P55D
Intel i5 750
ATI HD 7850
USB-Logitech Mouse
PS/2 Fujitsu Siemens Keyboard
Xonard STX Soundcard
Pinnacle PCI TV Card

Mahdi Dibaiee (mahdidibaie) wrote :

I feel the same as new4u, I have the problem in 13.04 beta more than ever, even after I disabled key press repeat in Prefrences -> Keyboard, I have this problem.

I used `xset r off` right now, gonna see if key repeat occurs or not.

P.S: Sorry for my bad English.

new4u (new4u) wrote :

Dear developers, I really would like to stress this issue. Only tonight I had to reboot my machine 3 times due to this issue. It is a MAJOR impediment in working. The key-stucks happened in gedit, and Gummi tonight. So it seems not attached to a specific application.

Despite I am not able to develop or program, I see myself as a kind of evangelist, who converted a lot of people to Ubuntu. But, honestly, it is a problem for continue recommending it of having basics such as a keyboard causing problems. I have never seen this on any other distribution.

So, please, please have a look at this issue, as I guess that many people might use Asus and Ubuntu 64bit (as it combination seems to correlate somehow).

Thank you for your time making Ubuntu that great - that also needs to be said.

Rizwan (rizwanenstien) wrote :

I feel the same as new4u, I have been having this keyboard problem and its really irritating. I use ubuntu as my main development machine. I left the mac cause I loved working on this, but with this problem, I guess I will go back. I have an i5 Asus machine running Ubuntu 13.04. I have upgraded my Kernel to run 3.9.0 but the problem persists.

Peter M (pmoss) wrote :

Just chiming in to say that this bug affects me too. Asus K55n laptop with Ubuntu 13.04. It randomly acts like sticky keys are enabled. A minute ago I hit ctrl and it acted as if I was holding ctrl until I logged out. Extremely annoying!

Artyom Kazak (artyom-kazak) wrote :

I’ve never experienced this problem on 13.04, but strangely enough, it happens very often to me with 13.10. Laptop’s keyboard works fine, but Bluetooth one stutters every now and then.

tags: added: saucy
Hồng Quân (ng-hong-quan) wrote :

Yes, me too, Ubuntu 13.10 :'(

Hồng Quân (ng-hong-quan) wrote :

Another workaround for me is to login to text console (not graphical UI) and remove all settings in home folder.

new4u (new4u) wrote :

Update for 14.04 beta 64 bit: The same error still also in this version... I think this error, which really impedes productivity, will be turning me away from Ubuntu. :(

new4u (new4u) wrote :

Dear all, just wanted to add: Also in 14.04 64bit the error is present, multiple times a day.

new4u (new4u) wrote :

Dear developers, maybe a information that helps localize the error: It is intermittent, and obviously related to a very few packages. The last days, it did not occur, and now since I updated (from 13th to 14th of May 2014) from the sources trusty-security, -updates, -proposed and -backports, the error appears twice an hour. Maybe you could have a look at these packages, as they seem to influence the behaviour.

Vyacheslav (sl-s) wrote :

also found this bug (keyboard imitates of pressing '1', '2', '3' and Enter) after installing of fresh copy of ubuntu 14.04 stable x64 server and when installing xorg and kubuntu-desktop meta package
also found this bug after installing of fresh copy of ubuntu 12.04.4 stable x64 server and when installing xorg and kubuntu-desktop meta package, but more rarely when in 14.04
my keyboard is physically well (dual-booting into Windows on this machine shows no problems), this bug exists if I change the keyboard to another.
If I reboot the computer and never click a button on keyboard (but work with it through RealVNC server and viewer - press any buttons on keyboard at other computer and VNC viewer sends it to server) - the bug appears again
The bug also appears sometimes after some hoгs of user inactivity (VNC viewers also disconnected for some hours)

Vyacheslav (slavoon2) wrote :

also found this bug after installing (at the middle of June 2014) fresh copy of ubuntu-14.04-beta2-server-amd64.iso AND NOTHING ELSE! (no KDE, Gnome etc.) predominantly arbitrarily keys presses digit '1', digit '2', digit '3', left and right arrows and Enter. My Ubuntu is installed at sda7 of hard disk, sda1 is partition for Win XP (then I boot in Windows, no any bugs with keyboard!), grub installed into sda Master Block Record), I selected Russian language before installin server, and updates are downloading during install, software sources enabled: main, universe, restricted, multiverse, download server is Main server (not local for Russian Federation), other software sources: Canonical partners, Canonical partners (source code), Independent, Independent (source code), Important security updates, Recommended updates, Pre-released updates, Unsupported updates, Release upgrade: long term support releases only.
my configuration is Asus P5G41T-M LX motherboard (northbridge Intel G41, southbridge Intel ICH7) with Pentium Dual-core CPU E5700 @ 3.00 GHz, 4 Gb dual-channel memory. Removing the keyboard physically from PS/2 socket does not solve the problem.
Also I installed fresh copy of ubuntu-14.04-beta2-server-amd64.iso and selected English and also found this bug (after KDE (kubuntu-desktop package) installed or before I install KDE, I don't remember), also found this bug after installing fresh copy of ubuntu-12.04.4-server-amd64.iso (with Russian selected) and kubuntu-desktop package (I am not sure if this bug will not appear after installing fresh copy of ubuntu-12.04.4-server-amd64.iso without KDE), but in 12.04.4 this bug appears more rarely then in 14.04. This bug appears more often when I use RealVNC or TeamViewer and remotely control my computer (in KDE enviromnent).

Vyacheslav (slavoon2) wrote :

in my situation - keyboard imitated of clicking '1', '2', '3' etc. even if I didn't work on keyboard and mouse for 30 min to several hours. The symbols that were stucked (imitated) didn't repet the symbols I manually typed before. The bug appeared more often when RealVNC server or TeamViewer server worked (and I typed symbols and moved mouse remotely - and VNC server or TeamViewer server received this symbols and mouse movements). Every time then bug began - it repeated from 1 to some hundreds of same symbols - and I every time can stop the bug by pressing any key phisically in keyboard or remotely via VNC server or TeamViewer server (but after such a stopping the bug - it could be begin again after period from 0.5 seconds to some hours).
THE PROBLEM SOLVED in my situation by phisically removing the USB device called 'SkypeMate' (USB-B2K model) (this device connects Skype software on desktop via USB with wire connected to standard office phone device to make calls via it).

Vyacheslav (slavoon2) wrote :

thank you all for help! as I already understood - in this topic users reports about DIFFERENT bugs (but the same sympthoms) - if you are lazy to read this topic above:
1) if your dmesg log contains USB errors ('reset low speed USB device' or other) - try to physically unplug USB devices (mayby onboard keyboards in notebooks seen as like USB devices in some situations?) or re-plug to ANOTHER USB controller; try to use USB keyboard (another keyboard); try to disable legacy USB support in BIOS. This is kernel problem.
2) if your dmesg log contains non-USB errors ('Unknown key released' or something else) -
try to change the BIOS setting 'Plug and play OS' to it's default state ('No');
try to disable WiFi adapter;
try to disable OpenGl in KDE, Gnome, ... ;
try to set atkbd.softrepeat=1 parameter to the kernel boot parameters in Grub;
try to unload the battery, AC and thermal modules of kernel after booting;
try to set acpi=off parameter to the kernel boot parameters in Grub;
try to disable legacy USB support in BIOS;
try to execute xset r rate 1000 50 command;
try to set in BIOS do not check if PCI-express videocard not installed search for PCI video card, if not - try to initialize internal video card - instead of it set BIOS to initialize your existing video card first;
try to disable auto-repeat keys in keyboard in KDE or Gnome settings;
try to switch to another kernel;
try to execute xmodmap /usr/share/xmodmap/ each time the bug occurs;
try to set highres=off nohz=off noapm parameters to the kernel boot parameters in Grub;
try to remove gnome-sensors-applet , lm_sensors , net-snmp-libs , hplip , hpijs , net-snmp packages or packages with same functionality;
try to edit /etc/mkinitcpio.conf and remove the word 'keyboard' from line HOOKS="... ;
try to remove gnome-accessibility-themes , gnome-accessibility-themes-extras accessibility packages or packages with same functionality;
try to remove hotkeys-setup package or package with same functionality;
try to report at and about this bug (include your list of hardware (lspci command) and Linux version (uname -a command) and dmesg log)
This is a kernel problem also.
useful links (are already listed above in this thread):

Abhirav Kumar (akabhirav) wrote :

I have a lead may be
Given scenario I have my keyboard stuck (i.e. I can't do andything with my keyboard)
I suspend my laptop using mouse and voilà my keyboard is working again
Hope this helps!!!

(Note: I intentionally don't fix repeated characters cccaaaaauuuusssssseeeeeedddd by that issue in my message below)

I'm affected by ttthhheeeeee sssssssame issue.

Initially I have installed Ubuntu 16.04.4 LTS. While installing it, I had to add ttttthe boot parameter "acpi=off" in grub settings (both for the installer andd for booting of the installed OS). Otherwise, I got a freeze on boot.

AAAAaafter installation, I got this probleeemmmm. But next to issues with repeated keys, I got temporary freezes in firefox. I see that sometimes the caret is applicaatioooooonsssss flickers too fast (and that is when I get repeated characters). And other strange issues.

I opened a clock application in and I saw that the speed offf the "seconds" needle is not regular, and it sometimes moves backwardssss bbbyyyy 10 to 15 seconds. There is really something wrong with system time.

Then I have upgraded to Ubuntu 17.10, but it was the same (but I got additional issues because of the upgrade :( ).

And the solution was the one from comment #356 from this thread ( ), which adds a "clocksource=jiffies" boot option.

I'm not done yet. Now I have a hang on Ubuntu shutdown ( ), and the suggested solution there is ... forcing acpi in boot options :(

I have no idea whether this issue is related my acpi issues.

I'm not sure whether it gives any information, but here is some output from journalctl, where the bug happens (no "clocksource=jiffies" boot option is used):

$ journalctl -k | grep clocksource

clocksource: refined-jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645519600211568 ns
clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
clocksource: Switched to clocksource refined-jiffies
clocksource: tsc: mask: 0xffffffffffffffff max_cycles: 0x2879c5f06f2, max_idle_ns: 440795220049 ns
clocksource: Switched to clocksource tsc
clocksource: timekeeping watchdog on CPU0: Marking clocksource 'tsc' as unstable because the skew is too large:
clocksource: 'refined-jiffies' wd_now: fffedcd0 wd_last: fffedc58 mask: ffffffff
clocksource: 'tsc' cs_now: 13ccf176fe cs_last: 13299ba17d mask: ffffffffffffffff
kernel: tsc: Marking TSC unstable due to clocksource watchdog
kernel: clocksource: Switched to clocksource refined-jiffies

WWWWWWwwwwweeeeeeelllllllllllll, IIIii bbbbbooooooooooottteeeeeeedddddddddd aaaaaaaggggggaaaaaaiiinnnnn wwwwiiiiitttthhhhh clocksource=jiffies,,, aaaaaaannnnnndddddd ttthhheeeeee iiiiisssssssssssssuuuueeeee ggggggottttt mmmmuuuuuuuccchhhh wwwwwooooorrsssssseeee tttttthhhhiiiiiiis tttttiimmmmeeeeee....

SSSSssooo clocksource=jiffies ddddddooeeeees nnnnoooooottttt ssssseeeeeeeeeeeemmmmmmm tttttooooo bbbbbeeee aaaaa ddddddeeeeeffffffiiiiiinnnniiitttttttiiiivvveeeee sssssoolllluuuuutttiiooooooonnnn....

I'm sorry for flooding this thread, but I have more experience to share.

After another reboot in "clocksource=jiffies" mode, I saw that 1 OS second passes in real 0.5 seconds. But the rest of the system was pretty stable. Keyboard auto-repeat was twice as fast, but did not get triggered inadvertently.

I did another reboot in "clocksource=jiffies" mode and opened the online clock application. Initially the clock speed seemed normal. After 20-30 seconds it became twice as fast.
Then from the console, I started an application with an infinite loop therein. That made the clock seconds turn very very fast. Probably CPU speed has influence here.

Good news is that when I changed the boot option to "clocksource=tsc", I got stable results even after a few reboots. Seconds seem to pass as fast as they should be.

wow! see this was opened in 2007. just googled this from the future (i am in 2018) and found this.

using ubuntu 18. found that what was causing it in my case was a clipboard manager i use here. closing the clipboard manager stopped the bleeding.

vak (khamenya) wrote :

The bug is still here in Ubuntu 18.04.1 on Lenovo IdeaPad Yoga 13
(last available BIOS for my model is installed)

It is notable to see so much Fujitsu Siemens hardware affected.
I have the same issue with the onboard USB 2.0 of a Fujitsu Siemens P710 E90+ Intel i5 3470 desktop computer.

The problem occurs with any of my Varmilo VA88M keyboards, but not with a Cherry Cymotion G-224. The Varmilo keyboards work perfectly fine on any other desktop computer I tested but which happened to be not of the Fujitsu brand.

However, only on the Fujitsu Siemens P710, both Varmilo keyboards would very often, but not always, stuck and repeat key combinations like Ctrl+C. This never happened in combination with the Cherry keyboard. So it seems, reproducibility of this issue depends on both the computer and the keyboard hardware.

Fed up with this behaviour, I recently installed a NEC USB 2.0 card in its single conventional PCI slot. The problem never reoccurred over the span of two weeks now.

Displaying first 40 and last 40 comments. View all 383 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.