ps2 mouse erratic - parity errors - lost synchronization errors

Reported by Dianne Reuby on 2007-06-07
192
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Ubuntu
Undecided
Unassigned
Nominated for Intrepid by Matt LaPaglia
linux (Ubuntu)
Medium
Unassigned
Nominated for Intrepid by Matt LaPaglia
linux-source-2.6.20 (Ubuntu)
High
Unassigned
Nominated for Intrepid by Matt LaPaglia

Bug Description

Binary package hint: linux-source-2.6.20

uname:
 2.6.20-16-generic #2 SMP Wed May 23 01:46:23 UTC 2007 i686 GNU/Linux
lspci:
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
00:08.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:08.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:08.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
00:0a.0 Communication controller: Intel Corporation 536EP Data Fax Modem
00:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8233A ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
00:11.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 23)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 40)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3)

dmesg extract:
[13992.656000] psmouse.c: bad data from KBC - bad parity
[13994.192000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[14007.616000] psmouse.c: bad data from KBC - timeout
[14009.432000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
[14010.720000] psmouse.c: bad data from KBC - bad parity
[14013.344000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[14048.616000] psmouse.c: bad data from KBC - timeout
[14048.624000] psmouse.c: bad data from KBC - bad parity
[14053.784000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[14055.280000] psmouse.c: bad data from KBC - bad parity
[14055.628000] psmouse.c: bad data from KBC - timeout
[14055.680000] psmouse.c: bad data from KBC - timeout
[14057.476000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
[14057.480000] psmouse.c: resync failed, issuing reconnect request
[14057.632000] input: GenPS/2 Genius Mouse as /class/input/input7
[14057.776000] input: GenPS/2 Genius Mouse as /class/input/input8
[14311.032000] psmouse.c: bad data from KBC - bad parity
[14312.612000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[14394.256000] psmouse.c: bad data from KBC - bad parity
[14395.584000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[14768.280000] psmouse.c: bad data from KBC - timeout
[14768.284000] psmouse.c: bad data from KBC - timeout
[14929.396000] psmouse.c: bad data from KBC - bad parity
[14931.560000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[15073.300000] psmouse.c: bad data from KBC - bad parity
[15076.748000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[15177.576000] psmouse.c: bad data from KBC - bad parity
[15179.288000] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.

This started in Dapper, and continues in Feisty, but not in Windows XP.

The mouse moves erratically around the screen, any icons or links that it passes over, it opens. I've seen many references to this error message, but no solutions. I've tried USB mice, but they give other errors, which are under investigation already.

Thanks for taking the time to report this bug. Unfortunately we can't fix it, because your description doesn't yet have enough information.

Please include the following additional information, if you have not already done so (please pay attention to lspci's additional options), as required by the Ubuntu Kernel Team:
1. Please include the output of the command "uname -a" in your next response. It should be one, long line of text which includes the exact kernel version you're running, as well as the CPU architecture.
2. Please run the command "dmesg > dmesg.log" and attach the resulting file "dmesg.log" to this bug report.
3. Please run the command "lspci -vvnn > lspci-vvnn.log" and attach the resulting file "lspci-vvnn.log" to this bug report.

For your reference, the full description of procedures for kernel-related bug reports is available at [WWW] http://wiki.ubuntu.com/KernelTeamBugPolicies. Thanks in advance!

Changed in linux-source-2.6.20:
importance: Undecided → High
status: Unconfirmed → Needs Info
Dianne Reuby (pramclub) wrote :

uname:

2.6.20-16-generic #2 SMP Wed May 23 01:46:23 UTC 2007 i686 GNU/Linux

Dianne Reuby (pramclub) wrote :

Thank you, I'm marking this as confirmed.

Changed in linux-source-2.6.20:
status: Needs Info → Confirmed
Changed in linux-source-2.6.20:
assignee: nobody → ubuntu-kernel-team
buio (rb11520) wrote :

One of quick workarounds for this is to turn off wireless in Network manager.

Dianne Reuby (pramclub) wrote :

This seems to have decreased dramatically in Gutsy - I have had only one occurrence since upgrading. I don't have wireless networking.

buio (rb11520) wrote :

Unfortunately, when the wifi is on, the problem occurs quite often. See attachment.

buio (rb11520) wrote :

For reference: laptop Acer Aspire 5030 AMD Turion 64bit (32 bit Ubuntu installed), wifi broadcom 4318, using restricted drivers for broadcom and ati mobility radeon (fglrx)

racoon97 (racoon97) wrote :

Same problem with PS2 mouse Logitech on Ubuntu Gutsy. No wifi. Mouse try to close session.
uname -a :
2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

Istrebitjel (madeingermany) wrote :

Same here, a compaq hp nc6000 with wifi on - the mouse is a built-in touchpad/trackman.... don't know how I could exchange that.... on Gutsy:
Linux marco-laptop 2.6.22-14-generic #1 SMP Tue Dec 18 08:02:57 UTC 2007 i686 GNU/Linux

Dianne Reuby (pramclub) wrote :

Since the update before last (24 January) this has increased a lot - as bad as on Fiesty again now.

Andriy Tymchenko (silpol) wrote :

I have same problem after latest kernel upgrade few days ago.

after load is done, it looks like this in logs
--------------------
[ 139.756000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[ 140.260000] psmouse.c: resync failed, issuing reconnect request
[ 404.680000] psmouse.c: bad data from KBC - timeout
[ 550.544000] psmouse.c: bad data from KBC - timeout
[ 1277.988000] psmouse.c: bad data from KBC - timeout
[ 1458.448000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[ 1458.952000] psmouse.c: resync failed, issuing reconnect request
[ 2925.460000] psmouse.c: bad data from KBC - timeout
[ 2972.748000] psmouse.c: bad data from KBC - timeout
[ 2973.608000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[ 2974.112000] psmouse.c: resync failed, issuing reconnect request
[ 3137.368000] psmouse.c: bad data from KBC - timeout
[ 3457.800000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
[ 3458.304000] psmouse.c: resync failed, issuing reconnect request
[ 4711.216000] psmouse.c: bad data from KBC - timeout
[ 4712.100000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[ 4712.604000] psmouse.c: resync failed, issuing reconnect request
[ 4721.920000] psmouse.c: bad data from KBC - timeout
[ 4722.700000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[ 4723.208000] psmouse.c: resync failed, issuing reconnect request
[ 4730.996000] input: PS/2 Logitech Wheel Mouse as /class/input/input7
[ 4731.012000] psmouse.c: Failed to enable mouse on isa0060/serio1
[ 4733.012000] input: ImPS/2 Logitech Wheel Mouse as /class/input/input8
[ 4748.208000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
[ 4748.716000] psmouse.c: resync failed, issuing reconnect request
[ 4826.408000] psmouse.c: bad data from KBC - timeout
[ 5107.752000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[ 5109.124000] psmouse.c: resync failed, issuing reconnect request
[ 5300.528000] psmouse.c: bad data from KBC - timeout
[ 5301.292000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
[ 5301.800000] psmouse.c: resync failed, issuing reconnect request
[ 5370.988000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
[ 5371.496000] psmouse.c: resync failed, issuing reconnect request
[ 5609.744000] input: ImPS/2 Logitech Wheel Mouse as /class/input/input9
[ 5896.732000] psmouse.c: bad data from KBC - timeout
[ 5897.540000] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[ 5898.044000] psmouse.c: resync failed, issuing reconnect request
--------------------

--------------------
/tmp$ uname -a
Linux xenia 2.6.22-14-386 #1 Fri Feb 1 04:32:03 UTC 2008 i686 GNU/Linux
--------------------

lspci added as attach

rebroad (rebroad) wrote :

This seems to be a problem cause by typing - it has actually happened twice now just during typing into the comment box for this bug - both times causing the text to be highlighted, and subsequently deleted by the next key press! Also, the mouse appears to be clicking (and right-clicking) at random, and also moving slowly in a diagonal direction for up to a few seconds (either down-left or up-right usually).

After the problem has happened, I lose the ability to click on dialogue boxes or to raise certain windows, but some mouse actions still appear to work. The only wait to gain (albeit temporarily) full mouse functionality is to CTRL-ALT-F1 to a text console and CTRL-ALT-F7 back to my X session.

Not entirely sure if this bug I'm describing here is exactly the same bug, but I certainly seem to be getting the same errors appearing in dmesg (attached) as has been described by other people. Whether this be causation or correlation, I'm not certain.

rebroad (rebroad) wrote :

Futher to my last comment - after the unwanted mouse events have passed, any further clicking of the mouse (e.g. on the applet bar at the bottom of the screen to raise a different window), all clicks behave as if they were entered in the currently selected window, highlighting all the text in the currently selected window. (How would this normally be achieved?). In order to successfully click on the applet bar, I have to switch to a different console window and back again (as mentioned in my previous comments).

rebroad (rebroad) wrote :

I just noticed the 2.6.20 in the url of this bug. I should point out that uname -a reveals "2.6.15-51-686", so apologies if my comments are being put in the wrong place!

The Hardy Heron 8.04 Alpha series is currently under development and contains an updated version of the kernel. It would be helpful if everyone could test the latest Hardy Alpha release: http://www.ubuntu.com/testing . You should be able to then test the new kernel via the LiveCD. If you can, please verify if this bug still exists or not and report back your results. Thanks.

Changed in linux-source-2.6.20:
status: Confirmed → Incomplete
Istrebitjel (madeingermany) wrote :

Thanks, Leann. I have alpha 6 running from live cd for some hours now and have not encountered any mouse trouble.
Linux ubuntu 2.6.24-11-generic #1 SMP Fri Feb 29 22:08:31 UTC 2008 i686 GNU/Linux

(Just that it seems to randomly switch to the Amharic keyboard layout ኢስ አ ቢት ስትራንገ) ;)

I'll keep you posted if the symptoms are really gone.
But please somebody else, give it a go as well!

Thanks!

BC7333 (brian-abtrafco) wrote :

Linux brian-laptop 2.6.24-12-rt #1 SMP PREEMPT RT Thu Mar 13 00:49:29 UTC 2008 i686 GNU/Linux

Hardy beta

experiencing this quite frequently.

iwl3945 intel pro wireless

Mar 24 13:35:26 brian-laptop kernel: [ 3674.896275] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.
Mar 24 13:35:26 brian-laptop kernel: [ 3674.983841] psmouse.c: resync failed, issuing reconnect request

happens very frequently, probably two or three times worse than with Gutsy.

Often Firefox will simply close and programs in the menu will appear.

brian@brian-laptop:~$ lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 01)
06:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

bigoperm (bigoperm) wrote :

Happens to me as well:

<pre>
>$ uname -a
Linux photon 2.6.22-14-generic #1 SMP Tue Feb 12 07:42:25 UTC 2008 i686 GNU/Linux
</pre>

I hope a fix to this comes quick. Not knowing what you're mouse is going to do from one second to the next is not fun.

Hi,

BC7333 - care to open a new bug report. The errors you are getting appear to be different than the original bug reporters. It's helpful to the development teams if bug reports target a specific issues against a specific set of hardware. We can easily mark reports as duplicates later on if necessary. In your new bug report if you could include all of the information outlined here: https://wiki.ubuntu.com/KernelTeamBugPolicies . Thanks.

bigoperm - your `uname -a` output shows you are still running a Gutsy kernel. Please test with the latest Hardy Beta release - www.ubuntu.com/testing. Thanks.

BC7333 (brian-abtrafco) wrote :

Leann,

Thanks for the kind tip. Added new bug https://bugs.launchpad.net/ubuntu/+bug/206761

armlis (armlis) wrote :

Hi,
I think I know the same bug. The mouse pointer move itself to some of the corners of the desktop and frenetically click either left or right button while approximately one second.
I can add that the keyboard may seem to press itself some of the last "really key pressed".

Of course.. all possible actions which were met in the mouse path happens : software close, some other "open with", gnome-session stop etc...) all that depending on what's on your desktop at this time (and the icons or applet in your desktop corners).

All worked fine for several months ; I do apply all official updates as soon as they come and have just updgraded to Hardy as adviced here. (nice to meat hardy)
The bug began for me near the 2008 march 15 (after an update?)

# uname -a
Linux armlis-desktop 2.6.24-12-generic #1 SMP Wed Mar 12 23:01:54 UTC 2008 i686 GNU/Linux

syslog always says that à the exact time of "this event" :
Mar 26 19:27:34 armlis-desktop kernel: [17987.676881] psmouse.c: bad data from KBC - bad parity
Mar 26 19:27:37 armlis-desktop kernel: [17990.868239] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.

Matt LaPaglia (mlapaglia) wrote :

This happens to me as well, i also have the ipw3945 wireless card. It seems to happen always at startup, when the desktop is first loading, but it rarely happens afterwards for me. I get the same error as armlis in my dmesg.

Matt LaPaglia (mlapaglia) wrote :

Sorry, I meant to mention I was using the hardy beta. This doesn't happen to me when I am running gutsy.

Matt LaPaglia (mlapaglia) wrote :

Does it matter that I have a synaptic touchpad but i'm getting ps2 errors?

Changed in linux-source-2.6.20:
status: Incomplete → Triaged
exactt (giesbert) wrote :

This happens to me as well, i also have the ipw3945 wireless card. It seems to happen always at startup, when the desktop is first loading, but it rarely happens afterwards for me. Using latest hardy. This didn't happen to me when I was running gutsy.

Changed in linux-source-2.6.24:
status: New → Confirmed
Changed in linux:
assignee: nobody → ubuntu-kernel-team
importance: Undecided → Medium
status: Confirmed → Triaged
armlis (armlis) wrote :

Sorry but i can't figure out why, but this bug has gone away for 2 or 3 days...
(I had a HardDrive disfonction that obliged me to boot on Gutsy Live-CD .. and what was my surprise : (without any mounted drive), my mouse gone away as discribed in here... ??? HELP)
I can't believe it. Would this be a material fact ? (I'd hope it would)

I really don't know why. This hasard seems so weird. (any kernel seems to be affected by this trouble)

 Leann.. how can I (we) help you ? (Material description ? WireLess ? I don't think so 'cause i'm not wifi equiped, but why not.. who knows... héhé))
Thank you anyway.

Dianne Reuby (pramclub) wrote :

For me, this seems to be related to the hardware of the mouse - if the cable catches on something, or is in certain positions, although I've tried several mice. Some days it's much worse than others.

Matt LaPaglia (mlapaglia) wrote :

Hm, when I use regular usb and bluetooth mice I don't seem to have any problem, it's only when I use the touchpad built into the laptop.

Maybe these are two separate problems?

Matt LaPaglia (mlapaglia) wrote :

Not to flood this thread, but this just happened to me after system startup (when it has previously only affected me.)

I opened up a 30mb .avi file into the default movie player, and when it fullscreened the mouse started jumping everywhere.

Matt LaPaglia (mlapaglia) wrote :

disabling acpi makes my touchpad work correctly at startup.

exactt (giesbert) wrote :

can confirm that "disabling acpi makes my touchpad work correctly at startup".
still this bug is a regression from gutsy.

exactt (giesbert) wrote :

this looks like a dup of #109326

Matt LaPaglia (mlapaglia) wrote :

exactt-
I would agree based on the "throwing away 2 bytes" part of that bug.

Also, I added "acpi_osi=Linux" in place of disabling acpi, and it makes the problem go away. No other devices seem to be negatively affected, and nothing weird shows up in dmesg.

Matt LaPaglia (mlapaglia) wrote :

any updates?

Mladen Jablanović (jablan) wrote :

Same problem, Ubuntu Hardy:

jablan@jablan-desktop:~$ uname -a
Linux jablan-desktop 2.6.24-16-generic #1 SMP Thu Apr 10 13:23:42 UTC 2008 i686 GNU/Linux

jablan@jablan-desktop:~$ cat /proc/version_signature
Ubuntu 2.6.24-16.30-generic

jablan@jablan-desktop:~$ dmesg | tail
[23578.339245] psmouse.c: bad data from KBC - bad parity
[23580.656852] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[33619.801237] psmouse.c: bad data from KBC - bad parity
[33621.410535] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[34156.690960] psmouse.c: bad data from KBC - bad parity
[34161.518525] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[34525.280931] psmouse.c: bad data from KBC - bad parity
[34528.304099] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[40697.503189] psmouse.c: bad data from KBC - bad parity
[40699.647446] psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.

FurYy (jack-un) wrote :

Hope that this gets fixed soon. Old gutsy kernel seemed fine.

[ 130.843926] psmouse.c: failed to re-enable mouse on isa0060/serio1
[ 130.843932] psmouse.c: resync failed, issuing reconnect request
[ 131.468100] psmouse.c: Wheel Mouse at isa0060/serio4/input0 lost synchronization, throwing 2 bytes away.

FurYy (jack-un) wrote :

Dmesg too

FurYy (jack-un) wrote :

Forgot.

cat /proc/version_signature
Ubuntu 2.6.24-18.32-generic

Thanks to Matt LaPaglia (2008-04-18):

Adding "acpi_osi=Linux" to my grub kernel parameters solved the problem for me.

I had this problem in Gutsy and (now) Hardy.

Linux gitz-t5600 2.6.24-18-generic #1 SMP Wed May 28 20:27:26 UTC 2008 i686 GNU/Linux

Compal EL80, IPW3945, NVidia GeForce Go 7600

/proc/bus/input/devices:
I: Bus=0011 Vendor=0002 Product=0005 Version=0063
N: Name="ImPS/2 Logitech Wheel Mouse"
P: Phys=isa0060/serio4/input0
S: Sysfs=/devices/platform/i8042/serio4/input/input8
U: Uniq=
H: Handlers=mouse1 event8
B: EV=7
B: KEY=70000 0 0 0 0 0 0 0 0
B: REL=103

Changed in linux:
status: Unknown → In Progress
Changed in linux-source-2.6.24:
status: New → Invalid
Steve Langasek (vorlon) on 2008-10-14
Changed in linux-source-2.6.20:
status: Triaged → Invalid
23 comments hidden view all 103 comments
Thomas (tjustleft) wrote :

I am running hardy 8.04.2 2.6.24-23-generic. For a week or more my optical wheel mouse is going crazy too. It will stop responding or just fly around and right click on it's own. I tried another one but it didn't help.

Syslog shows errors:
[ 9918.582579] psmouse.c: bad data from KBC - timeout
[ 9988.492592] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[ 9993.100946] psmouse.c: resync failed, issuing reconnect request

[16228.424932] psmouse.c: failed to re-enable mouse on isa0060/serio1

The same for messages log.

This is a fairly fresh install of Ubuntu. I did reinstall because of another problem where mouse and keyboard will stop responding when using firefox or opera. Freeze is so bad That I have to unplug the computer. Reinstall did not help.

1 comments hidden view all 103 comments
Morgan Olausson (ol-morgan) wrote :

Hi, I just wanted to say that the problem I had with my mouse in this bug is solved.
The problems disappeared when I changed the mouse-cable.

Thomas (tjustleft) wrote :

I posted that I was having these mouse problems. Also that I was having a problem where mouse and keyboard will stop responding when using firefox or opera. Freeze is so bad That I have to unplug the computer. Reinstall did not help.

I thought these were unrelated, at least in my case. It turns out they may be related. I tried a third mouse. One with a, gasp, ball. While response feels clunky compared to what I was used to with an optical mouse the freezes and erratic mouse pointer have gone away. This includes no more mouse errors in logs.

Is it possible that Ubuntu is having problems with optical mice? If any of you have a ball type mouse give it a try. Please post if this does or doesn't stop erratic mouse and errors.

Timo Salokas (timo-salokas) wrote :

Hi Thomas,

I also noticed the same thing. As I got tired of the optical mouse's erratic actions I fired up the ol' Cordless MouseMan Wheel. It works perfectly - for a ball'd mouse.

But this is not the whole story. I'm a dual booter... yes, it's the games, and noticed that the optical mouse would shut itself off from time to time in Windows also! With an exception that Windows didn't recover as good as Kubuntu did. I had to disconnect the cable and put it back in, with a prey it worked for a while but not always. I tried searching the cable for a magic spot with some serious twisting sessions but ended up with frustration. It was the cord, I knew it, but I had nothing to prove it as to where the faulty spot was.

In conclusion, I'm now using ball mouse but will buy an optical one in the near future. I'm however confident that my problem was inside the mouse's cable, although I could not replicate the incident in a more sophisticated manner.

pinzia (pinzia) wrote :

I have same problem with karmic KDE and ps/2 optical mouse

[ 4912.987223] psmouse.c: bad data from KBC - bad parity
[ 4918.016382] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[ 4918.023332] psmouse.c: resync failed, issuing reconnect request
[ 4918.157955] psmouse serio1: ID: 10 00 64

Pako (elektrobank01) wrote :
Download full text (3.6 KiB)

Same here Karmic RC:[ 1016.230996] psmouse serio1: ID: 10 00 64
[ 1016.290356] logips2pp: Detected unknown logitech mouse model 115
[ 1255.921688] psmouse.c: bad data from KBC - bad parity
[ 1256.586710] psmouse.c: Explorer Mouse at isa0060/serio1/input0 lost synchronization, throwing 1 bytes away.

And here are the kernel logs with mouse plugged directly into USB port without adapter:

Oct 29 13:51:50 amd2-desktop kernel: [ 67.360047] usb 3-1: USB disconnect, address 2
Oct 29 13:51:50 amd2-desktop kernel: [ 67.600038] usb 3-1: new low speed USB device using uhci_hcd and address 3
Oct 29 13:51:50 amd2-desktop kernel: [ 67.777114] usb 3-1: configuration #1 chosen from 1 choice
Oct 29 13:51:50 amd2-desktop kernel: [ 67.800391] input: Logitech USB-PS/2 Optical Mouse as /devices/pci0000:00/0000:00:10.1/usb3/3-1/3-1:1.0/input/input5
Oct 29 13:51:50 amd2-desktop kernel: [ 67.800505] generic-usb 0003:046D:C050.0002: input,hidraw0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:10.1-1/input0
Oct 29 13:51:56 amd2-desktop kernel: [ 73.812051] usb 3-1: USB disconnect, address 3
Oct 29 13:51:58 amd2-desktop kernel: [ 76.032042] usb 3-1: new low speed USB device using uhci_hcd and address 4
Oct 29 13:51:58 amd2-desktop kernel: [ 76.209019] usb 3-1: configuration #1 chosen from 1 choice
Oct 29 13:51:58 amd2-desktop kernel: [ 76.231280] input: Logitech USB-PS/2 Optical Mouse as /devices/pci0000:00/0000:00:10.1/usb3/3-1/3-1:1.0/input/input6
Oct 29 13:51:58 amd2-desktop kernel: [ 76.231396] generic-usb 0003:046D:C050.0003: input,hidraw0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:10.1-1/input0
Oct 29 13:52:06 amd2-desktop kernel: [ 83.728076] usb 3-1: USB disconnect, address 4
Oct 29 13:52:07 amd2-desktop kernel: [ 85.088022] usb 3-1: new low speed USB device using uhci_hcd and address 5
Oct 29 13:52:07 amd2-desktop kernel: [ 85.264787] usb 3-1: configuration #1 chosen from 1 choice
Oct 29 13:52:07 amd2-desktop kernel: [ 85.288089] input: Logitech USB-PS/2 Optical Mouse as /devices/pci0000:00/0000:00:10.1/usb3/3-1/3-1:1.0/input/input7
Oct 29 13:52:07 amd2-desktop kernel: [ 85.288201] generic-usb 0003:046D:C050.0004: input,hidraw0: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on usb-0000:00:10.1-1/input0
Oct 29 13:52:21 amd2-desktop kernel: [ 98.608042] usb 3-1: USB disconnect, address 5
Oct 29 13:52:21 amd2-desktop kernel: [ 98.880031] usb 3-1: new low speed USB device using uhci_hcd and address 6
Oct 29 13:52:21 amd2-desktop kernel: [ 99.028864] usb 3-1: device descriptor read/all, error -71
Oct 29 13:52:21 amd2-desktop kernel: [ 99.084071] hub 3-0:1.0: unable to enumerate USB device on port 1
Oct 29 13:52:22 amd2-desktop kernel: [ 99.548036] hub 3-0:1.0: unable to enumerate USB device on port 1
Oct 29 13:52:22 amd2-desktop kernel: [ 100.088026] usb 3-1: new low speed USB device using uhci_hcd and address 9
Oct 29 13:52:22 amd2-desktop kernel: [ 100.264813] usb 3-1: configuration #1 chosen from 1 choice
Oct 29 13:52:22 amd2-desktop kernel: [ 100.288116] input: Logitech USB-PS/2 Optical Mouse as /devices/pci0000:00/0000:00:10.1/usb3/3-1/3-1:1.0/input/input8
Oct...

Read more...

Damjan Jovanovic (damjan-jov) wrote :

I've added a patch to the relevant kernel bug (http://bugzilla.kernel.org/show_bug.cgi?id=6105) that mostly fixes this. Some assistance would be appreciated.

pinzia (pinzia) wrote :

any news on this?

utkatubuntu (just-utkarsh) wrote :

i am on karmic 2.6.31-17-generic latest kernel version and tried following things
1. adding i8042.nomux=1 as kernel boot options
2. acpi_osi=Linux as kernal boot options
3.sudo rmmod psmouse && sudo modprobe psmouse
4.installing xfree86-driver-synaptics instead of xserver-xorg-input-synaptics
  after seeing duplicates i think this bug is not usb mouse or touchpad specific
5.as a desperate measure added following to /etc/modprobe.d/options.conf
   "options psmouse resetafter=10" but this even worsens the situation

this problem pops up randomly, mostly followed by ipw2200 firmware error.
interestingly it occurs mostly at office wifi network not at all home network.

Bal (bal) wrote :

 I recently bought 2000 pcs mice from manufacturer in China for sales in Nepal. Have been using Linux for more than 10 years, never though PS/2 mouse wouldn't work on latest kernels. My display box says "Tested on Debian/Ubuntu". Shocked to say that it does not work in Debian Squeeze/Sid. Kernels tested, 2.6.32, 2.6.33 etc. It works OK on FC4 with custom built kernel 2.6.20 and WinXP flowlessly. Other cheap ps2 mice work OK in this system. Tried everything acpi, demux, etc. Issue is exactly as stated in this bug. Has following hardware in my system.

bal@head:~$ lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev a3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev a2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev a3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev a2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev a3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:07.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev 80)
01:08.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
05:00.0 VGA compatible controller: ATI Technologies Inc RV380 0x3e50 [Radeon X600]
05:00.1 Display controller: ATI Technologies Inc RV380 [Radeon X600] (Secondary)

 bal@head:~$ dmesg | grep mouse
[ 0.835005] mice: PS/2 mouse device common for all mice
[ 62.324146] psmouse.c: bad data from KBC - timeout
[ 133.292295] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[ 133.797623] psmouse.c: resync failed, issuing reconnect request
[ 141.192457] psmouse.c: bad data from KBC - timeout
[ 665.190026] psmouse.c: bad data from KBC - timeout
[ 1467.194410] psmouse.c: bad data from KBC - timeout

 It does all kind of wierd things when plugged in. Creating new "untitled folders" clustered on the upper right corner and open files and many wierd thngs.

Any help would be appreciated.

Thanks

Damjan Jovanovic (damjan-jov) wrote :

Hi Bal

Please try to recompile the psmouse kernel module with the patch on the kernel bug for this, the link to it is http://bugzilla.kernel.org/attachment.cgi?id=25282

Let me know if it works.

Thank you
Damjan

Bal (bal) wrote :

Hi Damjan,

Thank you for the patch but it did not work. Applied the patch, one hunk did not patch properly, manually added the line to pamouse-bace.c (psmouse->badchecksum = 0;) for that particular hunk. The modules compiled OK, but did not load for some reason, I must have done something wrong when only compiling psmouse.ko module. So I downloaded the 2.6.33 again, patched the tree with latest patches, 2010-03-03. Then patched with above psmouse patch. And compiled the whole thing again.

Everything went OK. New Kernel is working perfectly, except for my PS2 Mouse. dmesg shows

[ 0.834356] mice: PS/2 mouse device common for all mice
[ 129.761657] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 3 bytes away.
[ 130.265621] psmouse.c: resync failed, issuing reconnect request

This is a cheap mouse, but it works in other systems. Other PS2 work in my system too, Too confused!!

Sincerely

Bal

Damjan Jovanovic (damjan-jov) wrote :

Sorry Bal, that patch only addressed bad parity, your problem is timeouts instead.

Please try this new patch which addresses both.

tags: added: patch
Bal (bal) wrote :

Damjan,

Sorry to report that the new patch did not solve the problem. But seems like different input device was created this time.

[ 8.046716] input: ImPS/2 Generic Wheel Mouse as /devices/platform/i8042/serio1/input/input4
[ 64.276355] psmouse.c: bad data from KBC - timeout

Mouse does exactly the same thing. Here is the picture of my desktop, please take a look at the continuous creation of untitled folders on right side of my desktop until I plug out the mouse.

http://attaritech.net/errors/crazy_mouse.png

Thank you for taking time to solve this!

Bal

Damjan Jovanovic (damjan-jov) wrote :

Bal

Please try the following patch:
http://bugzilla.kernel.org/attachment.cgi?id=23750

If that doesn't work, try commenting out that entire "if" block marked with leading +'s in http://bugzilla.kernel.org/show_bug.cgi?id=6105#c37

If that still doesn't work, it may be a problem with your i8042 hardware. Can you reproduce this on a different motherboard? Go back to the unpatched psmouse driver, boot your kernel with the i8042.debug parameter, and attach the dmesg.

Bal (bal) wrote :

Damjan,

None of the above patches worked. All produced same condition. Here is the debug info with "i8042.debug" enabled with unpatched Debian kernel, but without the problem mouse attached. If you need that please let me know.

I haven't got another same motherboard. This mouse works on XP and FC4. I will try with Lenny stable sometime later today (I have a hard disk with Lenny installed and an extra Intel mother board, but that one is in disassembled condition.

What is surprising is : other PS2 mice work in this system too!!

Thank you!

Damjan Jovanovic (damjan-jov) wrote :

Bal,

The i8042.debug needs to be done with the mouse that breaks, and needs to include the time period during which the mouse broke.

When the mouse breaks, does it eventually settle if you leave it alone for a few seconds, or does it stay broken until you unplug it? My patches could affect this.

I'll send a patch that ignores the interrupt data if there is a timeout. I have no idea what it will do but let's see. Please try it.

Bal (bal) wrote :

Damjan,
I will try this latest patch in a moment. To answer the question: when I turn on computer with the problem mouse attached, it starts going crazy the first time I move and stays that way forever, until I unplug the cable.

It behaves same way with or without patched kernels.

Here is the dmesg with the problem mouse attatched. also a small part of "kern.log" attached.

Bal (bal) wrote :

dmesg log with the problem mouse attached.

Bal (bal) wrote :

This dmesg is at the begining after the boot process is complete. The above one is was after I plugged back after the first unplug.

Bal (bal) wrote :

Dear Damjan,

skip the PS/2 interrupt data on timeouts did not do anything to solve this problem. how do we proceed now?

Thank you!

Damjan Jovanovic (damjan-jov) wrote :

Bal

I am pretty sure that your problem is elsewhere, maybe in the i8042 driver. Do other computers exhibit the same problem with that mouse?

There's a final patch I can try to send you, which will freeze the mouse for a few seconds and reset it completely, but that's really a last resort.

Bal (bal) wrote :

Dear Damjan,

Yes, you are right, I don't think it's psmouse driver. It all points to some kind of hardware mismatch between my mouse and this particular computer. I would give up for "bad motherboard" or something like that if ohter ps2 mice did not work here.

This mouse works perfectly in another motherboard (Intel G30) in Lenny latest kernel 2.6.26 . In that computer I installed latest kernel this morning with the kernel patches applied (but not psmouse patches in this page). The mouse works OK with this too, 2.6.34-rc1-next-20100310+.

Then in the nvidia board (my problem motherboard) I did the same thing again, recompiled the kernel 2.6.34-rc1-next-20100310+ and it still does not work. same thing.

Some issues "impossible to figure out"

Bal (bal) wrote :

Hi Damjan,

I figured out this mouse did not work with some other boards too. In some boards no cursor at all, in others like described above, it went crazy. I found that this was no software issue, it did not matter what OS you used, it only mattered what motherboards you used.

When I had thousands of one particular type of Intel G31 chipset boards in my stock for which this mouse did not work, I had to find exactly what was it. It was the controller IC that is NOT COMPATIBLE (what's the reason?) with some boards, both cheap and expensive.

The problem controller IC was: MX84511FP. I replaced this IC with MX84521FP (without touching anything else), the mouse works like the best mouse in the world in all boards that I can test.

Thanks

Bal

papukaija (papukaija) wrote :

This bug seems to be fixed in Lucid.

Damjan Jovanovic (damjan-jov) wrote :

No, this bug is definitely not fixed in Lucid.

Damjan Jovanovic (damjan-jov) wrote :

This bug is now fixed in the latest Linux kernel git. Please backport to Lucid and earlier?

commit 6b9d363c49d22395d0cf8729c5963f83cfbb6d69
Author: Dmitry Torokhov <email address hidden>
Date: Mon Apr 19 00:42:16 2010 -0700

    Input: psmouse - ignore parity error for basic protocols

    Observing behavior of the other OS it appears that parity errors reported
    by the keyboard controller are being ignored and the data is processed
    as usual. Let's do the same for standard PS/2 protocols (bare, Intellimouse
    and Intellimouse Explorer) to provide better compatibility. Thsi should fix
    teh following bug:

        https://bugzilla.kernel.org/show_bug.cgi?id=6105

    Thanks for Damjan Jovanovic for locating the source of issue and ideas
    for the patch.

    Tested-by: Damjan Jovanovic <email address hidden>
    Signed-off-by: Dmitry Torokhov <email address hidden>

David Stansby (dstansby) on 2010-07-20
tags: added: patch-forwarded-upstream
removed: patch
papukaija (papukaija) wrote :

Please don't remove the patch tag.

tags: added: patch
tags: added: dapper edgy feisty gutsy hardy intrepid jaunty karmic lucid
summary: - [hardy] ps2 mouse erratic - parity errors - lost synchronization errors
+ ps2 mouse erratic - parity errors - lost synchronization errors
pinzia (pinzia) wrote :

I haven't had this bug on maverick yet.
Fixed for me.
Thank's

Ignacio Larrain (ilarrain) wrote :

I'm having this issue on Maverick. It appears to be related to my recent switch between Broadcom STA wireless proprietary module (wl) to the more open b43.

papukaija (papukaija) on 2010-10-16
tags: added: maverick
Selmi (selmi) wrote :

still happens on maverick. i noticed it happens much more often if cpu is busy and there is also big network traffic. for example when i have rhytmbox playing in background, i am running eclipse, android emulator and i am also downloading something on background that it happens every few minutes

i didn't tried solution "# defoptions=quiet splash acpi_osi=Linux in /boot/grub/menu.lst and then run update-grub" because in grub2 there is no such file and i am not sure where to write it so it won't be overwritten

papukaija (papukaija) wrote :

Ubuntu won't get the fix until this bug is fixed by upstream (the upstream bug is linked to this bug - see the affects Linux entry at the top of this page).

Luis Mondesi (lemsx1) wrote :

I get this same behavior on an OQO (netbook-like device) whenever I hibernate the system.

I think in grub 2 it is in /etc/default/grub

On Oct 17, 2010 6:21 AM, "Selmi" <email address hidden> wrote:

still happens on maverick. i noticed it happens much more often if cpu
is busy and there is also big network traffic. for example when i have
rhytmbox playing in background, i am running eclipse, android emulator
and i am also downloading something on background that it happens every
few minutes

i didn't tried solution "# defoptions=quiet splash acpi_osi=Linux in
/boot/grub/menu.lst and then run update-grub" because in grub2 there is
no such file and i am not sure where to write it so it won't be
overwritten

--
ps2 mouse erratic - parity errors - lost synchronization errors
https://bugs.launchpad.net/bugs...

Luis Mondesi (lemsx1) wrote :

The following workaround worked for me:

sudo apt-get install acpi-support swsusp

Then edit /etc/default/acpi-support

MODULES="ppp_async ath5k psmouse"
MODULES_WHITELIST=""

Changed in linux:
status: In Progress → Fix Released
Changed in linux:
importance: Unknown → Medium
Opvolger (opvolger) wrote :

I have the problem with my computer (10.10), laptop's(10.04 and 9.10) and now with my new installed server (10.04):

[15923.549889] psmouse.c: bad data from KBC - bad parity
[15923.551426] psmouse.c: bad data from KBC - bad parity
[15926.500924] psmouse.c: Wheel Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.

Mouse is crazy, clicking en all over the screen.

Linux server-client-desktop 2.6.32-28-generic #55-Ubuntu SMP Mon Jan 10 21:21:01 UTC 2011 i686 GNU/Linux

papukaija (papukaija) wrote :

Removing the patch tag since the patch is forwarded upstream. Btw, the upstream fix went probably to Natty. Please confirm.

tags: removed: patch

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Triaged → Won't Fix
Displaying first 40 and last 40 comments. View all 103 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.