Linux-tools should be available for all kernel flavors.

Bug #824610 reported by Jani Monoses on 2011-08-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Linux
Fix Released
Undecided
Unassigned
Linaro Ubuntu
High
John Rigby
linaro-landing-team-arm
Fix Released
Medium
Tixy (Jon Medhurst)
linaro-landing-team-samsung
Fix Released
Medium
Angus Ainslie
linaro-landing-team-ti
Invalid
Undecided
Unassigned

Bug Description

It appears that unlike the Ubuntu ARM kernels, the linaro ones do not provide the corresponding linux-tools package that contains perf.

Revision history for this message
Dave Martin (dave-martin-arm) wrote : Re: [Bug 824610] [NEW] build linux-tools

> It appears that unlike the Ubuntu ARM kernels, the linaro ones do not
> provide the corresponding linux-tools package that contains perf.

Don't we build linux-linaro-tools-* packages?

It would be nice if there was an easier way to the correct thing via
a generic dependency package though.

Cheers
---Dave

Revision history for this message
Jani Monoses (jani) wrote : Re: build linux-tools

I expected a linux-tools-linaro with linaro as a suffix as with the image and headers packages. I'll need to test one that matches my linaro kernel version then.

Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → High
milestone: none → 11.08
assignee: nobody → John Rigby (jcrigby)
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Can confirm that we're missing the linux-tools package for the TI LT kernel:

Built packages:
kernel-image-3.0.0-1402-linaro-lt-omap-di
linux-headers-3.0.0-1402
linux-headers-3.0.0-1402-linaro-lt-omap
linux-image-3.0.0-1402-linaro-lt-omap

Confirmed the bug with 11.08 RC.

summary: - build linux-tools
+ Linux-tools should be available for all kernel flavors.
Changed in linaro-ubuntu:
status: Confirmed → Fix Released
Revision history for this message
John Rigby (jcrigby) wrote :

TI LT has tools as of version 3.0.0-1402

Revision history for this message
Ricardo Salveti (rsalveti) wrote :

The linux-tools package is missing from the STE and Samsung LT kernel packages. For freescale it just need a better naming, as it's currently linux-linaro-tools-3.1.0-1002 (but should be linux-linaro-lt-mx5-tools-3.1.0-1002).

If you need any help enabling the tools package, please ping jcrigby directly at IRC.

Anmar Oueja (anmar) on 2011-12-02
Changed in linaro-landing-team-ste:
assignee: nobody → Lee Jones (lag)
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

For the LT TI kernel package this is not an issue, the package is already properly generated:
linux-linaro-lt-omap-tools-3.1.0-1402 Linux kernel tools for version 3.1.0-1402

Changed in linaro-landing-team-ti:
status: New → Invalid
Revision history for this message
Paweł Moll (pawel-moll) wrote :

Clean installation of http://releases.linaro.org/images/11.11/oneiric/nano/panda-nano.img.gz:

Welcome to Linaro 11.11 (GNU/Linux 3.1.0-1402-linaro-lt-omap armv7l)
[...]
root@linaro-nano:~# apt-get update
[...]
Fetched 1708 kB in 4s (346 kB/s)
Reading package lists... Done
root@linaro-nano:~# uname -a
Linux linaro-nano 3.1.0-1402-linaro-lt-omap #5~oneiric1-Ubuntu SMP PREEMPT Sat Nov 19 05:23:05 UTC 2011 armv7l armv7l armv7l GNU/Linux
root@linaro-nano:~# apt-get install linux-tools
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libdw1 libelf1 linux-tools-3.0.0-13 linux-tools-common
The following NEW packages will be installed:
  libdw1 libelf1 linux-tools linux-tools-3.0.0-13 linux-tools-common
0 upgraded, 5 newly installed, 0 to remove and 1 not upgraded.
Need to get 534 kB of archives.
After this operation, 1450 kB of additional disk space will be used.
Do you want to continue [Y/n]?
[...]
root@linaro-nano:~# perf
perf_3.1.0-1402 not found
You may need to install linux-tools-3.1.0-1402
root@linaro-nano:~# apt-get install linux-tools-3.1.0-1402
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-tools-3.1.0-1402
E: Couldn't find any package by regex 'linux-tools-3.1.0-1402'
root@linaro-nano:~#

Revision history for this message
Paweł Moll (pawel-moll) wrote :

Ah, I see, the package name is different than the suggested one... Not helpful, really ;-)

root@linaro-nano:~# apt-get install linux-linaro-lt-omap-tools-3.1.0-1402
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
  linux-linaro-lt-omap-tools-3.1.0-1402
0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
Need to get 243 kB of archives.
After this operation, 479 kB of additional disk space will be used.
Get:1 http://ppa.launchpad.net/linaro-maintainers/overlay/ubuntu/ oneiric/main l
inux-linaro-lt-omap-tools-3.1.0-1402 armel 3.1.0-1402.5~oneiric1 [243 kB]
Fetched 243 kB in 0s (489 kB/s)
Selecting previously deselected package linux-linaro-lt-omap-tools-3.1.0-1402.
(Reading database ... 9485 files and directories currently installed.)
Unpacking linux-linaro-lt-omap-tools-3.1.0-1402 (from .../linux-linaro-lt-omap-t
ools-3.1.0-1402_3.1.0-1402.5~oneiric1_armel.deb) ...
Setting up linux-linaro-lt-omap-tools-3.1.0-1402 (3.1.0-1402.5~oneiric1) ...
root@linaro-nano:~# perf

 usage: perf [--version] [--help] COMMAND [ARGS]

Revision history for this message
Ricardo Salveti (rsalveti) wrote : Re: [Bug 824610] Re: Linux-tools should be available for all kernel flavors.

On Tue, Dec 6, 2011 at 8:48 AM, Paweł Moll <email address hidden> wrote:
> Ah, I see, the package name is different than the suggested one... Not
> helpful, really ;-)

Yeah, that's a different issue, can you fill a bug for it?

Revision history for this message
Paweł Moll (pawel-moll) wrote :
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

On Tue, Dec 6, 2011 at 9:43 AM, Paweł Moll <email address hidden> wrote:
> https://bugs.launchpad.net/bugs/900704

Thanks Pawel!

Revision history for this message
Tixy (Jon Medhurst) (tixy) wrote :

How to fix this bug in landing team packaging...

Apply these two patches:
http://git.linaro.org/gitweb?p=people/jcrigby/linux-lt.git;a=commit;h=25db06de8a2f7d5e74dda28471141cd36450cb3a
http://git.linaro.org/gitweb?p=people/jcrigby/linux-lt.git;a=commit;h=4c0e3b7c14edefe75691eb00eac91b4fc8473f1f

Now building packages will require ARM libraries, for cross-building on an Oneiric PC the following _may_ work (please report success or failure)...

Add a line to /etc/apt/sources.list like this:
 deb [arch=armel] http://ports.ubuntu.com/ oneiric main restricted
Install ARM libraries with:
 sudo xapt -m -a armel binutils-dev libdw-dev
If the libraries don't install, then cross-building the tools package is not possible and you will need to temporarily disable this whenever building packages locally by setting "do_tools=false" in debian.linaro/rules.d/armel.mk

Question, does the tools package need adding to the hardware pack?

Changed in linaro-landing-team-arm:
assignee: nobody → Tixy (Jon Medhurst) (tixy)
status: New → In Progress
Revision history for this message
Tixy (Jon Medhurst) (tixy) wrote :

To answer my own question "does the tools package need adding to the hardware pack". The answer is no, because the tools package willl be added to the linux-image package as a Suggests package and so will be picked up automatically by hwpack-create and the image tools.

Changed in linaro-landing-team-arm:
importance: Undecided → Medium
milestone: none → 2011.12
Usman Ahmad (usman-ah) on 2011-12-08
Changed in linaro-landing-team-freescale:
assignee: nobody → Eric Miao (eric.y.miao)
Lee Jones (lag) on 2011-12-08
Changed in linaro-landing-team-ste:
status: New → Confirmed
importance: Undecided → High
status: Confirmed → In Progress
milestone: none → 2011.12
Changed in linaro-landing-team-samsung:
assignee: nobody → Angus Ainslie (angus-akkea)
Changed in linaro-landing-team-samsung:
status: New → Fix Committed
importance: Undecided → Medium
milestone: none → 2011.12
Changed in linaro-landing-team-arm:
status: In Progress → Fix Released
Eric Miao (eric.y.miao) on 2011-12-16
Changed in linaro-landing-team-freescale:
status: New → Fix Committed
importance: Undecided → High
milestone: none → 2011.12
Revision history for this message
Eric Miao (eric.y.miao) wrote :

Fixed in freescale landing team, the package is now linux-linaro-lt-mx5-tools-3.1.0-1002_3.1.0-1002.13_armel.deb. Although I'd recommend a more consistent naming like other kernel packages, e.g. linux-tools-{PKGVER}-{ABINUM}-{FLAVOR}, which we could do in next step.

Lee Jones (lag) on 2012-01-20
Changed in linaro-landing-team-ste:
status: In Progress → Fix Released
Changed in linaro-landing-team-samsung:
status: Fix Committed → Fix Released
Fathi Boudra (fboudra) on 2012-02-29
Changed in linaro-landing-team-freescale:
status: Fix Committed → Fix Released
Guodong Xu (guodong-xu) on 2012-04-20
tags: added: imx53
Linus Walleij (triad) on 2013-09-16
Changed in linux-linaro:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers