Multiple hwpacks do not boot correctly with ext4 rootfs

Bug #824545 reported by Jani Monoses on 2011-08-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Linux
Fix Released
Medium
Eric Miao
Linaro Ubuntu
High
John Rigby

Bug Description

these are the last logs when booting the current mx53loco hwpack using ext4 rootfs

udevd[56]: worker [118] did not accept message -1 (Connection refused), kill it

init: ureadahead main process (154) terminated with status 5
[ 6.476070] EXT4-fs (mmcblk0p3): Filesystem with huge files cannot be mounted RDWR without CONFIG_LBDAF
init: mounted-proc main process (160) terminated with status 1
mountall: Event failed
fsck from util-linux-ng 2.17.2
rootfs: clean, 22343/237568 files, 145718/950272 blocks
mount: cannot remount block device /dev/mmcblk0p3 read-write, is write-protected
mountall: mount / [201] terminated with status 32
mountall: Filesystem could not be mounted: /
An error occurred while mounting /
Press S to skip mounting or M for manual recovery

This problem is known to affect at least the mx53loco (at the time of the original bug report) and vexpress (as of 2011-08-24).

Judging based on the kernel packaging tree configs, the bug _probably_ also affects:
  * u8500 (all kernels)
  * s5pv310 (linux-linaro-natty only, up to at least Linux-linaro-2.6.38-1003.4)
  * mx51 (all kernels)
  * vexpress (regression in linux-linaro-oneiric only, up to at least Linux-linaro-3.0.0-1004.5)

Eric Miao (eric.y.miao) wrote :

The config option does need to be enabled for large files.

Changed in linux-linaro:
assignee: nobody → Eric Miao (eric.y.miao)
importance: Undecided → Medium
milestone: none → 11.08
status: New → Triaged
Jason Liu (r64343) wrote :

Let's see what CONFIG_LBDAF means:

CONFIG_LBDAF:Enable block devices or files of size 2TB and larger.This option is required to support the full capacity of large
(2TB+) block devices, including RAID, disk, Network Block
Device, Logical Volume Manager (LVM) and loopback.This option also enables support for single files larger than
2TB.The ext4 filesystem requires that this feature be enabled in
order to support filesystems that have the huge_file feature
enabled. Otherwise, it will refuse to mount in the read-write
mode any filesystems that use the huge_file feature, which is
enabled by default by mke2fs.ext4.The GFS2 filesystem also requires this feature.If unsure, say Y.

This iption is to support block devices or files of size 2TB and larger and is enabled by mke2fs.ext4 by default.

We have two ways,
- removed from an existing filesystem by running the following commands: tune2fs -O ^huge_file /dev/mmcblk0p3 fsck /dev/mmcblk0p3
- enable CONFIG_LBDAF in the def_config file

Jason

Eric Miao (eric.y.miao) wrote :

I'd vote for enabling CONFIG_LBDAF in the def_config file, as this is what's enabled in a latest ubuntu kernel as well.

Eric Miao (eric.y.miao) on 2011-08-16
Changed in linaro-landing-team-freescale:
assignee: nobody → Eric Miao (eric.y.miao)
importance: Undecided → High
milestone: none → 2011.08
status: New → Triaged
Eric Miao (eric.y.miao) wrote :

Fixed committed in LT kernel for ubuntu packaging.

Changed in linaro-landing-team-freescale:
status: Triaged → Fix Committed
Ricardo Salveti (rsalveti) wrote :

Can someone make sure this is tested with 11.08 RC and close the bug?

Jani Monoses (jani) wrote :

Works with the hwpack of Aug 24.

Changed in linux-linaro:
status: Triaged → Fix Released
summary: - iMX53 hwpack does not boot correctly with ext4 rootfs
+ Multiple hwpacks do not boot correctly with ext4 rootfs
Changed in linux-linaro:
status: Fix Released → Confirmed
Dave Martin (dave-martin-arm) wrote :

This also appears broken in both the natty and oneiric packaging trees for linaro-linux.

Unless anyone can think of a reason why not, we should fix this in one of the following two ways:

a) Set CONFIG_LBDAF=y should be added globally in debian.linaro/config/config.common.ubuntu or debian.linaro/config/armel/config.common.armel, and strip it from the flavour-specific configs (I'm not familiar enough with the packaging to know which is the most appropriate; however, there's nothing arch-specific about CONFIG_LBDAF)

b) Disable the huge_file ext4 filesystem feature when generating filesystems in linaro-media-create (mke2fs -text4 -O^huge_file). I don't know whether or not this will have unwanted side-effects.

git://git.linaro.org/ubuntu/linux-linaro-natty.git master
commit 1f4d30c122369a5cea3441fdc933179683957357
Author: John Rigby <email address hidden>
Date: Tue May 24 22:35:02 2011 -0600

    LINARO: Linux-linaro-2.6.38-1003.4

$ fgrep -r CONFIG_LBDAF debian.linaro/config
debian.linaro/config/armel/config.flavour.linaro-u8500:# CONFIG_LBDAF is not set
debian.linaro/config/armel/config.flavour.linaro-s5pv310:# CONFIG_LBDAF is not set
debian.linaro/config/armel/config.flavour.linaro-omap:CONFIG_LBDAF=y
debian.linaro/config/armel/config.flavour.linaro-mx51:# CONFIG_LBDAF is not set
debian.linaro/config/armel/config.flavour.linaro-vexpress:CONFIG_LBDAF=y

git://git.linaro.org/ubuntu/linux-linaro-oneiric.git master
commit a6f8bdff267b869202cf9d61c3f7750b241a192d
Author: John Rigby <email address hidden>
Date: Sun Aug 21 22:25:05 2011 -0600

    Linux-linaro-3.0.0-1004.5

$ fgrep -f CONFIG_LBDAF debian.linaro/config
debian.linaro/config/armel/config.flavour.linaro-u8500:# CONFIG_LBDAF is not set
debian.linaro/config/armel/config.flavour.linaro-s5pv310:CONFIG_LBDAF=y
debian.linaro/config/armel/config.flavour.linaro-omap:CONFIG_LBDAF=y
debian.linaro/config/armel/config.flavour.linaro-mx51:# CONFIG_LBDAF is not set
debian.linaro/config/armel/config.flavour.linaro-vexpress:# CONFIG_LBDAF is not set

Dave Martin (dave-martin-arm) wrote :

Linked to linaro-image-tools, since the fix could be applied there. This can be marked as don't fix if the kernel config is fixed instead.

description: updated
Ricardo Salveti (rsalveti) wrote :

This should be fixed with hwpacks from Aug 25.

affects: linaro-image-tools → linaro-ubuntu
Changed in linaro-ubuntu:
milestone: none → 11.08
assignee: nobody → John Rigby (jcrigby)
importance: Undecided → High
status: New → Fix Committed
Changed in linaro-ubuntu:
status: Fix Committed → Fix Released
Changed in linux-linaro:
status: Confirmed → Fix Released
Changed in linaro-landing-team-freescale:
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers