musb config'd out on 2.6.38-1000 kernel

Bug #730698 reported by Dr. David Alan Gilbert on 2011-03-07
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Linux
Invalid
Medium
Unassigned
Linaro Ubuntu
Medium
John Rigby
linux-linaro-omap (Ubuntu)
Undecided
John Rigby

Bug Description

I'm on a Beagle-C4 board with a powered usb hub plugged into the OTG port with a usb ethernet adapter.

It looks like MUSB was disabled by commit 61e9beafdd6f2b2d27ad5935a2de9c46709b9671
and I think this is the reason I can't use the ethernet I have plugged into the OTG port.

grep -i musb /boot/config-2.6.38-1000-linaro-omap
# CONFIG_USB_MUSB_HDRC is not set

At boot I don't see any hub lights on (except the power LED); on 2.6.37-1002 (and earlier) I used to
be able to get the Hub to come on by doing a modprobe g_ether; my guess is that kicked the port
into OTG host mode. That now says no such device when I modprobe g_ether.

The other recommended trick of writing to /sys/devices/platform/musb_hdrc/mode doesn't help since that's missing.

Dave

Changed in linux-linaro:
importance: Undecided → Medium
Mounir Bsaibes (mounir-bsaibes) wrote :

John, assigning this one to you, as it may need config tweak.

Changed in linux-linaro:
assignee: nobody → John Rigby (jcrigby)
Deepak Saxena (dsaxena-linaro) wrote :

Hi John,

Is this something you can quickly validate and submit the config change to Nicolas for 11.05 if it solves the issue?

John Stultz (jstultz) wrote :

Just to be clear, I assume the request above was for John Rigby. :)

I'd happily test on my beagle xm, but I don't have the right adapter for the usb gadget port (I had tried to get a micro-usb, but that doesn't fit).

John Rigby (jcrigby) wrote :

This is a config issue so it is a bug against the packaged kernel (so it's my problem). It will be fixed in the next release.

Changed in linux-linaro:
status: New → Invalid
Changed in linux-linaro-omap (Ubuntu):
status: New → In Progress
assignee: nobody → John Rigby (jcrigby)
Changed in linux-linaro:
assignee: John Rigby (jcrigby) → nobody
John Rigby (jcrigby) wrote :

I have turned these on for the next release:
CONFIG_USB_MUSB_HDRC=y
CONFIG_USB_MUSB_OMAP2PLUS=y
CONFIG_USB_MUSB_OTG=y
CONFIG_USB_GADGET_MUSB_HDRC=y
CONFIG_USB_MUSB_HDRC_HCD=y
CONFIG_USB_INVENTRA_DMA=y
CONFIG_USB_MUSB_DEBUG=y

Andy Doan (doanac) wrote :

John, I just re-tested the config options from comment #5 on the latest linux-linaro-2.6.38. I think the options are working, but the USB code seems a little buggy.

Basically I can get the g_serial module to work. However, you do get a flood a dmesg errors. The same messages occur when trying g_storage_file, and in that case I can't perform a mount from the host system to the device. The message I'm getting flooded with is:

 musb-hdrc musb-hdrc: configured as A device timeout

It looks like its coming from:
 drivers/usb/musb/omap2430.c

I apologize for not trying this against your tree.

Marcin Juszkiewicz (hrw) wrote :

Connected usb otg host cable and no reaction from panda.

Linux linaro 2.6.38-1003-linaro-omap #4~ppa5-Ubuntu SMP PREEMPT Wed May 25 14:44:32 UTC 2011 armv7l armv7l armv7l GNU/Linux

Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 11.07

On 3.0.0-1001-linaro-omap in the hwpack_linaro-omap3-20110726-1 we still don't have MUSB_HDRC configured
and also there are very few modules; the asix module which I need for my ethernet module is missing.

Dave

Changed in linaro-ubuntu:
milestone: 11.07 → 11.08
Changed in linaro-ubuntu:
milestone: 11.08 → 11.09
Fathi Boudra (fboudra) on 2011-08-31
Changed in linaro-ubuntu:
assignee: nobody → John Rigby (jcrigby)
Changed in linaro-ubuntu:
milestone: 11.09 → 11.10
Fathi Boudra (fboudra) on 2011-11-11
Changed in linaro-ubuntu:
milestone: 11.10 → 11.11
Ricardo Salveti (rsalveti) wrote :
tags: added: beagle
Ricardo Salveti (rsalveti) wrote :

With the attached config patch I'm able to use the otg port after loading the g_ether module. John, can you add this patch to the 11.11 kernel?

Changed in linaro-ubuntu:
status: Confirmed → In Progress

The attachment "Config changes for the 11.11 kernel." of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
John Rigby (jcrigby) wrote :

patch applied with small change to make vexpress compile
with this new kernel after loading g_ether I can ping host via the usb interface

Changed in linaro-ubuntu:
status: In Progress → Fix Committed
Changed in linaro-ubuntu:
status: Fix Committed → Fix Released
John Rigby (jcrigby) on 2012-08-02
Changed in linux-linaro-omap (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers