imx51: unable to mount root fs on SD card

Bug #656966 reported by Dave Martin
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Linux
Fix Released
Undecided
Unassigned

Bug Description

Affected: http://jameswestby.net:8080/job/linaro-imx51 hwpack/51/artifact/hwpack_linaro-imx51_20101007-51_armel_unsupported.tar.gz
Board: imx51 babbage3

May be closely related to, or the same as, #655641.

Linux doesn't seem to probe /dev/mmcblk0 correctly.

I don't know whether this was caused by modules missing from the initramfs, or whether it is related to the mdio failure or something else.

No /dev/mmcblk0* is visible in the initramfs after udev has settled.

Revision history for this message
Dave Martin (dave-martin-arm) wrote :
description: updated
description: updated
Revision history for this message
Shawn Guo (shawnguo) wrote :

i.MX51 mmc driver is not available in Linaro kernel yet.

Revision history for this message
Martin Pitt (pitti) wrote : Please test proposed package

Accepted linux-linaro into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Revision history for this message
Steve Langasek (vorlon) wrote :

Shawn, can you confirm whether the linux-image-2.6.35-1008-linaro-mx51 package in maverick-proposed fixes this issue?

I'm afraid this package is not available as part of a hwpack currently, so you would need to test by hand.

Revision history for this message
Shawn Guo (shawnguo) wrote :

I just made the uImage from vmlinuz in package linux-image-2.6.35-1008-linaro-mx51, and saw the issue had been fixed.

Steve Langasek (vorlon)
tags: added: verification-done
removed: verification-needed
Revision history for this message
John Stultz (jstultz) wrote :

Any ETA on the fix landing into the hwpack? Using testing the hwpack_linaro-imx51_20101108-1_armel_unsupported.tar.gz package today, the kernel does not find the sdcard device.

Revision history for this message
Steve Langasek (vorlon) wrote : Re: [Bug 656966] Re: imx51: unable to mount root fs on SD card

On Mon, Nov 08, 2010 at 09:09:08PM -0000, John Stultz wrote:
> Any ETA on the fix landing into the hwpack? Using testing the
> hwpack_linaro-imx51_20101108-1_armel_unsupported.tar.gz package today,
> the kernel does not find the sdcard device.

Jamie is working on sorting this out today; we need to get finalized hwpacks
up and going today in order to have time to test them for the release, it's
currently not clear why they didn't already get picked up for the most
recent run.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Revision history for this message
John Stultz (jstultz) wrote :

I verified this is fixed in hwpack_linaro-imx51_20101115-0_armel_unsupported.tar.gz today. Thanks!

Revision history for this message
Steve Langasek (vorlon) wrote :

John, could you please also confirm that it's fixed with the hardware pack that was released for Linaro 10.11, http://releases.linaro.org/platform/linaro-m/hwpacks/final/hwpack_linaro-imx51_20101110-0_armel_unsupported.tar.gz? Thanks!

Revision history for this message
John Rigby (jcrigby) wrote :
Steve Langasek (vorlon)
Changed in linux-linaro:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments