Settings in wrong path (/apps/ etc. are deprecated)

Reported by Robert Ancell on 2012-04-17
66
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Audience
Medium
Pim Vullers
BeatBox
Low
Corentin Noël
Cerbere
Undecided
Pim Vullers
Ergo
Undecided
Unassigned
Euclide
Medium
Pim Vullers
Feedler
Medium
Robert Ancell
Footnote
Undecided
Pim Vullers
Gnumeric
New
Undecided
Unassigned
Lingo
Low
Pim Vullers
Maya
Medium
Niels Avonds
Noise
Medium
Pim Vullers
Pantheon Wallpaper
Fix Released
Medium
Pim Vullers
Scratch
Medium
Unassigned
Shotwell
New
Undecided
Unassigned
Snap
Medium
Pim Vullers
Steadyflow
Medium
Unassigned
Strip
Critical
Brendan William
Terminal
Medium
David Gomes
WingPanel
Medium
Fabian Thoma
webcontracts
Medium
Cody Garver

Bug Description

GSettings scheme Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated. The affected applications should move to '/org/pantheon/APPLICATIONNAME' or something similar.

Reference to the change on Gnome mailinglist:
http://mail.gnome.org/archives/desktop-devel-list/2011-February/msg00064.html

Related branches

lp:~cech.kapavich/cerbere/fix-983560
Merged into lp:cerbere at revision 20
Victor Martinez: Approve on 2012-05-18
Cody Garver: Needs Fixing on 2012-04-30
lp:~mefrio-g/pantheon-files/fix-983560
Merged into lp:pantheon-files at revision 810
Pim Vullers (community): Needs Fixing on 2012-05-16
elementary Apps team: Pending requested 2012-05-15
Cody Garver (codygarver) wrote :

We're not a part of elementary so what should the gschema reflect?

What's wrong with /apps/audience anyway?

Pim Vullers (pimvullers) wrote :

CMake Error at cmake/GSettings.cmake:31 (message):
  Schema validation error: warning: Schema 'desktop.pantheon.slingshot' has
  path '/desktop/pantheon/slingshot/'. Paths starting with '/apps/',
  '/desktop/' or '/system/' are deprecated.

So we will have to change to something else then /apps/.

I get this message since glib 2.32.1

Pim Vullers (pimvullers) on 2012-04-17
summary: - Settings in wrong path
+ Settings in wrong path (/apps/ etc. are deprecated)
description: updated

Thanks for clarification!
Adding pantheon-terminal as affected, and I'll check other apps I have installed.

I'd mark this bug as incomplete at the moment; we have to agree on some path to store settings which works for both "official elementary" and "not yet there" apps, e.g. /org/pantheon

Also, when converting paths, please change schema names accordingly and keep them lowercase.

Mario Guerriero (mefrio-g) wrote :

All our apps are in /apps/app-name, we should discuss this in the next dev meeting and make a decision

Pim Vullers (pimvullers) wrote :

Maya actually uses org.elementary.Maya for the schema, but puts it in /apps/, see below:

CMake Error at cmake/GSettings.cmake:31 (message):
  Schema validation error: warning: Schema 'org.elementary.Maya.Settings' has
  path '/apps/maya/settings/'. Paths starting with '/apps/', '/desktop/' or
  '/system/' are deprecated.

  warning: Schema 'org.elementary.Maya.SavedState' has path
  '/apps/maya/saved-state/'. Paths starting with '/apps/', '/desktop/' or
  '/system/' are deprecated.

Mismatches between schema name and corresponding dconf path should be eradicated too.

Pim Vullers (pimvullers) wrote :

Actually I just found out that this is the case for a lot of the projects (org.elementary.* in the filename, but a /apps/ or so path).

Brendan William (mamemame187) wrote :

fixed

Changed in strip:
assignee: nobody → Brendan William (mamemame187)
importance: Undecided → Critical
status: New → Fix Committed
Pim Vullers (pimvullers) wrote :

Has the dev meeting resulted in a solution for this issue?

Brendan William (mamemame187) wrote :

why were they deprecated in the first place?

Fabian Thoma (agent00tai) wrote :

yes, we will use /org/pantheon/... for all elementary apps, same goes with org.pantheon....
This will also be allowed for third party apps designed for elementary, but ofc is no requirement

David Gomes (davidgomes) on 2012-04-29
Changed in pantheon-terminal:
importance: Undecided → Medium
milestone: none → luna-beta1
status: New → Confirmed
David Gomes (davidgomes) on 2012-04-29
Changed in pantheon-terminal:
status: Confirmed → Fix Committed
assignee: nobody → David Gomes (davidgomes)
Mario Guerriero (mefrio-g) wrote :

As we decided in the last meeting this but needs to be fixed in all our apps

Changed in wingpanel:
milestone: none → luna-beta1
status: New → Confirmed
Changed in slingshot:
milestone: none → luna-beta1
status: New → Confirmed
Changed in scratch:
milestone: none → luna-beta1
status: New → Confirmed
Changed in webcontracts:
status: New → Confirmed
Changed in snap-elementary:
importance: Undecided → Medium
milestone: none → 0.1
status: New → Confirmed
Changed in pantheon-wallpaper:
status: New → Confirmed
Changed in maya:
milestone: none → luna-beta1
status: New → Confirmed
Changed in lingo-dictionary:
status: New → Confirmed
Changed in scratch:
importance: Undecided → Medium
Changed in footnote:
status: New → Confirmed
Changed in euclide:
importance: Undecided → Medium
status: New → Confirmed
Changed in feedler:
status: New → Confirmed
Changed in cerbere:
status: New → Confirmed
description: updated
Changed in wingpanel:
assignee: nobody → Fabian Thoma (agent00tai)
importance: Undecided → Medium
status: Confirmed → Fix Committed
Changed in scratch:
status: Confirmed → Fix Committed
Changed in slingshot:
assignee: nobody → Mario Guerriero (mefrio-g)
Fabian Thoma (agent00tai) wrote :

Wingpanel now uses /org/pantheon/desktop/wingpanel I suggest the same path for other desktop components

Pim Vullers (pimvullers) on 2012-04-30
Changed in audience:
status: New → Confirmed
Pim Vullers (pimvullers) on 2012-05-02
Changed in audience:
assignee: nobody → Pim Vullers (pimvullers)
importance: Undecided → Medium
status: Confirmed → Fix Committed
Pim Vullers (pimvullers) on 2012-05-03
Changed in ergo:
status: New → Confirmed
Changed in marlin:
status: New → Confirmed
Changed in slingshot:
status: Confirmed → Fix Committed
Pim Vullers (pimvullers) on 2012-05-07
Changed in pantheon-files:
status: New → Confirmed
Daniel Fore (danrabbit) on 2012-05-07
Changed in pantheon-files:
milestone: none → 0.1
Changed in wingpanel:
status: Fix Committed → Fix Released
Maia Everett (sikon) wrote :

Fixed in unstable Steadyflow r367.

Changed in steadyflow:
milestone: none → 0.2
status: New → Fix Committed
Maia Everett (sikon) on 2012-05-09
Changed in steadyflow:
importance: Undecided → Medium
Changed in feedler:
assignee: nobody → Robert Ancell (robert-ancell)
status: Confirmed → Fix Committed
Daniel Fore (danrabbit) on 2012-05-11
Changed in scratch:
milestone: luna-beta1 → 1.1
status: Fix Committed → Fix Released
Changed in maya:
assignee: nobody → Niels Avonds (niels-avonds)
importance: Undecided → Medium
status: Confirmed → Fix Committed
Changed in pantheon-files:
assignee: nobody → Mario Guerriero (mefrio-g)
Changed in feedler:
importance: Undecided → Medium
Changed in euclide:
assignee: nobody → Pim Vullers (pimvullers)
status: Confirmed → Fix Committed
Cody Garver (codygarver) on 2012-05-19
Changed in cerbere:
status: Confirmed → Fix Committed
Changed in pantheon-files:
status: Confirmed → Fix Committed
Cody Garver (codygarver) on 2012-05-19
Changed in audience:
milestone: none → 0.1
Changed in noise:
assignee: nobody → Pim Vullers (pimvullers)
importance: Undecided → Medium
milestone: none → 1.0
status: New → Fix Committed
Changed in strip:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2012-05-21
Changed in pantheon-wallpaper:
assignee: nobody → Pim Vullers (pimvullers)
status: Confirmed → Fix Committed
Cody Garver (codygarver) on 2012-05-21
Changed in footnote:
assignee: nobody → Pim Vullers (pimvullers)
status: Confirmed → Fix Committed
Changed in snap-elementary:
assignee: nobody → Pim Vullers (pimvullers)
status: Confirmed → Fix Committed
Changed in cerbere:
assignee: nobody → Pim Vullers (pimvullers)
ammonkey (am-monkeyd) on 2012-05-28
no longer affects: marlin
Pim Vullers (pimvullers) wrote :

xapantu's latest sync with marlin (commit 844) broke the committed fixes...
why did we revert to using the marlin settings location?

Changed in pantheon-files:
status: Fix Committed → Confirmed

Because I don't want to merge manually schemas change. We'll change
this /apps/ problem in Marlin, don't worry ;)

Le dimanche 03 juin 2012 à 19:52 +0000, Pim Vullers a écrit :
> xapantu's latest sync with marlin (commit 844) broke the committed fixes...
> why did we revert to using the marlin settings location?
>
> ** Changed in: pantheon-files
> Status: Fix Committed => Confirmed
>

Changed in cerbere:
status: Fix Committed → Fix Released
xapantu (xapantu) wrote :

FIxed in marlin upstream for pantheon-files.

Changed in pantheon-files:
status: Confirmed → Invalid
Maia Everett (sikon) on 2012-06-30
Changed in steadyflow:
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) on 2012-07-06
Changed in pantheon-files:
milestone: luna-beta1 → none
Changed in beat-box:
assignee: nobody → Corentin Noël (tintou)
importance: Undecided → Low
milestone: none → 0.6
status: New → Fix Released
Changed in pantheon-terminal:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2012-08-03
Changed in lingo-dictionary:
assignee: nobody → Pim Vullers (pimvullers)
importance: Undecided → Low
milestone: none → luna-beta1
status: Confirmed → Fix Committed
Cody Garver (codygarver) on 2012-08-30
Changed in webcontracts:
assignee: nobody → Cody Garver (codygarver)
importance: Undecided → Medium
status: Confirmed → In Progress
Cody Garver (codygarver) on 2012-08-30
Changed in webcontracts:
status: In Progress → Fix Committed
Download full text (14.4 KiB)

How about releasing fixed packages into quantal ?

Here is a list of warning messages in quantal on my system as of today:

Processing triggers for libglib2.0-0:i386 ...
warning: Schema 'apps.gecko-mediaplayer.preferences' has path '/apps/gnome-mplayer/preferences/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.gnome-mplayer.preferences' has path '/apps/gnome-mplayer/preferences/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'com.canonical.notify-osd' has path '/apps/notify-osd/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'com.canonical.Unity.ApplicationsLens' has path '/desktop/unity/lenses/applications/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'com.canonical.Unity.Runner' has path '/desktop/unity/runner/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'com.canonical.Unity.FilesLens' has path '/desktop/unity/lenses/files/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'com.canonical.indicator.session' has path '/apps/indicator-session/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'com.ubuntu.update-manager' has path '/apps/update-manager/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard' has path '/apps/onboard/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.auto-show' has path '/apps/onboard/auto-show/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.keyboard' has path '/apps/onboard/keyboard/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.window' has path '/apps/onboard/window/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.window.landscape' has path '/apps/onboard/window/landscape/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.window.portrait' has path '/apps/onboard/window/portrait/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.icon-palette' has path '/apps/onboard/icon-palette/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.icon-palette.landscape' has path '/apps/onboard/icon-palette/landscape/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.icon-palette.portrait' has path '/apps/onboard/icon-palette/portrait/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.universal-access' has path '/apps/onboard/universal-access/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warning: Schema 'apps.onboard.theme-settings' has path '/apps/onboard/theme-settings/'. Paths starting with '/apps/', '/desktop/' or '/system/' are deprecated.
warni...

Daniel Fore (danrabbit) on 2012-09-22
Changed in lingo-dictionary:
milestone: luna-beta1 → none
Daniel Fore (danrabbit) on 2012-10-12
Changed in maya:
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) on 2012-11-09
no longer affects: slingshot
Changed in noise:
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2013-04-12
no longer affects: pantheon-files
Changed in pantheon-wallpaper:
importance: Undecided → Medium
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2013-04-15
Changed in webcontracts:
status: Fix Committed → Fix Released
Changed in audience:
status: Fix Committed → Fix Released
Changed in euclide:
status: Fix Committed → Fix Released
Changed in feedler:
status: Fix Committed → Fix Released
Changed in footnote:
status: Fix Committed → Fix Released
Changed in lingo-dictionary:
status: Fix Committed → Fix Released
Changed in snap-elementary:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers