Netbook image - no valid session found

Bug #707232 reported by Paul Larson on 2011-01-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro
Fix Released
Undecided
Unassigned
gnome-session (Ubuntu)
High
Didier Roche
Natty
High
Didier Roche

Bug Description

hwpack_linaro-omap3_20110124-0_armel_supported.tar.gz
linaro-natty-efl-tar-20110124-0.tar.gz

When booting, I get a popup message on the graphical console after X starts saying "No valid session found."
The "X" mouse curser is present, and the mouse works, but the graphical console switches back and forth between a black screen and a red screen several times
No panic/oops in dmesg,

From /home/linaro/.xsession-errors:
gnome-session[677]: Gtk-CREITICAL: IA__gtk_main_quit: assertion `main_loops != NULL' failed

Stéphane Graber (stgraber) wrote :

Bugs also affect Ubuntu.
It's breaking LTSP in Natty.

It seems to be because "/etc/X11/Xsession" without parameters should start the default X session and not fail saying "No valid session found". gnome-session should just start whatever should be the default.

Changed in gnome-session (Ubuntu):
importance: Undecided → High
Didier Roche (didrocks) on 2011-02-02
Changed in gnome-session (Ubuntu):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
tags: added: iso-testing
Didier Roche (didrocks) wrote :

@Stéphane: in fact, it's not really the cause :)
The cause is that it tries to launch /usr/share/gnome-session/session/gnome.session by default, which is correct, but this one try to get acceleration and doesn't fallback because of a key change.

So, what I'll do for now:
- change the default to ubuntu
- fix the gnome.session file to the new syntax

Not sure that the ubuntu session will works for you as it's testing for acceleration, so it will probably fallback

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-session - 2.32.1-0ubuntu14

---------------
gnome-session (2.32.1-0ubuntu14) natty; urgency=low

  * debian/patches/02_add_ubuntu_session.patch:
    - add a better wording (LP: #712091)
  * debian/control.in:
    - recommends unity-2d as a gnome-panel | unity alternative (LP: #708928)
  * debian/patches/05_enhance_fallback_mode.patch:
    - change the multi-fallback handling, now a list of key in the keyfile is
      provided to FallbackSessionsID. If the fallback is found, the matching
      <keyname>_Message will be displayed if exists. (LP: #704409)
    - don't show "change user session" for now has gnome-control-center with
      that option won't be ready for natty (LP: #711920)
    - adapt the gnome session to the new format (LP: #707232)
  * debian/patches/02_add_ubuntu_session.patch:
    - adapt to new format
    - set ubuntu as the default session if no argument is given
 -- Didier Roche <email address hidden> Thu, 03 Feb 2011 16:17:57 +0100

Changed in gnome-session (Ubuntu Natty):
status: Triaged → Fix Released
Changed in linaro:
status: New → Won't Fix
status: Won't Fix → Fix Released
Eyad Salah (eyad-salah) wrote :

I tried using the gnome3 PPA for a couple of hours and noticed it was causing multiple crashes to the desktop, so I purged the PPA and restored the old versions of the installed packages using synaptic.
For some reason now I keep getting the error message whenever I try using the ubuntu entry in the login window. I can still use the "ubuntu classic" just fine. But I really like the new look and want to get to work again.

Is there anything I need to do or is this a bug?

BTW. I'm using natty beta "2.6.38-8-generic"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers