ubuntu-bug complains "not a genuine Linaro package"

Bug #627777 reported by Paul Larson on 2010-09-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Apport
Undecided
Unassigned
Linaro
Fix Released
Undecided
Unassigned
apport (Ubuntu)
Low
Steve Langasek

Bug Description

While looking into another problem, I installed apport and tried to use ubuntu-bug to file a bug on the kernel. It came back with the following error:
root@localhost:/var/log# ubuntu-bug linux

*** Collecting problem information

The collected information can be sent to the developers to improve the
application. This might take a few minutes.
........

*** Problem in linux-image-2.6.35-1004-linaro-omap

The problem cannot be reported:

This is not a genuine Linaro package

Press any key to continue...
--------------------------

This was using the 20100831-2 image. I also tried to use apport on a recent image, I believe it was 20100830-3, and did not have this problem, so it seems to be a recent regression. I also tried running apt-get update and retrying, but it still complains. If it weren't for that, I would think this was related to bug #497796

Steve Langasek (vorlon) wrote :

Added /etc/apport/native-origins.d/uses-ubuntu-binaries to base-files in the Linaro overlay ppa to address this. However, the fix is incomplete because it turns out apport's handling of native-origins.d is buggy: it tries to open the files relative to the cwd instead of the .d directory. Opening a task on apport for this.

Changed in linaro:
status: New → Fix Released
Changed in apport (Ubuntu):
status: New → Triaged
Steve Langasek (vorlon) on 2010-09-02
Changed in apport (Ubuntu):
status: Triaged → Fix Committed
assignee: nobody → Steve Langasek (vorlon)
importance: Undecided → Low
milestone: none → ubuntu-10.10
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package apport - 1.14.1-0ubuntu6

---------------
apport (1.14.1-0ubuntu6) maverick; urgency=low

  * backends/packaging-apt-dpkg.py: fix handling of
    /etc/apport/native-origins.d to actually work. LP: #627777.
 -- Steve Langasek <email address hidden> Thu, 02 Sep 2010 22:28:48 +0000

Changed in apport (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Merged into trunk r1768, thanks Steve!

Changed in apport:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers