Panda: Bluetooth functionality broken

Bug #996438 reported by Abhishek Paliwal on 2012-05-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Unassigned
linaro-landing-team-ti
Fix Released
Medium
Unassigned

Bug Description

Description:
----------------
Using
hwpack:
http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/32/hwpack_linaro-lt-panda-x11-base_20120505-32_armhf_supported.tar.gz
Rootfs:
http://snapshots.linaro.org/precise/images/ubuntu-desktop/119/linaro-precise-ubuntu-desktop-20120426-119.tar.gz

Bluetooth functionality is broken, BT configuration not listed as well as scan does not work.
Running test : https://wiki.linaro.org/Platform/QA/TestCases/Ubuntu#Bluetooth

Logs:
------
#hciconfig -no output
#hcitool scan
Device is not available: No Such device

Impact:
----------
Can't test Bluetooth functionality.

Steps to reproduce:
--------
Follow steps from here : https://wiki.linaro.org/Platform/QA/TestCases/Ubuntu#Bluetooth

Hardware:
----------
Panda Board 4430 and 4460
Class 10 SD card - transcend

Ricardo Salveti (rsalveti) wrote :
Download full text (3.9 KiB)

Using http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/139/lt-panda-x11-base-precise_ubuntu-desktop_20120626-139.html

Kernel:
linux-linaro-lt-omap-3.4 (3.4.0-1.1~120625232503) precise; urgency=low-lt-omap/ch
  * Packaged version of lt-omap kernel created from:
    Kernel:
    Repo: git://git.linaro.org/landing-teams/working/ti/kernel.git
    Branch: tilt-3.4
    Head:
        commit 61abde21bf6272908466e2d13acd479743b4f0b3
        Author: Jaswinder Singh <jaswinder.singh.org>
        Date: Fri Jun 22 11:26:22 2012 +0800

            omapdss temp hack ignore resume runtime_pm fail

            Signed-off-by: Jaswinder Singh <jaswinder.singh.org>

    Board config fragment:
    Repo: git://git.linaro.org/kernel/configs.git
    Branch: config-boards-3.4
    Head:
        commit b7274f7e11c782039d94a6662c823e339c21dd50
        Author: Ricardo Salveti de Araujo <ricardo.salveti.org>
        Date: Mon Jun 25 15:30:04 2012 -0300

            configs: omap4: disabling CPU_IDLE due bug 971091

            Signed-off-by: Ricardo Salveti de Araujo <ricardo.salveti.org>

    Ubuntu and Linaro Base config fragments:
    Repo: git://git.linaro.org/kernel/configs.git
    Branch: config-core-3.4
    Head:
        commit 072bd6cb29aa25a3fe0f6be08af48f5a58eae849
        Author: Ricardo Salveti de Araujo <ricardo.salveti.org>
        Date: Mon Jun 25 18:06:06 2012 -0300

            configs: ubuntu: disabling CGROUPS as default

            Not yet stable enough to be used as default for all boards we currently
            support at Linaro.

            Signed-off-by: Ricardo Salveti de Araujo <ricardo.salveti.org>

    Packaging template:
    Repo: git://git.linaro.org/ubuntu/linux-linaro-quantal.git
    Branch: linaro-ubuntu-packaging-3.4
    Head:
        commit 3da2b9971c9fbd9d039bf902ee8d31fdc8cc16f2
        Author: John Rigby <john.rigby.org>
        Date: Mon Jun 25 15:04:23 2012 -0600

            LINARO: template debian.linaro based on omap only version

            Signed-off-by: John Rigby <john.rigby.org>

 -- John Rigby <email address hidden> Mon, 25 Jun 2012 15:04:22 -0600

It seems the interface is recognized, but it's not properly initialized. During boot I got the following logs:

[ 14.310852] (stk) : timed out waiting for ldisc to be un-installed
[ 15.431427] (stk) :ldisc installation timeout
[ 16.514709] (stk) : timed out waiting for ldisc to be un-installed
[ 17.631530] (stk) :ldisc installation timeout
[ 18.639221] (stk) : timed out waiting for ldisc to be un-installed
[ 19.764923] (stk) :ldisc installation timeout
[ 20.770599] (stk) : timed out waiting for ldisc to be un-installed
[ 21.898559] (stk) :ldisc installation timeout
[ 22.895111] (stk) : timed out waiting for ldisc to be un-installed
[ 22.901458] Bluetooth: st_register failed -22
[ 24.028411] (stk) :ldisc installation timeout
[ 25.034118] (stk) : timed out waiting for ldisc to be un-installed
[ 26.174468] (stk) :ldisc installation timeout
[ 27.238616] (stk) : timed out waiting for ldisc to be un-installed
[ 28.349426]...

Read more...

Ricardo Salveti (rsalveti) wrote :
Download full text (3.8 KiB)

Trying to run uim by hand I get the following:

root@linaro-ubuntu-desktop:~# rmmod btwilink
root@linaro-ubuntu-desktop:~# modprobe btwilink
root@linaro-ubuntu-desktop:~# uim
uim:@ main
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim: signal received, opening ����
uim:Can't open ����
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 0 from install

uim:@ st_uart_config
uim:Un-Installed N_TI_WL Line displine
uim:begin polling...
uim:poll broke due to event 10(PRI:2/ERR:8)

uim:read 1 from install

uim:@ st_uart_config
uim...

Read more...

Ricardo Salveti (rsalveti) wrote :

Andy, how do you usually test bluetooth with your kernel? Just want to make sure we're not missing anything.

warmcat (andy-warmcat) wrote :

Normally with uim and then bluetooth UI on Ubuntu desktop.

There were a couple of patches missing, tilt-3.4 == 448be0e3981852c8b7032c5d7d51747a1187b774 is working OK at least for scan.

Notice bt firmware now lives down /lib/firmware/ti-connectivity (it has for a while but just making sure) and on my PandaBoard ES, it needed TIInit_7.6.15.bts rather than the TIInit_7.2.31.bts that was in my rootfs.

warmcat (andy-warmcat) on 2012-06-27
Changed in linaro-landing-team-ti:
status: New → Fix Committed
Botao (botao-sun) wrote :

On Wed, Jun 27, 2012 at 12:37 AM, warmcat <email address hidden> wrote:
> Normally with uim and then bluetooth UI on Ubuntu desktop.
>
> There were a couple of patches missing, tilt-3.4 ==
> 448be0e3981852c8b7032c5d7d51747a1187b774 is working OK at least for
> scan.

Great, should be getting a new package in a few hours and will verify it again.

> Notice bt firmware now lives down /lib/firmware/ti-connectivity (it has
> for a while but just making sure) and on my PandaBoard ES, it needed
> TIInit_7.6.15.bts rather than the TIInit_7.2.31.bts that was in my
> rootfs.

Yeah, we got the correct firmware already, guess it was just at the kernel side.

Changed in linaro-ubuntu:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Ricardo Salveti (rsalveti)
warmcat (andy-warmcat) on 2012-06-27
Changed in linaro-landing-team-ti:
status: Fix Committed → Fix Released
Changed in linaro-ubuntu:
milestone: none → 12.07
Usman Ahmad (usman-ah) on 2012-06-28
Changed in linaro-landing-team-ti:
importance: Undecided → Medium
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :

For Panda 4430 board, now the Bluetooth can be enabled and paired with other Bluetooth device successfully, but the file transfer feature is still unavailable.

Observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197/hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz

with ubuntu rootfs:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/305/linaro-precise-ubuntu-desktop-20120723-305.tar.gz

Botao (botao-sun) wrote :

Same behavior on Panda 4460 board.

Changed in linaro-ubuntu:
milestone: 12.07 → 12.08
Botao (botao-sun) wrote :

For Panda 4460 board, system hangs during the Bluetooth Headset pair process.

Observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/201/hwpack_linaro-lt-panda-x11-base_20120725-201_armhf_supported.tar.gz

with ubuntu rootfs image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/313/linaro-precise-ubuntu-desktop-20120725-313.tar.gz

Refer to attachment to get the serial console output.

Botao (botao-sun) wrote :

On Panda 4430 board, although file transfer failed, the board still can paired with laptop and Bluetooth headset successfully.

Observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/201/hwpack_linaro-lt-panda-x11-base_20120725-201_armhf_supported.tar.gz

with ubuntu rootfs image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/313/linaro-precise-ubuntu-desktop-20120725-313.tar.gz

Botao (botao-sun) wrote :

For Panda 4460 board, it can be paired with another Bluetooth device - my laptop successfully, but hangs after file transfer failed. observed on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

Please refer to attachment to get serial log output.

Botao (botao-sun) wrote :

For the behaviour in comment #16, it can be observed while another paired Bluetooth device turning off. The procedures are:

1. Pair Panda 4460 with another Bluetooth device, such like a Bluetooth enabled laptop or a Bluetooth headset;

2. Turning off Bluetooth function on that Bluetooth device, for example, disable Bluetooth on laptop or power off Bluetooth headset;

3. Panda 4460 board hangs.

Please refer to attachment to get the serial console log output.

Botao (botao-sun) wrote :

For Panda 4430 board, with the same Linaro ubuntu pre-built image as Panda 4460 board:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

Bluetooth works well except can't transfer files. Board doesn't hang even another paired device suddenly disabled its Bluetooth function.

Amit Khare (amit-khare) wrote :

Observed with panda 4430 build
http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/242/lt-panda-x11-base-precise_ubuntu-desktop_20120812-242.img.gz

detecting BT device and pairing works fine but file transfer is not happening

Amit Khare (amit-khare) wrote :

and with BT Headset pairing works fine but it never connects with the headset

root@linaro-ubuntu-desktop:~# [ 1243.073638] hci0: type 1 len 10
[ 1243.156799] hci0: type 1 len 17
[ 1243.229888] hci0: type 1 len 10
[ 1243.349670] hci0: type 1 len 17
[ 1248.599212] hci0: type 1 len 17

Amit Khare (amit-khare) wrote :
Download full text (32.6 KiB)

Observed with panda 4460 build
http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/242/lt-panda-x11-base-precise_ubuntu-desktop_20120812-242.img.gz

Board tries to search for device and freezes

root@linaro-ubuntu-desktop:~# [ 105.419769] hci0: type 1 len 9
[ 114.405517] PVR_K: HWRecoveryResetSGX: SGX Hardware Recovery triggered
[ 114.412445] PVR_K: SGX debug (SGX_DDK_Linux_CustomerTI sgxddk 19 1.9@956766)
[ 114.424285] PVR_K: (P0) EUR_CR_CORE_ID: 01140000
[ 114.430297] PVR_K: (P0) EUR_CR_CORE_REVISION: 00010200
[ 114.436035] PVR_K: (P0) EUR_CR_EVENT_STATUS: 20000000
[ 114.441772] PVR_K: (P0) EUR_CR_EVENT_STATUS2: 00000000
[ 114.447540] PVR_K: (P0) EUR_CR_BIF_CTRL: 00000000
[ 114.453308] PVR_K: (P0) EUR_CR_BIF_INT_STAT: 0000C010
[ 114.459014] PVR_K: (P0) EUR_CR_BIF_FAULT: 0C847020
[ 114.464935] PVR_K: (P0) EUR_CR_BIF_MEM_REQ_STAT: 00000000
[ 114.470855] PVR_K: (P0) EUR_CR_CLKGATECTL: 000AAA6A
[ 114.477203] PVR_K: (P0) EUR_CR_PDS_PC_BASE: 00203274
[ 114.483673] PVR_K: Found MMU context for page fault 0x0c847000
[ 114.491455] PVR_K: GPU memory context is for PID=2096 (Xorg)
[ 114.497467] PVR_K: No PDE found
[ 114.502044] PVR_K: SGX Host control:
[ 114.505920] PVR_K: (HC-0) 0x00000001 0x00000000 0x00000000 0x00000000
[ 114.514892] PVR_K: (HC-10) 0x00000001 0x0000000A 0x0004B000 0x00000003
[ 114.521911] PVR_K: (HC-20) 0x00000000 0x00000003 0x00000000 0x000001AC
[ 114.529144] PVR_K: (HC-30) 0x00003D4E 0xF4D2CD74 0x00000000 0x00000000
[ 114.536346] PVR_K: (HC-40) 0x00000000 0x28014645 0x69A8D00A 0xF248B920
[ 114.543548] PVR_K: SGX TA/3D control:
[ 114.547576] PVR_K: (T3C-0) 0x0F003000 0x0F0030E0 0x0F002000 0x0F018F80
[ 114.554748] PVR_K: (T3C-10) 0x00000000 0x00000000 0x00000000 0x0F00AA60
[ 114.561981] PVR_K: (T3C-20) 0x00000000 0x00000000 0x00000000 0x00000000
[ 114.569091] PVR_K: (T3C-30) 0x00000000 0x00000000 0x00000000 0x0F00AB80
[ 114.576385] PVR_K: (T3C-40) 0x0F00AB80 0x00000000 0x00000000 0x00000000
[ 114.583618] PVR_K: (T3C-50) 0x00000000 0x0F00AE30 0x0F000000 0xBFC12000
[ 114.590850] PVR_K: (T3C-60) 0x0F022100 0x0F00AE30 0x0F01EB00 0x0F00AB80
[ 114.598083] PVR_K: (T3C-70) 0x0F00AD38 0x0F01E280 0x00020000 0x00000000
[ 114.605346] PVR_K: (T3C-80) 0x00000000 0x00000000 0x00000000 0x00000000
[ 114.612579] PVR_K: (T3C-90) 0x00000000 0x00000120 0x0000011F 0x0F004000
[ 114.619812] PVR_K: (T3C-A0) 0x0F00A420 0x0F00B000 0x0F01E000 0x0F01E000
[ 114.627075] PVR_K: (T3C-B0) 0x00000000 0x00000A3E 0x00000A3E 0x00000000
[ 114.634246] PVR_K: (T3C-C0) 0x00000001 0x00000000 0x00000000 0x00000003
[ 114.641418] PVR_K: (T3C-D0) 0x803ED289 0x2700FB04 0x66EF2032 0xFAFFF001
[ 114.648651] PVR_K: SGX Kernel CCB WO:0x91 RO:0x8C
[ 146.094635] hci0: type 1 len 9
[ 165.644226] hci0: type 1 len 9
[ 206.126556] hci0: type 1 len 9
[ 210.559783] Alignment trap: not handling instruction e8531f00 at [<c0467902>]
[ 210.567321] Unhandled fault: alignment exception (0x001) at 0x0000003a
[ 210.574249] Internal error: : 1 [#1] PREEMPT SMP THUMB2
[ 210.579772] Modules linked in: omapdce(C) omapdrm_pvr(O) omap_remoteproc rpmsg_resmgr_comm...

Ricardo Salveti (rsalveti) wrote :

With latest hwpack (latest lt-omap's kernel) I can successfully use bluetooth, to scan devices and also able to use it with a BT headset. The issue while transferring files is not specific to panda, and it's covered by bug 872044.

Marking bug as fix-commited as the basic functionality on the hardware level is working as expected on panda.

Changed in linaro-ubuntu:
status: In Progress → Fix Committed
Botao (botao-sun) wrote :

Confirmed on pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/256/lt-panda-x11-base-precise_ubuntu-desktop_20120819-256.img.gz

Now under HDMI+Unity 2D mode, Panda 4460 board can use Bluetooth to pair another Bluetooth device, for example, a Bluetooth headset.

Botao (botao-sun) wrote :

Observed same behaviour as comment #18, system hangs after I shut down another paired Bluetooth device (my laptop). This happens on Panda 4460 board with Linaro ubuntu image:

http://releases.linaro.org/12.08/ubuntu/leb-panda/lt-panda-x11-base_20120826-270-ubuntu-desktop.img.gz

Botao (botao-sun) wrote :

On Panda 4460 with Linaro ubuntu image:

http://releases.linaro.org/12.08/ubuntu/leb-panda/lt-panda-x11-base_20120826-270-ubuntu-desktop.img.gz

No sound can be heard via Bluetooth headset, although it can be paired successfully, and the device can be shown in "Output" section of "Sound" settings.

Amit Khare (amit-khare) wrote :

observed with panda 4430 ubuntu build
http://releases.linaro.org/12.08/ubuntu/leb-panda/lt-panda-x11-base_20120826-270-ubuntu-desktop.img.gz

Board tries to search for device, when tried to pair with another device it freezes. Log same as comment #22

Ricardo Salveti (rsalveti) wrote :

The freeze observed at #22 is not related with bluetooth (at least I hope so). That's probably more connect with the PowerVG SGX driver. Are you using unity-3d while running this test or unity-2d?

Now regarding comment #18, that might indeed be an issue related with bluetooth, probably happening when stressing the bt interface. Mind opening another bug for this behavior? This is just because this bug is more related with the basic functionality, which is already in place.

Amit Khare (amit-khare) wrote :

observed on Panda 4430 board with image
http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

Bluetooth File transfer is not happening. Music over BT Headset works fine.

Amit Khare (amit-khare) wrote :

addition to comment #30 the board freezes after listening to music over BT headset for a while.

Botao (botao-sun) wrote :

On Panda 4460 board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

System hangs during Bluetooth pairing. Please refer to attachment to get detailed log output.

Botao (botao-sun) wrote :

On Panda 4460 board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

Bluetooth headset can be paired successfully with the board, and it also can be shown in "Output" section of settings menu. However, first, there is no any sound be heard after music started to play; second, system hangs around 1 minute later after music started playing.

Please refer to attachment to get detailed log output. The display mode is HDMI + Unity 2D.

Botao (botao-sun) wrote :

Here is attachment for comment #33.

Botao (botao-sun) wrote :

On Panda 4460 board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

Reboot the board and try it again, now it can pair with another Bluetooth device - my laptop successfully. However, when try to play music via Bluetooth headset, no sound be beard.

Bluetooth feature now looks unstable and may need to investigate more.

Botao (botao-sun) wrote :

Log in serial console after click the test sound button and then click front left button, refer to attachment.

Many "hci0: type 2 len NN" flushing in console, after that, no any sound could be heard. However, after the first click on front left button, sound can be heard, but only that 1 time.

warmcat (andy-warmcat) wrote :

This is blowing up on graphics side, not obviously related to bt

[ 281.364868] [<c009c732>] (set_page_dirty+0x28/0x62) from [<c036c399>] (_drm_gem_put_pages+0x25/0x6c)
[ 281.374725] [<c036c399>] (_drm_gem_put_pages+0x25/0x6c) from [<c03689cd>] (omap_gem_detach_pages+0x69/0x78)
[ 281.385223] [<c03689cd>] (omap_gem_detach_pages+0x69/0x78) from [<c0369b2f>] (omap_gem_free_object+0xb3/0x100)
[ 281.395996] [<c0369b2f>] (omap_gem_free_object+0xb3/0x100) from [<c02aa6f3>] (drm_gem_object_free+0x1f/0x20)
[ 281.406555] [<c02aa6f3>] (drm_gem_object_free+0x1f/0x20) from [<c02aab11>] (drm_gem_handle_delete+0xb7/0xc2)
[ 281.417144] [<c02aab11>] (drm_gem_handle_delete+0xb7/0xc2) from [<c02a97dd>] (drm_ioctl+0x1d7/0x2ae)
[ 281.426971] [<c02a97dd>] (drm_ioctl+0x1d7/0x2ae) from [<c00c72f5>] (do_vfs_ioctl+0x1a5/0x1dc)
[ 281.436157] [<c00c72f5>] (do_vfs_ioctl+0x1a5/0x1dc) from [<c00c735f>] (sys_ioctl+0x33/0x4c)
[ 281.445159] [<c00c735f>] (sys_ioctl+0x33/0x4c) from [<c000c101>] (ret_fast_syscall+0x1/0x52)

Normally there's not much idea to be had from that, but yesterday we found a problem with one of the Androidization patches that causes crashes when under memory pressure. It's an mm subsystem locking race related problem giving pernicious results.

If you try again with a kernel from tilt-3.4 b71a84254eca700ad8cdf3e3735488cde746f2ac or later, it'll be interesting to see if the problem is still coming.

Changed in linaro-ubuntu:
status: Fix Committed → Fix Released
status: Fix Released → In Progress
milestone: 12.08 → 12.09
Botao (botao-sun) wrote :

On Panda 4430 board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/299/lt-panda-x11-base-precise_ubuntu-desktop_20120909-299.img.gz

The Bluetooth pairing with Motorola S305 headset failed and system hangs. Please refer to attachment to get serial log output. I tried twice but got same behaviour. The action list is:

1. Click "System Settings" icon on desktop left side panel;

2. Click "Bluetooth" in "Hardware" section of "All Settings" screen;

3. Power on Motorola S305 Bluetooth headset & wait around 30 seconds;

4. Click "+" button to add a Bluetooth device, follow instructions;

5. System hangs.

However, in this condition, keep Bluetooth headset is ON, plug out board power cable and plug it in to reboot, then enter the Bluetooth settings, you will see the headset has been paired there. Now click the headset name (Motorola S305) on left side of Bluetooth settings screen, then turn "Connection" ON by clicking it on the right side area. After the "Connection" be turned ON, the Bluetooth item will be shown in Sounds settings, and that A2DP one can be used to listen music from rhythmbox, and it works well.

Botao (botao-sun) wrote :

Bluetooth pair & headset (Motorola S305) work well on Panda 4460 with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/299/lt-panda-x11-base-precise_ubuntu-desktop_20120909-299.img.gz

Botao (botao-sun) wrote :

On Panda 4430 board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/312/lt-panda-x11-base-precise_ubuntu-desktop_20120916-312.img.gz

Motorola S305 Bluetooth headset can be paired and works well. However, after power off the headset, the board hangs. Please refer to attachment to get serial log.

Ricardo Salveti (rsalveti) wrote :

Are you still able to reproduce this issue with the 12.09 RC1 image?

Botao (botao-sun) wrote :

@Ricardo, Motorola Bluetooth headset S305 now works well. Observed on Linaro ubuntu image:

https://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/329/lt-panda-x11-base-precise_ubuntu-desktop_20120924-329.img.gz

However, file transfer feature is still unavailable, but there is another bug for that:

https://bugs.launchpad.net/gnome-bluetooth/+bug/872044

We can consider this bug as "Fix Released", also, if necessary, we can raise a bug on our side to trace the file transfer failure since bug 872044 was reported by outside person.

Amit Khare (amit-khare) wrote :

Observed with panda ubuntu pre-built image
https://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/329/lt-panda-x11-base-precise_ubuntu-desktop_20120924-329.img.gz

While pairing with the BT headset the board freezes. File transfer on another computer is not working.

root@linaro-ubuntu-desktop:~# [ 1189.981018] hci0: type 1 len 9
[ 1201.423980] hci0: type 1 len 17
[ 1201.930999] hci0: type 1 len 6
[ 1201.949005] hci0: type 1 len 7
[ 1201.962615] hci0: type 1 len 14
[ 1202.083496] hci0: type 1 len 6
[ 1206.438232] Unable to handle kernel paging request at virtual address 00100104
[ 1206.445983] pgd = c0004000
[ 1206.448883] [00100104] *pgd=00000000
[ 1206.452728] Internal error: Oops: 817 [#1] PREEMPT SMP THUMB2
[ 1206.458801] Modules linked in: omapdrm_pvr(O) arc4 wl12xx wlcore mac80211 cfg80211 omapdce(C) rpmsg_omx omaprpc(C) rfcomm ppdev omap_remotepd
[ 1206.486114] CPU: 0 Tainted: G C O (3.4.0-2-linaro-lt-omap #2~ci+120922092236-Ubuntu)
[ 1206.495513] PC is at l2cap_chan_destroy+0x19/0x64 [bluetooth]
[ 1206.501708] LR is at l2cap_chan_destroy+0x10/0x64 [bluetooth]
[ 1206.507781] pc : [<bf837706>] lr : [<bf8376fd>] psr: 600f0133
[ 1206.507781] sp : ebad5d90 ip : 00000000 fp : eac2405c
[ 1206.519927] r10: ebad5de4 r9 : eae636d8 r8 : eb023320
[ 1206.525451] r7 : 00000006 r6 : ead49800 r5 : eae63400 r4 : eae63400
[ 1206.532348] r3 : 00200200 r2 : 00100100 r1 : ebad5cf0 r0 : bf840e10
[ 1206.539276] Flags: nZCv IRQs on FIQs on Mode SVC_32 ISA Thumb Segment kernel
[ 1206.547210] Control: 50c5387d Table: a932804a DAC: 00000015
[ 1206.553283]
[ 1206.553283] SP: 0xebad5d10:
[ 1206.557800] 5d10 eae63400 bf840e24 00000006 00000000 00000000 00000000 600f0113 c005d90f
[ 1206.566528] 5d30 00000002 bf837706 600f0133 ffffffff ebad5d7c c046c1b9 bf840e10 ebad5cf0
[ 1206.575256] 5d50 00100100 00200200 eae63400 eae63400 ead49800 00000006 eb023320 eae636d8
[ 1206.583984] 5d70 ebad5de4 eac2405c 00000000 ebad5d90 bf8376fd bf837706 600f0133 ffffffff
[ 1206.592712] 5d90 ead49800 bf83a887 eb023200 bf83a915 bf83a909 bf838831 ebad5ddc c046ddc7
[ 1206.601440] 5db0 00000001 c046ddc7 00000004 00000000 e9154014 00000004 c15dfb14 eb3f95c0
[ 1206.610168] 5dd0 ed0d8040 eb2c9b80 00000001 00420042 00000000 c0776b00 c079c228 00000000
[ 1206.618927] 5df0 ebad5e08 c046afb7 ebad4000 c077f110 00000000 c007652f e545eebe 00000118

Changed in linaro-ubuntu:
milestone: 12.09 → 12.10
Botao (botao-sun) wrote :

On Panda 4430 board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/361/lt-panda-x11-base-precise_ubuntu-desktop_20121007-361.img.gz

System crashes after paired with Motorola S305 Bluetooth headset.

The Bluetooth headset worked well on build 329:

https://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/329/lt-panda-x11-base-precise_ubuntu-desktop_20120924-329.img.gz

Please refer to attachment for more details.

Botao (botao-sun) wrote :

Panda 4430 Bluetooth crashed again during the pairing process, observed on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/375/lt-panda-x11-base-precise_ubuntu-desktop_20121014-375.img.gz

Please refer to attachment for more details.

Soumya Basak (soumya-basak) wrote :

observed on Panda 4430 board with 12.10 release image
https://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/390/lt-panda-x11-base-precise_ubuntu-desktop_20121021-390.img.gz
while sending files via bluetooth throws error "Unable to find service record"

Soumya Basak (soumya-basak) wrote :

observed on panda ubuntu image
https://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/419/lt-panda-x11-base-precise_ubuntu-desktop_20121105-419.img.gz

root@linaro-ubuntu-desktop:~# hcitool scan
Scanning ...
[ 410.804290] Bluetooth: hci0 command tx timeout
Inquiry failed: Connection timed out

not able to scan other BT devices.

Soumya Basak (soumya-basak) wrote :

Observed on panda 4460 ubuntu image
https://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/419/lt-panda-x11-base-precise_ubuntu-desktop_20121105-419.img.gz

BT scaning the Device found, and pair with the devices well.
But Browse Files and Send Files to Device Fails.

Fathi Boudra (fboudra) on 2012-11-24
Changed in linaro-ubuntu:
milestone: 12.10 → none
assignee: Ricardo Salveti (rsalveti) → nobody
Soumya Basak (soumya-basak) wrote :

observed with panda ubuntu 12.11 release builds

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/456/lt-panda-x11-base-precise_ubuntu-desktop_20121125-456.img.gz

sending file to other BT device is failed.

Botao (botao-sun) wrote :

For project "linaro-ubuntu", Linaro has switched from GUI based ubuntu image to solid command line console, and this "Bluetooth" test is no longer required.

Fathi Boudra (fboudra) on 2013-06-07
Changed in linaro-ubuntu:
status: In Progress → Fix Released
To post a comment you must log in.