Panda: Video playback is distorted (using totem player ,480p video)

Bug #989672 reported by Abhishek Paliwal on 2012-04-27
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Unassigned
linaro-landing-team-ti
Fix Released
Undecided
Unassigned

Bug Description

Description:
------------
Video playback is distorted:
Download and play
http://samplemedia.linaro.org/H264/big_buck_bunny_480p_H264_AAC_25fps_1800K.MP4
Screensot attached,

Reproducible:
------------
Yes 5/5

Impact:
--------
Bad video quality

Steps:
--------
1. cd /home/linaro
2. wget http://samplemedia.linaro.org/H264/big_buck_bunny_480p_H264_AAC_25fps_1800K.MP4
3. Open totem player
4. Play this video
Issue: Video player is distorted , refer attached image

Hardware:
----------
Panda 4430

Software:
-----------
http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/10/hwpack_linaro-lt-panda-x11-base_20120426-10_armhf_supported.tar.gz
http://snapshots.linaro.org/precise/images/ubuntu-desktop/119/linaro-precise-ubuntu-desktop-20120426-119.tar.gz

sd card image created:
sudo linaro-media-create --mmc /dev/sdb --dev panda --hwpack hwpack_linaro-lt-panda-x11-base_20120426-10_armhf_supported.tar.gz --binary linaro-precise-ubuntu-desktop-20120426-119.tar.gz

###################################################################
For Panda 4430 & 4460, this issue is observed on following images:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/10/hwpack_linaro-lt-panda-x11-base_20120426-10_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/139/hwpack_linaro-lt-panda-x11-base_20120626-139_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197/hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/201/hwpack_linaro-lt-panda-x11-base_20120725-201_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/242/lt-panda-x11-base-precise_ubuntu-desktop_20120812-242.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/256/lt-panda-x11-base-precise_ubuntu-desktop_20120819-256.img.gz

http://releases.linaro.org/12.08/ubuntu/leb-panda/lt-panda-x11-base_20120826-270-ubuntu-desktop.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/299/lt-panda-x11-base-precise_ubuntu-desktop_20120909-299.img.gz

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/312/lt-panda-x11-base-precise_ubuntu-desktop_20120916-312.img.gz

IglooCommunity isn't the right launchpad project for a pandaboard bug.

Changed in igloocommunity:
status: New → Invalid
Fathi Boudra (fboudra) on 2012-05-01
no longer affects: igloocommunity
warmcat (andy-warmcat) wrote :

Is this still happening with more recent builds?

Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → High
Ricardo Salveti (rsalveti) wrote :

Yes, able to reproduce with the 12.06 RC1 image:
hwpack: hwpack_linaro-lt-panda-x11-base_20120626-139_armhf_supported.tar.gz
image: linaro-precise-ubuntu-desktop-20120626-247.tar.gz

This is probably an issue with the omap xorg driver, as with fbdev (remove pvr-omap4 package) it works as expected.

Botao (botao-sun) wrote :

Now the exactly same issue be observed on Panda 4430 board with DVI-D port connected (HDMI is unavailable due to bug 1019977).

Observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197/hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz

with ubuntu rootfs image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/305/linaro-precise-ubuntu-desktop-20120723-305.tar.gz

Botao (botao-sun) wrote :

Same behavior on Panda 4460 board.

Botao (botao-sun) wrote :

For Panda 4460 board with Unity 2D enabled & DVI-D display output, observed same screen display as comment #1 attachment.

Hardware pack is:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/201/hwpack_linaro-lt-panda-x11-base_20120725-201_armhf_supported.tar.gz

ubuntu rootfs image is:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/313/linaro-precise-ubuntu-desktop-20120725-313.tar.gz

Botao (botao-sun) wrote :

For Panda 4460 board, observed same behaviour as attachment in comment #1 on DVI-D display mode, with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

Botao (botao-sun) wrote :

Same behaviour observed on Panda 4430 board as attachment in comment #1 on HDMI display mode, with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

Amit Khare (amit-khare) wrote :

same observation on panda 4460 with same build as comment #13

Uli Luckas (c94cs2wt6) wrote :

Same here with "xine -V xv" and "xineliboutput-sxfe -V xv".
I can't name an image but updated all packages to most recent before testing.

Uli Luckas (c94cs2wt6) wrote :

One more data point - The distortion has been observed with xine* in fullscreen. Without scaling things seem fine.

Botao (botao-sun) wrote :

For Panda 4460 board, observed same behaviour as attachment in comment #1 on HDMI+Unity 2D display mode, with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/256/lt-panda-x11-base-precise_ubuntu-desktop_20120819-256.img.gz

Botao (botao-sun) wrote :

For Panda 4460 board, observed same behaviour as attachment in comment #1 on HDMI+Unity 2D display mode, with Linaro ubuntu image:

http://releases.linaro.org/12.08/ubuntu/leb-panda/lt-panda-x11-base_20120826-270-ubuntu-desktop.img.gz

Botao (botao-sun) wrote :

For Panda 4460 board, observed same behaviour as attachment in comment #1 on HDMI+Unity 2D display mode, with Linaro ubuntu image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

Botao (botao-sun) on 2012-09-13
description: updated
Botao (botao-sun) on 2012-09-14
description: updated
Botao (botao-sun) on 2012-09-20
description: updated
Botao (botao-sun) on 2012-09-27
description: updated
Botao (botao-sun) wrote :

After install package "ubuntu-omap4-extras-multimedia", the 480p video now can be played well on Panda 4430 board with Linaro ubuntu image:

https://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/329/lt-panda-x11-base-precise_ubuntu-desktop_20120924-329.img.gz

Both on small & full screen.

description: updated
warmcat (andy-warmcat) on 2012-09-27
Changed in linaro-landing-team-ti:
status: New → Fix Released
Amit Khare (amit-khare) wrote :

Also observed on 4460 with same image as comment #23

description: updated
description: updated
Botao (botao-sun) wrote :

For project "linaro-ubuntu", Linaro has switched from GUI based ubuntu image to solid command line console, and this "Video Playback" test is no longer applicable.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments