Regression in HW acceleration on 4430 PandaBoard

Bug #969507 reported by Keyan Mobli on 2012-03-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Ricardo Salveti

Bug Description

In the latest 12.03 release of linaroTV-xbmc, hw acceleration of video playback is nonfunctional. Where before CPU usage would be relatively low, it is now spiked and frames are being dropped in 720p video.

This is on the 4430 Pandaboard.

Uwe Geuder (ubuntulp-ugeuder) wrote :

Yes, video playback regression observed also on Ubuntu desktop image 12.03.

Video playback causes the following error messages and the video is not played

  linaro@linaro-ubuntu-desktop:~$ gst-launch-0.10 playbin2 uri=file:///home/linaro/test_data/The\ Simpsons\ Movie\ -\ Trailer.mp4
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
*** _RcmClient_Instance_init: MessageQ not found
        Error [0xfffffff2] at Line no: 436 in file RcmClient.c
dce.c:1263: dce_init error: failed to create dCE: 0xfffffff2
*** RcmClient_alloc: Invalid handle passed!
        Error [0xffffffec] at Line no: 959 in file RcmClient.c
dce.c:442: Engine_open error: fail: ffffffec
ERROR: from element /GstPlayBin2:playbin20/GstPlaySink:playsink0: The autovideosink element is not working.
Additional debug info:
gstplaysink.c(1332): gen_video_chain (): /GstPlayBin2:playbin20/GstPlaySink:playsink0
ERROR: pipeline doesn't want to preroll.
Setting pipeline to NULL ...
Freeing pipeline ...
linaro@linaro-ubuntu-desktop:~$

(Reportedly it plays sometimes, but I have only seen this error message. It worked 100% fine in 12.01)

Ricardo Salveti (rsalveti) wrote :

Can you update your packages, remove .gstreamer-0.10/ and give it another try?

I updated a few gstreamer related packages at the Overlay, and it's working again for me at least.

Keyan Mobli (persiansown) wrote :

Seems to be working now. Thanks!

Changed in linaro-ubuntu:
status: New → Fix Committed
status: Fix Committed → Fix Released
importance: Undecided → High
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → 12.04
Uwe Geuder (ubuntulp-ugeuder) wrote :

Yes, my mp4 test video works fine after updating.

However, I have another test video and it still does not work (worked fine in 12.01)

$ file /home/linaro/test_data/I-15bis.ogg
/home/linaro/test_data/I-15bis.ogg: Ogg data, Theora video
$ DISPLAY=:0 gst-launch-0.10 playbin2 uri=file:///home/linaro/test_data/I-15bis.ogg
Setting pipeline to PAUSED ...
Pipeline is PREROLLING ...
Pipeline is PREROLLED ...
Setting pipeline to PLAYING ...
New clock: GstPulseSinkClock
PVR:(Error): SGXQueueTransfer: all paths failed [9037, /sgxtransfer_queue.c]
PVR:(Error): SGXQueueTransfer: all paths failed [9037, /sgxtransfer_queue.c]
PVR:(Error): SGXQueueTransfer: all paths failed [9037, /sgxtransfer_queue.c]
(same error message continues forever)

(I'm changing projects and might not have access to hardware to test in future, but I just thought to let you know)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers