Linaro Ubuntu Engineering Builds

Snowball hardware pack does not enable wired network interface

Reported by Zygmunt Krynicki on 2012-03-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
IglooCommunity
High
Lee Jones
Linaro Ubuntu
Medium
Ricardo Salveti

Bug Description

<zyga> rsalveti, snowball hwpack _or_ snowball support in lmc is broken
<rsalveti> zyga: not sure, lag would know better
<zyga> rsalveti, snowball nano images don't start up eth0, there are no entries in /etc/network/interfaces
<rsalveti> that's fine, probably something that needs to be fixed at the hwpack side
<zyga> one of you will want to fix this
<zyga> right
 if anyone reports this (I'm not sure where the fault lies)
<rsalveti> let me check the hwpack
<rsalveti> zyga: http://bazaar.launchpad.net/~linaro-landing-team-ste/linaro-images/hwpack.oneiric.linaro-lt-snowball/view/head:/hwpacks/linaro-lt-snowball
<rsalveti> it's still using hwpack v1 :-(
 if it was v2 you'd just need to add "wired_interfaces=eth0"
<zyga> rsalveti, I don't know what that means sadly
 rsalveti, I see
<rsalveti> different config format
<zyga> rsalveti, well I'm glad LAVA helps you uncover bugs :)
 lag, ^^ now I'm sure you want to fix this :)
<rsalveti> ok, can you open a bug against the igloocommunity project?
<zyga> yup
<rsalveti> zyga: thanks

description: updated
Ricardo Salveti (rsalveti) wrote :

A simple solution for this problem would be to port the hwpack definition file from v1 to v2.

description: updated
Changed in igloocommunity:
status: New → Confirmed
Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → 12.03
Changed in igloocommunity:
assignee: nobody → Lee Jones (lag)
Lee Jones (lag) on 2012-03-21
Changed in igloocommunity:
status: Confirmed → In Progress
importance: Undecided → High
milestone: none → 2012.03
Lee Jones (lag) on 2012-03-22
Changed in igloocommunity:
status: In Progress → Fix Released
Lee Jones (lag) wrote :

Created a new v2 hwpack:
  https://code.launchpad.net/~linaro-landing-team-ste/linaro-images/hwpack-v2.oneiric.linaro-lt-snowball

Added extra parameter to automatically setup eth0:
  wired_interfaces=eth0

Changed in igloocommunity:
milestone: 2012.03 → 2012.04.alpha-1
Anmar Oueja (anmar) wrote :

Lee will revert the changes since the side effect is preventing the system from booting. Must update the release notes accordingly (no auto eth0 upon boot)

Changed in igloocommunity:
status: Fix Released → In Progress
Lee Jones (lag) wrote :

If no dhcpd is found the system just hangs:
  https://launchpad.net/bugs/856810

Changed in igloocommunity:
status: In Progress → Won't Fix
Ricardo Salveti (rsalveti) wrote :

To be reviewed during 12.04, once we get the Precise based images working with Snowball.

Changed in linaro-ubuntu:
milestone: 12.03 → 12.04
Patrik Klinger (patrik-klinger) wrote :

+Lee Jones could you please add a comment that the bug wont be fixed.

Is there another bug that will implement the auto config feature for eth?

Changed in igloocommunity:
milestone: 2012.04.alpha-1 → 2012.03-1
Changed in linaro-ubuntu:
milestone: 12.04 → 12.05
Ricardo Salveti (rsalveti) wrote :

lt-snowball has the eth0 enabled by default, while lt-snowball-x11-base depends on network-manager for network support.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers