Audio jack input and output not working on Panda

Bug #920899 reported by Avik Sil on 2012-01-24
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Ricardo Salveti
linaro-landing-team-ti
Fix Released
High
Unassigned

Bug Description

Image: 12.01 RC

In Sound settings, no audio device is listed in the Hardware tab; neither the audio is working

Ricardo Salveti (rsalveti) wrote :

This is partially the same issue as described by bug 893402, but also adding that jack input is at the same situation.

Tom or Andy, do you know if jack input was ever tested on Panda with tilt-linux-linaro-3.1?

Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → High
tags: added: lt-panda
Avik Sil (aviksil) wrote :

With 12.02 RC image, the audio jack output is working fine, but the jack input is not working.

warmcat (andy-warmcat) wrote :

This is working on current tilt-tracking about to become tilt-3.4

Changed in linaro-landing-team-ti:
status: New → Fix Committed
Fathi Boudra (fboudra) on 2012-06-14
Changed in linaro-ubuntu:
milestone: none → 12.06
Fathi Boudra (fboudra) wrote :

Assign to Ricardo for verification once the tilt-3.4 kernel package is available.

Changed in linaro-ubuntu:
assignee: nobody → Ricardo Salveti (rsalveti)
warmcat (andy-warmcat) wrote :

This is definitely workable in tilt-3.4 / omap4plus_defconfig.

Here's the test script we use

#!/bin/sh
amixer -Dhw:0 cset name='DL1 Mixer Multimedia' 1
amixer -Dhw:0 cset name='DL1 Media Playback Volume' 118
amixer -Dhw:0 cset name='Sidetone Mixer Playback' 1
amixer -Dhw:0 cset name='SDT DL Volume' 120
amixer -Dhw:0 cset name='DL1 PDM Switch' 1
amixer -Dhw:0 cset name='Headset Left Playback' 'HS DAC'
amixer -Dhw:0 cset name='Headset Right Playback' 'HS DAC'
amixer -Dhw:0 cset name='Headset Playback Volume' 13
aplay -Dhw:0,6 -M -f S16_LE -c 2 test48.wav

where test48.wav is a 48kHz stereo 16bps wav file.

Ricardo Salveti (rsalveti) wrote :

Also worked fine for me with 4460, without any other change besides recording and playing the sound by the default applications.

AFAIK Paul said he got it working with 4430, so it could be related with your test environment. Will give it a try on 4430.

Ricardo Salveti (rsalveti) wrote :

Also worked with me at 4430, so might be something with your test environment. Can we get someone else to also validate this test case to make sure we're not getting an issue which is just hard to reproduce?

Changed in linaro-ubuntu:
status: Confirmed → Fix Committed
Fathi Boudra (fboudra) wrote :

Verified with lt-panda-x11-base build 139 on OMAP4430. Worksforme.

warmcat (andy-warmcat) wrote :

I'm pretty sure there's nothing for TILT to do here, closing as Fix Released.

Changed in linaro-landing-team-ti:
status: Fix Committed → Fix Released
Usman Ahmad (usman-ah) on 2012-06-28
Changed in linaro-landing-team-ti:
importance: Undecided → High
David Long (dave-long) wrote :

I've just tested audio output on the Panda 4430 with the 20120708 images listed above. The audio settings menu displays two choices: 3.5mm headset, and "Analog Output HDMI". I get audio on the expected output when I select it from the menu and use the "Test Sound" button.

Botao (botao-sun) wrote :

For Panda 4430 board, observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/175/hwpack_linaro-lt-panda-x11-base_20120714-175_armhf_supported.tar.gz

with ubuntu rootfs image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/287/linaro-precise-ubuntu-desktop-20120714-287.tar.gz

For sound settings, on output section, there are 2 options: 3.5mm jack & HDMI. Audio over HDMI works well, but 3.5mm jack output doesn't work.

warmcat (andy-warmcat) wrote :

Botao, is it possible the jack on your Panda, or your headphones, are busted?

We tested them also on 4430 and they are workable.

FWIW it is the lower jack of the two that is the audio output, just in case.

If you don't believe us, well, probably that is what testing means that you don't believe us, but is there someone else you can ask for a second opinion that you can trust? Otherwise we hear about this bug forever and we don't think it's a real problem.

Botao (botao-sun) wrote :

@warmcat, My headset works well, I use it to listen music, make VOIP calls, etc., and it also works on vexpress board with ubuntu image. For Panda 4430 board, the audio over 3.5mm jack doesn't work on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197/hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz

with ubuntu rootfs:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/305/linaro-precise-ubuntu-desktop-20120723-305.tar.gz

I will check the Panda 4460 soon, which is I just bought from Internet.

warmcat (andy-warmcat) wrote :

On Panda, it is not a 4-pole headset jack, just three pole for line out / stereo headphone (in fact there are no mic arrangements at all, the upper socket is for line-in with no bias).

If you're using a 4-pole jack it may not be providing signal to the headphone part properly.

Another way to confirm it, is there any Panda hardware pack, no matter how old, that makes sound come on your headset?

Botao (botao-sun) wrote :

OK, for my Panda 4460 board, audio output works well via 3.5mm jack port (lower one).

warmcat (andy-warmcat) wrote :

For audio input there are some differences in routing between 4430 and 4460 Pandas. That shows up in UCM differences too.

But there isn't any difference in routing for audio output.

Paul Larson (pwlars) wrote :

For Panda 4430 board, observed on hardware pack:
http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197/hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz

with ubuntu rootfs image:
http://snapshots.linaro.org/precise/images/ubuntu-desktop/305/linaro-precise-ubuntu-desktop-20120723-305.tar.gz

I see both the 3.5mm and hdmi output devices, and output over both works just fine for me as long as I select it. The headset seems to be the default regardless of whether anything is plugged into the headphone jack.

Amit Khare (amit-khare) wrote :

observed on panda 4430 with build
http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/242/lt-panda-x11-base-precise_ubuntu-desktop_20120812-242.img.gz

HDMI sound works fine but 3.5mm jack out put is not working

Ricardo Salveti (rsalveti) wrote :

Tested with http://snapshots.linaro.org/precise/images/ubuntu-desktop/376/linaro-precise-ubuntu-desktop-20120826-376.tar.gz + http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/270/hwpack_linaro-lt-panda-x11-base_20120826-270_armhf_supported.tar.gz and was able to use the jack output just fine.

Same result as I got with previous releases. Will mark it as fix released for now, please re-open it if you're still having this issue with the newer kernel/hwpack.

Changed in linaro-ubuntu:
status: Fix Committed → Fix Released
Amit Khare (amit-khare) wrote :

after inserting the headset i get 2 option in sound setting.
1. pandaboard 3.5mm headset playback and capture
2. analog output - OMAP HDMI

after selecting pandaboard 3.5 mm headset i still cant hear any sound from the headset

Botao (botao-sun) wrote :

@Ricardo, unfortunately the 3.5mm audio output jack port doesn't work on my Panda 4430, however, it's not surprise since I highly doubt there is a hardware broken on my Panda 4430board.

@Amit, I remember the 3.5mm audio output jack port worked on your Panda 4430 before, then if you could not hear any sound after that, then perhaps something goes wrong.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers