please enable CONFIG_TUN

Bug #904737 reported by Domen Puncer on 2011-12-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
IglooCommunity
Medium
Philippe Langlais
Linaro Ubuntu
Medium
Ricardo Salveti
linaro-landing-team-samsung
Fix Released
Undecided
Unassigned

Bug Description

I really miss this one:

# CONFIG_TUN is not set

and it looks I'm not the only one: http://ask.linaro.org/questions/202/tunko-for-linaro-compilation

Ricardo Salveti (rsalveti) wrote :

Seems this is an issue with all the flavors we currently support. Didn't open a bug task for TI LT because the dev plat team is maintaining the package.

affects: linux-linaro → linaro-ubuntu
Changed in linaro-ubuntu:
status: New → Incomplete
status: Incomplete → Triaged
importance: Undecided → Medium
milestone: none → 11.12
Changed in linaro-landing-team-samsung:
status: New → Fix Released
Changed in linaro-ubuntu:
milestone: 11.12 → 12.01
Domen Puncer (domen) wrote :

Kernel on
http://snapshots.linaro.org/oneiric/igep-oneiric/20120102/0/images/hwpack/
still doesn't have this option set.

Or should I look elsewhere?

Anmar Oueja (anmar) wrote :

Seems easy enough to do so it shouldn't be a problem to target it at 2012.01 cycle.

no longer affects: linaro-landing-team-ste
Changed in igloocommunity:
milestone: none → 2012.01
status: New → Confirmed
Ricardo Salveti (rsalveti) wrote :

Patch sent to John so it can be added at the LT TI packaging tree. A new kernel should be around in 1 or 2 days with the fix.

Changed in linaro-ubuntu:
status: Triaged → In Progress
assignee: nobody → Ricardo Salveti (rsalveti)
Anmar Oueja (anmar) on 2012-01-17
Changed in igloocommunity:
importance: Undecided → Medium
assignee: nobody → Philippe Langlais (philang)
Philippe Langlais (philang) wrote :

CONFIG_TUN is already set in u8500_defconfig for Ubuntu Igloo Kernel 3.0 & higher version

Anmar Oueja (anmar) on 2012-01-19
Changed in igloocommunity:
status: Confirmed → Fix Released
Domen Puncer (domen) wrote :

http://snapshots.linaro.org/oneiric/igep-oneiric/20120116/0/images/hwpack/ which is the latest snapshot does not include the fix.

Domen Puncer (domen) wrote :

What am I missing? Where can I see the fix released?

Linaro snapshot from yesterday still doesn't have this set.

Changed in igloocommunity:
status: Fix Released → In Progress
Kalle Vahlman (kvahlman) wrote :

This is fixed (or technically it never existed I think) on Snowball kernels, so for igloocommunity project this should be resolved as fix released.

Changed in igloocommunity:
milestone: 2012.01 → none
status: In Progress → Fix Released

On Fri, Jan 20, 2012 at 5:51 AM, Domen Puncer <email address hidden> wrote:
> What am I missing? Where can I see the fix released?
>
> Linaro snapshot from yesterday still doesn't have this set.

That's because this is an issue with another kernel package, and not
the one for snowball.

I'm looking a getting this fixed for the common linux-linaro packages today.

Ricardo Salveti (rsalveti) wrote :

Patch sent to John Rigby, and the new linux-linaro packages should be available at the Overlay tomorrow.

Ernst Bachmann (e-bachmann) wrote :

While you're adding kernel modules:

CONFIG_VLAN_8021Q

for VLAN support and

CONFIG_BRIDGE

for bridging would be quite useful for me.

On the other hand, there seem to be some quite strange other network options enabled, for example

CONFIG_USB_NET_ZAURUS=y

Which, IMHO, should be a module, if enabled at all.

Ricardo Salveti (rsalveti) wrote :

Thanks for reviewing the changes, I just copied the generic support available at ubuntu's kernel package. Will update it again adding your extra requests.

Changed in linaro-ubuntu:
milestone: 12.01 → 12.02
Domen Puncer (domen) wrote :

$ grep CONFIG_TUN boot/config-3.1.0-14-linaro-omap
CONFIG_TUN=m

Thanks!

Changed in linaro-ubuntu:
status: In Progress → Fix Released
Guodong Xu (guodong-xu) on 2012-02-23
tags: added: imx6

Hi,

It seems that there are a number of related queries on Ask Linaro.

The lack of available kernel modules (compared to what you have in a standard Ubuntu distro) makes it more difficult to use our images for prototypes.

The same happened to me last week-end when I had to replace my dead IGEPv2 board by a more recent one, and choose to use the Linaro distro. I had to recompile my kernel because the Linaro omap kernel missed the below settings:

CONFIG_DM, CONFIG_BLK_DEV_DM, CONFIG_DM_CRYPT, CONFIG_CRYPTO_SHA256

(I needed that to access an encrypted disk).

It would make everyone's life easier if Linaro could ship bigger hardware packs with more modules compiled by default. Yes, it would make the root filesystems bigger, but wouldn't it be acceptable for prototypes? I guess that's what most Linaro hardware packs are used: building prototypes.

Thoughts?

Michael.

Guodong Xu (guodong-xu) on 2012-02-25
Changed in linaro-landing-team-freescale:
assignee: nobody → Haitao Zhang (minipanda)
Guodong Xu (guodong-xu) on 2012-03-12
Changed in linaro-landing-team-freescale:
milestone: none → 2012.03
status: New → In Progress
importance: Undecided → Medium
Guodong Xu (guodong-xu) on 2012-04-01
Changed in linaro-landing-team-freescale:
status: In Progress → Fix Committed
Guodong Xu (guodong-xu) on 2012-04-05
Changed in linaro-landing-team-freescale:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers