Poor graphics with Compiz and Unity 3D

Bug #893538 reported by Avik Sil on 2011-11-22
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Ricardo Salveti
ubuntu-omap4-extras-graphics
Undecided
Unassigned

Bug Description

Mouse movement is sluggish. Getting poor screen graphics, see attached screenshot.

Avik Sil (aviksil) wrote :
Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ricardo Salveti (rsalveti)
summary: - Poor graphics with 2011.11 lt-hwpack
+ Poor graphics with 2011.11 lt-panda hwpack

Same issue with 11.12 RC image.

Ricardo Salveti (rsalveti) wrote :

The flickering is normal, because of the lack of proper HW cursor.

When testing I also noticed that the Semi-HW cursor makes things worse with Compiz, so if you force "SWcursor" to "true" you'll see that the pointer will behave better, at least it'll always show one single pointer and not two.

Xavier, do you know why Semi-HW cursor is enabled by default at the current pvr_drv?

summary: - Poor graphics with 2011.11 lt-panda hwpack
+ Poor graphics with Compiz and Unity 3D

When this was implemented, it was decided to enable it by default.
You can use SW cursor by enabling it
into /usr/share/X11/xorg.conf.d/99-pvr.conf.panda as you explained:
        Option "SWCursor" "true"

We shall change this default value in future releases.

*Xavier*

On Thu, Jan 12, 2012 at 11:12 PM, Ricardo Salveti <email address hidden>wrote:

> The flickering is normal, because of the lack of proper HW cursor.
>
> When testing I also noticed that the Semi-HW cursor makes things worse
> with Compiz, so if you force "SWcursor" to "true" you'll see that the
> pointer will behave better, at least it'll always show one single
> pointer and not two.
>
> Xavier, do you know why Semi-HW cursor is enabled by default at the
> current pvr_drv?
>
> ** Summary changed:
>
> - Poor graphics with 2011.11 lt-panda hwpack
> + Poor graphics with Compiz and Unity 3D
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/893538
>
> Title:
> Poor graphics with Compiz and Unity 3D
>
> Status in Linaro Ubuntu Evaluation Builds:
> Confirmed
> Status in Ubuntu OMAP4 graphics addons:
> New
>
> Bug description:
> Mouse movement is sluggish. Getting poor screen graphics, see attached
> screenshot.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-ubuntu/+bug/893538/+subscriptions
>

Ricardo Salveti (rsalveti) wrote :

On Fri, Jan 13, 2012 at 6:35 AM, Xavier Boudet
<email address hidden> wrote:
> When this was implemented, it was decided to enable it by default.
> You can use SW cursor by enabling it
> into /usr/share/X11/xorg.conf.d/99-pvr.conf.panda as you explained:
>        Option          "SWCursor"      "true"
>
> We shall change this default value in future releases.

Yes, I tested by setting this config and it worked better.

As we don't use any xorg file (ubuntu's recommendation), would be nice
if this could be enabled by default at future releases.

Thanks!

Xavier Boudet (x-boudet) wrote :

Hello Ricardo,

For you info, I have pushed today a new pvr-omap in release ppa: version
1.7.10.0.1.9-1
This one have SWCursor ON by default.
I did not generate a "compiz" version with EXA patch reverted as far as it
is no more needed according to my comprehension.
Is it ok for you?

Regards,

*Xavier Boudet -* Texas Instruments France
Linux SW Integration - Platform Enablement Organization
Office: +33 4 93 22 *26 83*

Texas Instruments France SA, 821 Avenue Jack Kilby, 06270 Villeneuve
Loubet. 036 420 040 R.C.S Antibes. Capital de EUR 753.920

On Fri, Jan 13, 2012 at 7:01 PM, Ricardo Salveti <email address hidden>wrote:

> On Fri, Jan 13, 2012 at 6:35 AM, Xavier Boudet
> <email address hidden> wrote:
> > When this was implemented, it was decided to enable it by default.
> > You can use SW cursor by enabling it
> > into /usr/share/X11/xorg.conf.d/99-pvr.conf.panda as you explained:
> > Option "SWCursor" "true"
> >
> > We shall change this default value in future releases.
>
> Yes, I tested by setting this config and it worked better.
>
> As we don't use any xorg file (ubuntu's recommendation), would be nice
> if this could be enabled by default at future releases.
>
> Thanks!
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/893538
>
> Title:
> Poor graphics with Compiz and Unity 3D
>
> Status in Linaro Ubuntu Evaluation Builds:
> Confirmed
> Status in Ubuntu OMAP4 graphics addons:
> New
>
> Bug description:
> Mouse movement is sluggish. Getting poor screen graphics, see attached
> screenshot.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-ubuntu/+bug/893538/+subscriptions
>

Ricardo Salveti (rsalveti) wrote :

Thanks a lot Xavier, we have this driver integrated at our release for quite a while already (sorry for not posting the results earlier).

With the newer driver and newer Unity3d + Compiz the interface is working a lot better than before.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
milestone: none → 12.02

No Pb, thx for the update...

Regards,

*Xavier Boudet -* Texas Instruments France
Linux SW Integration - Platform Enablement Organization
Office: +33 4 93 22 *26 83*

Texas Instruments France SA, 821 Avenue Jack Kilby, 06270 Villeneuve
Loubet. 036 420 040 R.C.S Antibes. Capital de EUR 753.920

On Wed, Feb 22, 2012 at 8:36 AM, Ricardo Salveti <email address hidden>wrote:

> Thanks a lot Xavier, we have this driver integrated at our release for
> quite a while already (sorry for not posting the results earlier).
>
> With the newer driver and newer Unity3d + Compiz the interface is
> working a lot better than before.
>
> ** Changed in: linaro-ubuntu
> Status: Confirmed => Fix Released
>
> ** Changed in: linaro-ubuntu
> Milestone: None => 12.02
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/893538
>
> Title:
> Poor graphics with Compiz and Unity 3D
>
> Status in Linaro Ubuntu Evaluation Builds:
> Fix Released
> Status in Ubuntu OMAP4 graphics addons:
> New
>
> Bug description:
> Mouse movement is sluggish. Getting poor screen graphics, see attached
> screenshot.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-ubuntu/+bug/893538/+subscriptions
>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers