installing lt-panda hwpack fails

Bug #886101 reported by Michael Hudson-Doyle on 2011-11-04
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Undecided
Ricardo Salveti

Bug Description

As seen on http://validation.linaro.org/lava-server/scheduler/job/3287, trying to install the lt-panda hwpack on the ubuntu desktop for the released images fails:

<LAVA_DISPATCHER>2011-11-03 09:46:42 PM INFO: deploying on panda22
<LAVA_DISPATCHER>2011-11-03 09:46:42 PM INFO: hwpack: http://releases.linaro.org/11.10/ubuntu/leb-panda/hwpack_linaro-lt-panda-x11-base_20111026-2_armel_supported.tar.gz
<LAVA_DISPATCHER>2011-11-03 09:46:42 PM INFO: rootfs: http://releases.linaro.org/11.10/ubuntu/leb-panda/linaro-o-ubuntu-desktop-tar-20111026-0.tar.gz
<LAVA_DISPATCHER>2011-11-03 09:46:42 PM INFO: Booting master image
reboot

...

Setting up ti-uim (0.0+git20110201+c738944-1linaro3) ...
start: Unknown job: ti-uim
invoke-rc.d: initscript ti-uim, action "start" failed.
dpkg: error processing ti-uim (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of hwpack-linaro-lt-panda-x11-base:
 hwpack-linaro-lt-panda-x11-base depends on ti-uim; however:
  Package ti-uim is not configured yet.

mwhudson@control:~$ linaro-media-create --version
/usr/lib/pymodules/python2.6/argparse.py:1576: DeprecationWarning: The "version" argument to ArgumentParser is deprecated. Please use "add_argument(..., action='version', version="N", ...)" instead
  """instead""", DeprecationWarning)
linaro-media-create 2011.10 : qemu-arm version 0.15.50 (Debian
0.15.50-2011.08-0ubuntu2~ppa10.10.1), Copyright (c) 2003-2008 Fabrice Bellard

Tom Gall (tom-gall) wrote :

Is the host a maverick system?

Fathi Boudra (fboudra) wrote :

yes, it's maverick.

Fathi Boudra (fboudra) wrote :

I can't reproduce on Oneiric

On Fri, Nov 4, 2011 at 11:40 AM, Fathi Boudra <email address hidden> wrote:
> yes, it's maverick.

Then that's probably the issue Tom was having before the release.

Don't know if it was related with the qemu version or any other thing
at the system, maybe Tom can explain better what he did that fixed the
issue.

Tom Gall (tom-gall) wrote :

My solution was to update my "old and crusty" maverick install to oneiric. :-(

nooperation (nooperation) wrote :

I've got the same problem with Ubuntu 10.04 LTS (Lucid Lynx) and the latest version of the linaro-image-tools (2011.10+1-0ubuntu1~linaro1).

================================================================================
sudo linaro-media-create --rootfs ext4 --mmc /dev/sde --binary linaro-o-ubuntu-desktop-tar-20111103-0.tar.gz --hwpack hwpack_linaro-lt-panda-x11-base_20111103-0_armel_supported.tar.gz --dev panda
[sudo] password for juergen:
/usr/lib/pymodules/python2.6/argparse.py:1576: DeprecationWarning: The "version" argument to ArgumentParser is deprecated. Please use "add_argument(..., action='version', version="N", ...)" instead
  """instead""", DeprecationWarning)

[..]

Setting up libopenvg1-sgx-omap4 (1.7.9.2.1.5-1linaro1) ...
Setting up ti-uim (0.0+git20110201+c738944-1linaro3) ...
start: Unknown job: ti-uim
invoke-rc.d: initscript ti-uim, action "start" failed.
dpkg: error processing ti-uim (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of hwpack-linaro-lt-panda-x11-base:
 hwpack-linaro-lt-panda-x11-base depends on ti-uim; however:
  Package ti-uim is not configured yet.
dpkg: error processing hwpack-linaro-lt-panda-x11-base (--configure):
 dependency problems - leaving unconfigured
Setting up linux-headers-3.0.0-12 (3.0.0-12.20) ...
Setting up manpages (3.27-1ubuntu2) ...
Setting up manpages-dev (3.27-1ubuntu2) ...
/bin/df: cannot read table of mounted file systems: No such file or directory
No apport report written because the error message indicates its a followup error from a previous failure.
Setting up u-boot-tools (2011.06-3ubuntu1) ...
Setting up uboot-mkimage (2011.06-3ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 ti-uim
 hwpack-linaro-lt-panda-x11-base
E: Sub-process /usr/bin/dpkg returned an error code (1)
Cleaning up ...Done
proc umounted
Traceback (most recent call last):
  File "/usr/bin/linaro-media-create", line 161, in <module>
    verified_files, *hwpacks)
  File "/usr/lib/pymodules/python2.6/linaro_image_tools/media_create/chroot_utils.py", line 64, in install_hwpacks
    install_hwpack(chroot_dir, hwpack_file, hwpack_force_yes or hwpack_verified)
  File "/usr/lib/pymodules/python2.6/linaro_image_tools/media_create/chroot_utils.py", line 85, in install_hwpack
    cmd_runner.run(args, as_root=True, chroot=chroot_dir).wait()
  File "/usr/lib/pymodules/python2.6/linaro_image_tools/cmd_runner.py", line 100, in wait
    raise SubcommandNonZeroReturnValue(self._my_args, returncode)
linaro_image_tools.cmd_runner.SubcommandNonZeroReturnValue: Sub process "['chroot', '/tmp/tmpog7fJL/binary/boot/filesystem.dir', 'linaro-hwpack-install', '/hwpack_linaro-lt-panda-x11-base_20111103-0_armel_supported.tar.gz']" returned a non-zero value: 100
================================================================================

Michael Hudson-Doyle (mwhudson) wrote :

Well we want to upgrade validation.linaro.org to oneiric reasonably soon, but I guess it would be good to understand the issue a bit. I guess the obvious suspect is the qemu version?

nooperation (nooperation) wrote :

As I don't know how the linaro tools do their job I can't tell if it's a qemu problem or not but here is the version installed on my Ubuntu 10.04 LTS (Lucid Lynx).

==========================================
qemu-user-static
0.15.50-2011.10-0ubuntu1~ppa10.04.2
==========================================

I hope it helps to fix the issue.

Ricardo Salveti (rsalveti) wrote :

I believe this is a combination of your userspace, upstart and qemu. I update the ti-uim package to avoid starting once the package is installed, as it's udev should handle it anyway. Without starting ti-uim while you're flashing the sd card should make it work again.

Changed in linux-linaro:
status: New → Fix Released
assignee: nobody → Ricardo Salveti (rsalveti)
affects: linux-linaro → linaro-ubuntu
Fang Bao (fang-bao) wrote :

I also encountered this issue when installing Linaro Ubuntu 11.10 to SD for Pandaboard and I can't resolve it.

==========================================

$ sudo linaro-media-create --mmc /dev/sdb --dev panda --hwpack hwpack_linaro-lt-panda-x11-base_20111026-2_armel_supported.tar.gz --binary linaro-o-ubuntu-desktop-tar-20111026-0.tar.gz
/usr/lib/pymodules/python2.6/argparse.py:1576: DeprecationWarning: The "version" argument to ArgumentParser is deprecated. Please use "add_argument(..., action='version', version="N", ...)" instead
  """instead""", DeprecationWarning)

Setting up ti-uim (0.0+git20110201+c738944-1linaro3) ...
start: Unknown job: ti-uim
invoke-rc.d: initscript ti-uim, action "start" failed.
dpkg: error processing ti-uim (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of hwpack-linaro-lt-panda-x11-base:
 hwpack-linaro-lt-panda-x11-base depends on ti-uim; however:
  Package ti-uim is not configured yet.
dpkg: error processing hwpack-linaro-lt-panda-x11-base (--configure):
 dependency problems - leaving unconfigured

==========================================

$ linaro-media-create --version
/usr/lib/pymodules/python2.6/argparse.py:1576: DeprecationWarning: The "version" argument to ArgumentParser is deprecated. Please use "add_argument(..., action='version', version="N", ...)" instead
  """instead""", DeprecationWarning)
linaro-media-create 2011.11 : qemu-arm version 0.15.50 (Debian
0.15.50-2011.10-0ubuntu1~ppa10.10.1), Copyright (c) 2003-2008 Fabrice Bellard

==========================================

qemu-user-static
0.15.50-2011.10-0ubuntu1~ppa10.04.2

==========================================

Ricardo Salveti (rsalveti) wrote :

On Thu, Nov 24, 2011 at 4:25 AM, Fang Bao <email address hidden> wrote:
> I also encountered this issue when installing Linaro Ubuntu 11.10 to SD
> for Pandaboard and I can't resolve it.

This was fixed for 11.11, please try the hwpack
http://snapshots.linaro.org/oneiric/lt-panda-x11-base-oneiric/20111122/1/images/hwpack/hwpack_linaro-lt-panda-x11-base_20111122-1_armel_supported.tar.gz

BTW, our 11.11 release is tomorrow.

Fang Bao (fang-bao) wrote :

I tried the latest 11.11 ubuntu image and found this issue was fixed.

Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers