gator binary package does not match kernel

Bug #877242 reported by Colin Tuckley on 2011-10-18
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro ST-Ericsson Landing Team Project
Fix Released
Medium
Mathieu Poirier
Linaro Ubuntu
Medium
Ricardo Salveti
linaro-landing-team-arm
Fix Released
Medium
Tixy (Jon Medhurst)
linaro-landing-team-samsung
Fix Released
Undecided
Usman Ahmad

Bug Description

Running Linaro on i.MX53 the binary gator module package does not match the kernel.

root@linaro-alip:~# uname -a
Linux linaro-alip 2.6.38-1000-linaro-lt-mx5 #11-Ubuntu Tue Sep 27 15:41:40 UTC 2011 armv7l armv7l armv7l GNU/Linux

Gator module package: gator-module-2.6.38-1000-linaro-lt-mx5

root@linaro-alip:~# modprobe gator
FATAL: Error inserting gator (/lib/modules/2.6.38-1000-linaro-lt-mx5/misc/gator.ko): Invalid module format

affects: linux-linaro → linaro-ubuntu
Changed in linaro-ubuntu:
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → 11.10
status: New → Confirmed
importance: Undecided → Medium
Ricardo Salveti (rsalveti) wrote :

There's no gator-module package for lt-mx5 for the 5.7 release, so I believe you're just using the older one available at the PPA.

We'll have a newer kernel (3.1) for mx5 this cycle, and will request the LTs to enable the configs to be able to generate a pre-compiled gator-module package. Meanwhile you can try installing the gator-module-dkms package, but I believe it'll fail due missing config options.

We'd need https://bugs.launchpad.net/ubuntu/+source/linux-linaro-vexpress/+bug/764796 to be fixed for i.Mx53 builds so that gator binary package for i.Mx53 gets built against the right kernel config.

Anmar Oueja (anmar) on 2011-10-19
Changed in linaro-landing-team-freescale:
milestone: none → 2011.11
Anmar Oueja (anmar) on 2011-10-19
Changed in linaro-landing-team-ste:
milestone: none → 2011.11
assignee: nobody → Lee Jones (lag)
Changed in linaro-landing-team-samsung:
milestone: none → 2011.11
assignee: nobody → Usman Ahmad (usman-ah)
Eric Miao (eric.y.miao) on 2011-10-25
Changed in linaro-landing-team-freescale:
assignee: nobody → Eric Miao (eric.y.miao)
importance: Undecided → Medium
status: New → Triaged
Eric Miao (eric.y.miao) wrote :

@Vinod Krishnamoni, the bug 764796 should have been fixed, could you try the latest landing team's build, and let know if this gator module still fails to build or not.

Paweł Moll (pawel-moll) wrote :

@Eric: Cool, but could you please tell us where is it? ;-) I can't find any lt-mx kernel neither here https://launchpad.net/~linaro-maintainers/+archive/kernel nor here https://launchpad.net/~linaro-landing-team-freescale/+archive/public.

Also, correct me if I'm wrong, but Ricardo will have to trigger the DS5 PPA to build new version of gator? Unless it happens automagically?

On Tue, Oct 25, 2011 at 11:11 AM, Paweł Moll <email address hidden> wrote:
> Also, correct me if I'm wrong, but Ricardo will have to trigger the DS5
> PPA to build new version of gator? Unless it happens automagically?

Yes, I'll bump gator-module to rebuild against the 11.10 kernel packages.

Paweł Moll (pawel-moll) wrote :

@Eric: Uh, sorry - apparently got blind for a second (I see linux-linaro-lt-mx5-3.1 3.1.0-1001.6 now ;-)

Hi Ricardo, Eric and others,

The end goal for the exercise is that users ( DS-5 tools users, partner FAEs, partner kernel developers etc ) should be able to pull a Freescale i.Mx5 evaluation build from http://www.linaro.org/downloads/ ( or a snowball / origen / panda eval build for that matter) , install the correct gator ppa for the platform automagically and get going with the profiling tools without having to rebuild the kernel image or the gator module.

Pawel tells me that eval builds produced by the developer platform team uses hwpacks produced from the lt kernel ( at least in the case of Freescale i.Mx ), so this should work. Shout if this is not the case.

Thanks,
Vinod

Angus Ainslie (angus-akkea) wrote :

Hi Vinod,

On Tue, Oct 25, 2011 at 4:07 AM, Vinod Krishnamoni
<email address hidden> wrote:
> Hi Ricardo, Eric and others,
>
> The end goal for the exercise is that users ( DS-5 tools users, partner
> FAEs, partner kernel developers etc ) should be able to pull a Freescale
> i.Mx5 evaluation build from http://www.linaro.org/downloads/ ( or a
> snowball / origen / panda eval build for that matter) , install the
> correct gator ppa for the platform automagically  and get going with the
> profiling tools without having to rebuild the kernel image or the gator
> module.
>

Are there instructions in the wiki for installing the "correct" gator ppa ?

Is there any way we can test the module if functioning correctly ?

Thanks
Angus

> Pawel tells me that eval builds produced by the developer platform team
> uses hwpacks produced from the lt kernel ( at least in the case of
> Freescale i.Mx ), so this should work. Shout if this is not the case.
>
> Thanks,
> Vinod
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: Samsung, which is subscribed to linaro-landing-team-
> samsung.
> https://bugs.launchpad.net/bugs/877242
>
> Title:
>  gator binary package does not match kernel
>
> Status in Linaro ARM Landing Team Project:
>  New
> Status in Linaro Freescale Landing Team Project:
>  Triaged
> Status in Linaro Samsung Landing Team Project:
>  New
> Status in Linaro ST-Ericsson Landing Team Project:
>  New
> Status in Linaro Ubuntu Evaluation Builds:
>  Confirmed
>
> Bug description:
>  Running Linaro on i.MX53 the binary gator module package does not
>  match the kernel.
>
>  root@linaro-alip:~# uname -a
>  Linux linaro-alip 2.6.38-1000-linaro-lt-mx5 #11-Ubuntu Tue Sep 27 15:41:40 UTC 2011 armv7l armv7l armv7l GNU/Linux
>
>  Gator module package: gator-module-2.6.38-1000-linaro-lt-mx5
>
>  root@linaro-alip:~# modprobe gator
>  FATAL: Error inserting gator (/lib/modules/2.6.38-1000-linaro-lt-mx5/misc/gator.ko): Invalid module format
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-landing-team-arm/+bug/877242/+subscriptions
>

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Changed in linaro-landing-team-samsung:
status: New → Triaged

Hi Angus,
The instructions for installing the ppa are at https://launchpad.net/~linaro-maintainers/+archive/arm-ds5. ( see Technical details link on the page )

We are trying to get automated tests for gator into LAVA but in the meanwhile you can do a simple command line test by following the instructions at http://infocenter.arm.com/help/index.jsp?topic=/com.arm.doc.dui0482e/CIHDJFDA.html . Effectively, we need the gator module to be loaded correctly by the gator daemon and do a capture of performance data for a few seconds to prove it is working on the target.

Anmar Oueja (anmar) on 2011-10-27
Changed in linaro-landing-team-arm:
importance: Undecided → Medium
milestone: none → 2011.11
Anmar Oueja (anmar) on 2011-10-27
Changed in linaro-landing-team-ste:
status: New → Confirmed
importance: Undecided → Medium
Fathi Boudra (fboudra) on 2011-11-11
Changed in linaro-ubuntu:
milestone: 11.10 → 11.11
Eric Miao (eric.y.miao) wrote :

Relevant config options have been enabled in freescale LT kernel. And thanks Ricardo for his patience and great help, gator module could be built OK against the Freescale LT kernel. However, there are missing symbols when inserting the module, which is very likely caused by recent kernel changes to the PMU part, specifically this commit, http://git.linaro.org/gitweb?p=kernel/linux-linaro-3.1.git;a=commitdiff;h=b0e89590f4f27ea5ff30bdedb9a58ea904a6b353.

The init_pmu() has been removed, and release_pmu() no longer being exported. And considering the significance of the changes, there doesn't seem to be an easy way to fix this within the kernel, and gator module needs to be updated to reflect this change.

Changed in linaro-landing-team-freescale:
milestone: 2011.11 → 2011.12
milestone: 2011.12 → 2011.11
Ryan Harkin (ryanharkin) wrote :

At the moment, I believe that ARM will be fixing this in the gator package and then pushing a new version to the tree

Changed in linaro-landing-team-arm:
status: New → In Progress
Eric Miao (eric.y.miao) wrote :

This depends on gator module being fixed, I'm moving this to next month's milestone, unless this can be fixed soon and we do a respin.

Changed in linaro-landing-team-freescale:
milestone: 2011.11 → 2011.12
Ryan Harkin (ryanharkin) on 2011-11-16
Changed in linaro-landing-team-arm:
milestone: 2011.11 → 2011.10
milestone: 2011.10 → 2011.11
Paweł Moll (pawel-moll) wrote :

The mentioned change is actually 3.2-rc1 (rather then 3.1) commit in the main line - it's changing the pmu reservation API and contains a bug (lack of EXPORT_SYMBOL(release_pmu)).

Anyway, I'll work it around today and update gator Android and Ubuntu repositories.

Anmar Oueja (anmar) on 2011-11-16
Changed in linaro-landing-team-ste:
assignee: Lee Jones (lag) → Mathieu Poirier (mathieu.poirier)
Ricardo Salveti (rsalveti) wrote :

On Wed, Nov 16, 2011 at 9:12 AM, Paweł Moll <email address hidden> wrote:
> The mentioned change is actually 3.2-rc1 (rather then 3.1) commit in the
> main line - it's changing the pmu reservation API and contains a bug
> (lack of EXPORT_SYMBOL(release_pmu)).
>
> Anyway, I'll work it around today and update gator Android and Ubuntu
> repositories.

Great, as the change is just related with the gator-module and not the
kernel, if you manage to get the fix in place until the end of this
week we can still make it for the 11.11 release for all the supported
flavors.

Paweł Moll (pawel-moll) wrote :

The attached patch disables EBS feature in the gator driver, which "solves" the problem. Please replace the current patch (gator-module-fix_release_pmu_call_for_linaro_3_0.patch) in gator-module package with this one.

Changed in linaro-ubuntu:
status: Confirmed → In Progress
Anmar Oueja (anmar) on 2011-11-17
Changed in linaro-landing-team-arm:
milestone: 2011.11 → 2011.12
Changed in linaro-ubuntu:
status: In Progress → Fix Released
Changed in linaro-landing-team-arm:
assignee: nobody → Tixy (Jon Medhurst) (tixy)
milestone: 2011.12 → none
milestone: none → 2011.12
status: In Progress → Fix Released
Tixy (Jon Medhurst) (tixy) wrote :

I can confirm that gator-module 5.8-rc2-1 contains a module that works
with the ARM landing team's vexpress-a9 hwpack. Also, if that module
isn't installed but the linux-headers for the running kernel are, then
installing gator-module will cause the module to be built from source.

Eric Miao (eric.y.miao) wrote :

I confirm that gator-module-5.8.1 works with Freescale LT's hwpack on i.MX53 QuickStart. Tested with latest ds-5 5.8 version. DS-5 5.7 version didn't work, with error of version mismatch.

Changed in linaro-landing-team-freescale:
status: Triaged → Fix Released
Anmar Oueja (anmar) on 2012-01-05
Changed in linaro-landing-team-ste:
status: Confirmed → Fix Released
Changed in linaro-landing-team-samsung:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers