Linaro Ubuntu Engineering Builds

Pulseaudio consumes 100% of the cpu when trying to play a sound with natty's linaro LEB and 3.0.0-1402-linaro-lt-omap

Reported by Ricardo Salveti on 2011-07-26
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Ricardo Salveti

Bug Description

Once gdm starts with the user session, pulseaudio will start and consume 100% of the CPU, letting the desktop unusable.

Linking /bin/true to /usr/bin/pulseaudio makes the system usable again.

Hwpack: hwpack_linaro-lt-panda-x11-base_20110726-1_armel_supported.tar.gz
Image: linaro-n-ubuntu-desktop-tar-20110726-1.tar.gz
Kernel: linux-image-3.0.0-1402-linaro-lt-omap 3.0.0-1402.3~ppa~natty

Another thing is that the serial gets flooded by like:
[ 37.145355] SDP4430 Media: scan for new SDP4430 Media playback streams
[ 37.154266] aess aess: check playback path from MM_DL_LP to PDM_DL1
[ 37.161010] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.170166] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.179229] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.188415] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.197265] SDP4430 Media: scanned playback paths BE PDM_DL1 for stream HS Playback num 0
[ 37.205993] aess aess: check playback path from MM_DL_LP to PDM_DL2
[ 37.212829] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.221618] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.227081] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.239715] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.248565] SDP4430 Media: scanned playback paths BE PDM_DL2 for stream HF Playback num 0
[ 37.257324] aess aess: check playback path from MM_DL_LP to BT_VX_DL
[ 37.264343] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.272979] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.282073] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.290802] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.299530] SDP4430 Media: scanned playback paths BE BT_VX_DL for stream BT num 0
[ 37.303649] aess aess: check playback path from MM_DL_LP to MM_EXT_DL
[ 37.314636] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.320831] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.332031] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.340667] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.349456] SDP4430 Media: scanned playback paths BE MM_EXT_DL for stream FM num 0
[ 37.357635] SDP4430 Media: asoc: SDP4430 Media no valid playback route from source to sink
[ 37.366760] SDP4430 Media: dsp: open FE SDP4430 Media
[ 37.372528] omap-abe-dai omap-abe-dai: omap_abe_dai_startup: MultiMedia1
[ 37.379730] SDP4430 Media: dsp: hw_params FE SDP4430 Media
[ 37.379730] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 37.393615] SDP4430 Media: dsp: prepare FE SDP4430 Media
[ 37.399505] SDP4430 Media: dsp: no backend DAIs enabled for SDP4430 Media
[ 37.406860] SDP4430 Media: dsp: hw_free FE SDP4430 Media
[ 37.412780] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 37.419860] SDP4430 Media: dsp: hw_params FE SDP4430 Media
[ 37.425872] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 37.433410] SDP4430 Media: dsp: prepare FE SDP4430 Media
[ 37.439117] SDP4430 Media: dsp: no backend DAIs enabled for SDP4430 Media
[ 37.446533] SDP4430 Media: dsp: hw_free FE SDP4430 Media
[ 37.452362] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 37.459594] SDP4430 Media: dsp: hw_params FE SDP4430 Media
[ 37.465942] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 37.473266] SDP4430 Media: dsp: prepare FE SDP4430 Media
[ 37.477142] SDP4430 Media: dsp: no backend DAIs enabled for SDP4430 Media
[ 37.486694] SDP4430 Media: dsp: hw_free FE SDP4430 Media
[ 37.488739] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 37.499694] SDP4430 Media: dsp: hw_params FE SDP4430 Media
[ 37.505706] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 37.513031] SDP4430 Media: dsp: prepare FE SDP4430 Media
[ 37.518859] SDP4430 Media: dsp: no backend DAIs enabled for SDP4430 Media
[ 37.526245] SDP4430 Media: dsp: hw_free FE SDP4430 Media
[ 37.532257] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 37.532257] SDP4430 Media: dsp: hw_params FE SDP4430 Media
[ 37.545440] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 37.552795] SDP4430 Media: dsp: prepare FE SDP4430 Media
[ 37.558868] SDP4430 Media: dsp: no backend DAIs enabled for SDP4430 Media
[ 37.566253] SDP4430 Media: dsp: hw_free FE SDP4430 Media
[ 37.567260] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 37.579315] SDP4430 Media: dsp: hw_free FE SDP4430 Media
[ 37.581817] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 37.592803] SDP4430 Media: dsp: close FE SDP4430 Media
[ 37.598419] omap-abe-dai omap-abe-dai: omap_abe_dai_shutdown: MultiMedia1
[ 37.606414] SDP4430 Media: scan for new SDP4430 Media playback streams
[ 37.613616] aess aess: check playback path from MM_DL_LP to PDM_DL1
[ 37.620391] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.629211] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.637908] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.646697] aess aess: 1:try source MM_DL_LP path (null) to MM_DL VMixer len 0 connect 1
[ 37.655700] SDP4430 Media: scanned playback paths BE PDM_DL1 for stream HS Playback num 0

Ricardo Salveti (rsalveti) wrote :

You can find the git tree used to build the kernel at http://git.linaro.org/gitweb?p=people/jcrigby/linux-lt.git;a=summary.

Ricardo Salveti (rsalveti) wrote :

This is probably related with bug 746023, but didn't want to link against it as we're using a newer kernel this time.

Changed in linaro-ubuntu:
milestone: 11.07 → 11.08
Changed in linaro-ubuntu:
assignee: nobody → Ricardo Salveti (rsalveti)
Ricardo Salveti (rsalveti) wrote :

The current workaround we got was to disable sound for both SDP4430 and Panda, until we can get a working kernel and userspace (as we now need proper Alsa UCM support).

Seems a good bug to fix for 11.09.

Kurt Taylor (kurt-r-taylor) wrote :

I was able to reproduce this on panda with:
(release 11.08-RC)
hwpack_linaro-lt-panda-x11-base_20110823-0_armel_supported.tar.gz
linaro-n-ubuntu-desktop-tar-20110823-3.tar.gz

Changed in linaro-ubuntu:
milestone: 11.08 → 11.09
Kan HU (kanhu) wrote :

no audio device found with
hwpack_linaro-lt-panda-x11-base_20110824-1_armel_supported.tar.gz and /linaro-n-ubuntu-desktop-tar-20110824-1.tar.gz

reproduced with hwpack_linaro-lt-panda-x11-base_20110726-1_armel_supported.tar.gz and linaro-n-ubuntu-desktop-tar-20110728-1.tar.gz

Feng Wei (b34248) wrote :
Ricardo Salveti (rsalveti) wrote :

Added latest alsa ucm configs from git://git.linaro.org/people/weifeng/alsa-ucm-conf.git alsa ucm configs at alsa-lib and also changed alsa-utils to call alsaucm via an udev rule.

The main issue with pulse is gone, but only works with Jack, as now Panda shows another sound device just for HDMI:

root@linaro-desktop:~# cat /proc/asound/cards
 0 [Panda ]: OMAP4 - Panda
                      TI OMAP4 Board
 1 [PandaHDMI ]: - PandaHDMI
                      TI OMAP4 HDMI Board

Changed in linaro-ubuntu:
status: Confirmed → Triaged
status: Triaged → Fix Released
James Tunnicliffe (dooferlad) wrote :
Download full text (4.1 KiB)

Looks like it is back in the latest Panda RC hardware pack:

Created image using:
linaro-media-create --nocheck-mmc --hwpack-force-yes --rootfs ext4 --mmc /dev/sdc --dev panda --binary /home/dooferlad/.cache/linaro/image-tools/fetch_image/snapshots.linaro.org/11.05-daily/linaro-ubuntu-desktop/20110926/0/images/tar/linaro-n-ubuntu-desktop-tar-20110926-0.tar.gz --hwpack ~/Downloads/hwpack_linaro-panda_20110927-1110_armel_supported.tar.gz

Hardware pack from http://snapshots.linaro.org/11.05-daily/linaro-hwpacks/lt-panda-x11-base-natty/20110927/1/

As soon as the desktop loads, the collowing message is seen in a continuous loop:

[ 180.596038] SDP4430 Media: asoc: SDP4430 Media no valid playback route from source to sink
[ 180.605255] omap-abe-dai omap-abe-dai: omap_abe_dai_startup: MultiMedia1
[ 180.612518] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 180.621337] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 180.628814] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 180.637084] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 180.644622] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 180.652496] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 180.659698] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 180.667877] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 180.675140] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_params: MultiMedia1
[ 180.679351] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 180.690002] omap-abe-dai omap-abe-dai: omap_abe_dai_hw_free: MultiMedia1
[ 180.697082] omap-abe-dai omap-abe-dai: omap_abe_dai_shutdown: MultiMedia1

This is when connecting my Panda to a monitor over HDMI. When connecting to the same screen using DVI, the screen flickers and I see this message:

[ 35.411529] type=1400 audit(1317289260.955:17): apparmor="STATUS" operation="profile_replace" name="/usr/lib/cups/backend/cups-pdf" pid=1748 comm="apparmor_parser"
[ 35.427185] type=1400 audit(1317289260.986:18): apparmor="STATUS" operation="profile_replace" name="/usr/sbin/cupsd" pid=1748 comm="apparmor_parser"
[ 41.026641] eth0: no IPv6 routers present
[ 45.981994] omapdss DISPC error: GO bit not down for channel 2
[ 45.988769] omapdss DISPC error: GO bit not down for channel 2
[ 52.004089] ieee80211 phy0: device no longer idle - scanning
[ 53.670776] ieee80211 phy0: device now idle
[ 59.110351] omapdss DISPC error: GO bit not down for channel 2
[ 59.117523] omapdss DISPC error: GO bit not down for channel 2
[ 71.561553] omapdss DISPC error: GO bit not down for channel 2
[ 71.569488] omapdss DISPC error: GO bit not down for channel 2
[ 82.827972] ieee80211 phy0: device no longer idle - scanning
[ 84.239257] omapdss DISPC error: GO bit not down for channel 2
[ 84.247955] omapdss DISPC error: GO bit not down for channel 2
[ 84.520050] ieee80211 phy0: device now idle
[ 95.628540] omapdss DISPC error: GO bit not down for channel 2
[ 95.637298] omapdss DISPC error: GO bit not down for channel 2
[ 107.396514] omapdss DISPC error: GO bit not down for channel 2
[ 107.404...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers