Snowball USB not working in V5 and V11 boards

Bug #804091 reported by Mathieu Poirier
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
IglooCommunity
Fix Released
High
Abhishek Paliwal
Linaro Android
Fix Released
Undecided
Unassigned
Linaro Ubuntu
Fix Released
High
Unassigned

Bug Description

After performing the tests found here:
- https://wiki.linaro.org/Platform/QA/TestCases/Nano

The following issues can be reported:

USB is not responsive and the 5V power is not routed to the USB device.

Lee Jones (lag)
summary: - Release image (20110629) on Nano not working to the fullest
+ USB not working on release image (20110629)
description: updated
summary: - USB not working on release image (20110629)
+ Snowball USB not working on release image (20110629)
description: updated
Changed in linaro-landing-team-ste:
assignee: nobody → Lee Jones (lag)
importance: Undecided → High
Lee Jones (lag)
Changed in linaro-landing-team-ste:
status: New → In Progress
Lee Jones (lag)
visibility: private → public
Lee Jones (lag)
summary: - Snowball USB not working on release image (20110629)
+ Snowball USB not working
Revision history for this message
Frans Gifford (fgiff) wrote : Re: Snowball USB not working

Apparently this is a hardware problem on V2 and V3 boards and is fixed on V5.

Changed in linaro-ubuntu:
status: New → Fix Committed
Changed in linaro-landing-team-ste:
status: In Progress → Fix Committed
Fathi Boudra (fboudra)
Changed in linaro-ubuntu:
milestone: none → 11.09
importance: Undecided → High
Revision history for this message
Anmar Oueja (anmar) wrote :

Frans Fathi: We don't have any V5 boards so we can't verify that. targeting this for 11.09 is too optimistic. I suggest 11.11 since the availability of the V5 board is unknown at the moment.

Revision history for this message
Frans Gifford (fgiff) wrote :

Hi Anmar,

There should be a few V5s available to STE assignees soon. Thomas Espersson had 3 he was planning to distribute.

Revision history for this message
Frans Gifford (fgiff) wrote :

Today's daily android build (https://android-build.linaro.org/builds/~linaro-android/leb-snowball/#build=81) features either mouse/keyboard working using mini-USB-A or ADB working over USB *on V2* using mini-USB-B.

The failure to route power remains a hardware issue on V2 and V3. I don't yet have a V5 to confirm that this is fixed.

Changed in linaro-ubuntu:
milestone: 11.09 → 11.10
Revision history for this message
Anmar Oueja (anmar) wrote :

Mathieu tested on Snowball V5 with the same results. We believe this is to be a software issue.

Changed in linaro-landing-team-ste:
status: Fix Committed → Confirmed
Revision history for this message
Anmar Oueja (anmar) wrote :

To be tested using the latest GLK from ST-Ericsson by Lee Jones

Revision history for this message
Lee Jones (lag) wrote :

Still seems to be the case:

[ 558.661682] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 561.645690] usb 1-1: device descriptor read/64, error -71
[ 561.875488] usb 1-1: device descriptor read/64, error -71
[ 562.225463] usb 1-1: device descriptor read/64, error -71
[ 562.455780] usb 1-1: device descriptor read/64, error -71
[ 563.105651] usb 1-1: device not accepting address 69, error -71
[ 563.645629] usb 1-1: device not accepting address 70, error -71

Can someone from inside ST-Ericsson please pass to the USB guys?

Changed in linaro-landing-team-ste:
assignee: Lee Jones (lag) → Thomas Espersson (espersson)
Changed in linaro-ubuntu:
status: Fix Committed → Confirmed
Revision history for this message
Thomas Espersson (espersson) wrote :

This issue is investigated by USB team inside STE already, Robert Marklund is providuig them with logs has the latest status.

Revision history for this message
Riku Voipio (riku-voipio) wrote :
Download full text (3.3 KiB)

USB keyboard/mouse combo appears to work fine on my snowball (V2).

Linux linaro-ubuntu-desktop 3.0.0-1000-ux500 #0-Ubuntu SMP PREEMPT Wed Sep 28 07:49:32 UTC 2011 armv7l armv7l armv7l GNU/Linux

Bus 001 Device 002: ID 0e8f:0020 GreenAsia Inc. USB to PS/2 Adapter
Device Descriptor:
  bLength 18
  bDescriptorType 1
  bcdUSB 1.10
  bDeviceClass 0 (Defined at Interface level)
  bDeviceSubClass 0
  bDeviceProtocol 0
  bMaxPacketSize0 8
  idVendor 0x0e8f GreenAsia Inc.
  idProduct 0x0020 USB to PS/2 Adapter
  bcdDevice 2.80
  iManufacturer 1 GASIA
  iProduct 2 PS2toUSB Adapter
  iSerial 0
  bNumConfigurations 1
  Configuration Descriptor:
    bLength 9
    bDescriptorType 2
    wTotalLength 59
    bNumInterfaces 2
    bConfigurationValue 1
    iConfiguration 0
    bmAttributes 0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower 400mA
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 0
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 3 Human Interface Device
      bInterfaceSubClass 1 Boot Interface Subclass
      bInterfaceProtocol 1 Keyboard
      iInterface 0
        HID Device Descriptor:
          bLength 9
          bDescriptorType 33
          bcdHID 1.10
          bCountryCode 0 Not supported
          bNumDescriptors 1
          bDescriptorType 34 Report
          wDescriptorLength 62
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x81 EP 1 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type Data
        wMaxPacketSize 0x0008 1x 8 bytes
        bInterval 8
    Interface Descriptor:
      bLength 9
      bDescriptorType 4
      bInterfaceNumber 1
      bAlternateSetting 0
      bNumEndpoints 1
      bInterfaceClass 3 Human Interface Device
      bInterfaceSubClass 1 Boot Interface Subclass
      bInterfaceProtocol 2 Mouse
      iInterface 0
        HID Device Descriptor:
          bLength 9
          bDescriptorType 33
          bcdHID 1.10
          bCountryCode 0 Not supported
          bNumDescriptors 1
          bDescriptorType 34 Report
          wDescriptorLength 130
         Report Descriptors:
           ** UNAVAILABLE **
      Endpoint Descriptor:
        bLength 7
        bDescriptorType 5
        bEndpointAddress 0x82 EP 2 IN
        bmAttributes 3
          Transfer Type Interrupt
          Synch Type None
          Usage Type ...

Read more...

tags: added: linaro-android snowball-landing snowball-staging usb-camera
tags: added: usb-camera-record
Fathi Boudra (fboudra)
Changed in linaro-ubuntu:
milestone: 11.10 → 11.11
Revision history for this message
Abhishek Paliwal (abhishek-paliwal) wrote :
Revision history for this message
Anmar Oueja (anmar) wrote :

This is a hardware issue. Will not target a monthly release until more is known.

Fathi Boudra (fboudra)
Changed in linaro-ubuntu:
milestone: 11.11 → none
Revision history for this message
Abhishek Paliwal (abhishek-paliwal) wrote :
Anmar Oueja (anmar)
summary: - Snowball USB not working
+ Snowball USB not working in V3, V5 and V11 boards
Changed in linaro-landing-team-ste:
status: Confirmed → Won't Fix
Frans Gifford (fgiff)
Changed in linaro-android:
status: New → Confirmed
Revision history for this message
Riku Voipio (riku-voipio) wrote : Re: Snowball USB not working in V3, V5 and V11 boards

Anmar, if you are no longer using linaro-landing-team-ste, please assign this to the right project.

For me, usb used work n previous releases (V2 and V11 hw), but on 11.12 RC usb no longer functions:

[ 275.972015] usb 1-1: device descriptor read/64, error -110
[ 291.202056] usb 1-1: device descriptor read/64, error -110
[ 291.432037] usb 1-1: new full speed USB device number 7 using musb-hdrc
[ 306.551940] usb 1-1: device descriptor read/64, error -110
[ 321.782043] usb 1-1: device descriptor read/64, error -110
[ 322.012023] usb 1-1: new full speed USB device number 8 using musb-hdrc
[ 332.431884] usb 1-1: device not accepting address 8, error -110
[ 332.552032] usb 1-1: new full speed USB device number 9 using musb-hdrc
[ 342.972259] usb 1-1: device not accepting address 9, error -110
[ 342.978302] hub 1-0:1.0: unable to enumerate USB device on port 1
[ 360.882049] usb 1-1: device descriptor read/64, error -110
[ 376.112121] usb 1-1: device descriptor read/64, error -110
[ 391.462036] usb 1-1: device descriptor read/64, error -110
[ 406.691894] usb 1-1: device descriptor read/64, error -110

Ad nauseam.

Kernel is:

ii linux-image-3.0.0-4-ux500 3.0.0-4.0 Linux kernel image for version 3.0.0 on STE UX500-based systems
Linux linaro-ubuntu-desktop 3.0.0-4-ux500 #0-Ubuntu SMP PREEMPT Mon Dec 12 23:18:33 UTC 2011 armv7l armv7l armv7l GNU/Linux

Revision history for this message
Anmar Oueja (anmar) wrote :

This bug is a hardware issue that plagues the V5 and V11. It is marked as won't fix because the Landing Team/Igloocommunity-maintainers are unable to fix it.

ST-Ericsson is aware of this issue and is working tirelessly to fix it.

Revision history for this message
Anmar Oueja (anmar) wrote :

removed V3 from the title since it is no longer supported board.

Changed in igloocommunity:
assignee: nobody → Abhishek Paliwal (abhishek-paliwal)
summary: - Snowball USB not working in V3, V5 and V11 boards
+ Snowball USB not working in V5 and V11 boards
Changed in igloocommunity:
importance: Undecided → High
status: New → Confirmed
Lee Jones (lag)
Changed in igloocommunity:
status: Confirmed → Fix Released
Changed in linaro-ubuntu:
status: Confirmed → Fix Released
Changed in linaro-landing-team-ste:
status: Won't Fix → Fix Released
Revision history for this message
Tony Hook (tonyhook-su) wrote :

How this bug is fixed? I still cannot use any USB device on the OTG port. (Snowball V11)
Thanks.

Revision history for this message
Matt Sealey (mwsealey) wrote :

This bug is absolutely infuriating :] Have a Snowball V11 here, some bluetooth panic on boot and then OTG port doesn't work. I can list USB devices but it's all read descriptor errors, or "can't enable port 1, maybe the cable is bad?" warnings (tried it with 5 cables so far, all brand new, different sources, and they work fine on Panda and Beagle just as a test)

Revision history for this message
Abhishek Paliwal (abhishek-paliwal) wrote :
Revision history for this message
Alexis De la Vega (craksz) wrote :

this patch is included on kernel 3.3 and 3.4 as far as i know... but USB is still not working with high speed devices... at least with 3G modem or HHD... or even a highspeed compatible hub...

Changed in linaro-android:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers