speaker-test fails on OMAP3 based boards

Bug #760919 reported by Tom Gall
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Medium
John Rigby

Bug Description

ALIP 0414 daily snapshot, 0414 hwpack for panda.

root@linaro:~# speaker-test

speaker-test 1.0.24.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_card_driver returned y
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_concat returned errory
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned error:y
ALSA lib conf.c:4663:(snd_config_expand) Evaluate error: No such file or directory
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,No such file or directory

Tom Gall (tom-gall)
Changed in linaro:
assignee: nobody → Kurt Taylor (kurt-r-taylor)
Revision history for this message
Tom Gall (tom-gall) wrote :

Fails on Beagle C4 as well tho in that case it's a matter of no output.

Revision history for this message
Tom Gall (tom-gall) wrote :

Interesting data point ... the tool seems to be freezing

root@linaro:~# speaker-test

speaker-test 1.0.24.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 640 to 32768
Period size range from 8 to 16384
Using max buffer size 32768
Periods = 4
[ 310.108367] omap_i2c omap_i2c.1: controller timed out waiting for start condition to finh
[ 310.117218] twl: i2c_write failed to transfer all messages
[ 311.131805] omap_i2c omap_i2c.1: controller timed out waiting for start condition to finh
[ 311.140655] twl: i2c_write failed to transfer all messages
[ 312.149902] omap_i2c omap_i2c.1: controller timed out
[ 312.157684] twl: i2c_read failed to transfer all messages
[ 313.170898] omap_i2c omap_i2c.1: controller timed out waiting for start condition to finh
[ 313.180175] twl: i2c_write failed to transfer all messages
[ 314.188629] omap_i2c omap_i2c.1: controller timed out
[ 314.194488] twl: i2c_read failed to transfer all messages
[ 315.202148] omap_i2c omap_i2c.1: controller timed out waiting for start condition to finh
[ 315.211364] twl: i2c_write failed to transfer all messages
[ 316.233398] omap_i2c omap_i2c.1: controller timed out waiting for start condition to finh
[ 316.242645] twl: i2c_write failed to transfer all messages
was set period_size = 8192
was set buffer_size = 32768
 0 - Front Left

Revision history for this message
Tom Gall (tom-gall) wrote :

Beagle Xm fails much like the panda.

root@linaro:~# speaker-test

speaker-test 1.0.24.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from [ 444.200927] asoc: interface omap-mcbsp-dai.1 hw params failed
16 to 32768
Period size range from 8 to 16384
Using max buffer size 32768
Periods = 4
Unable to set hw params for playback: No such device
Setting of hwparams failed: No such device

Revision history for this message
Tom Gall (tom-gall) wrote : Re: speaker-test fails on panda, Xm, Beagle C

Fails currently on Xm and Beagle C4 with the omap3-x11 hwpack and alip from beta2.

summary: - speaker-test fails on panda
+ speaker-test fails on panda, Xm, Beagle C
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Sound only works at Beagle if you use alsamixer to unmute and increate the volume of the other available options.

After setting up with alsamixer I'm able to use speaker-test.

Revision history for this message
Marcin Juszkiewicz (hrw) wrote :

On PandaBoard speaker-test was working with HDMI Audio.

Revision history for this message
Ricardo Salveti (rsalveti) wrote : Re: speaker-test fails on Xm, Beagle C

Removed panda from bug name because of Marcin's feedback.

summary: - speaker-test fails on panda, Xm, Beagle C
+ speaker-test fails on Xm, Beagle C
affects: linaro → linaro-ubuntu
Revision history for this message
Tom Gall (tom-gall) wrote :

still present on beagle C using current daily 0706 daily snapshot + alip image

Revision history for this message
James Tunnicliffe (dooferlad) wrote :

While I don't have an HDMI sound sink, using alsamixer I can't see the analogue output or hear anything on it. It is currently unsupported?

Revision history for this message
James Tunnicliffe (dooferlad) wrote :

Sorry, forgot to say I am using a Panda board.

Changed in linaro-ubuntu:
milestone: none → 11.07
status: New → Confirmed
importance: Undecided → Medium
Revision history for this message
Tom Gall (tom-gall) wrote :

on 11.07 alip RC on beagle Xm this continues to fail exactly as was reported some time ago.

root@linaro-alip:~# speaker-test

speaker-test 1.0.24.2

Playback device is default
Stream parameters are 48000Hz, S16_LE, 1 channels
Using 16 octaves of pink noise
ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_card_driver retury
ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_concat returned ey
ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
ALSA lib conf.c:4184:(_snd_config_evaluate) function snd_func_refer returned ery
ALSA lib conf.c:4663:(snd_config_expand) Evaluate error: No such file or directy
ALSA lib pcm.c:2212:(snd_pcm_open_noupdate) Unknown PCM default
Playback open error: -2,No such file or directory

Revision history for this message
Andy Doan (doanac) wrote :

alasmixer won't run for me. I ran it with strace and I think this is the problem:

 open("/dev/snd/controlC0", O_RDONLY|O_CLOEXEC) = -1 ENOENT (No such file or directory)

The only thing under /dev/snd for me is timer.

Revision history for this message
Andy Doan (doanac) wrote :

this is also broken on Overo.

Changed in linaro-ubuntu:
milestone: 11.07 → 11.08
Revision history for this message
Andy Doan (doanac) wrote :

still broke with with today's (2011-08-22) snapshot. This looks like a kernel issue to me, so I wonder if we have this bug assigned to the proper team? Seems like linaro-linux-omap3 is probably better.

Here's my kernel info:

  Linux linaro-nano 3.0.0-1003-linaro-omap #4~ppa~natty-Ubuntu SMP PREEMPT Mon Aug 8 21:53:39 UTC 2011 armv7l armv7l armv7l GNU/Linux

Revision history for this message
Andy Doan (doanac) wrote :

I've found the cause of this problem. During the change to the 3.0 kernels we changed how the sound drivers were build for OMAP. Previously they were built-ins, they are now built as modules:

 CONFIG_SND_OMAP_SOC
 CONFIG_SND_OMAP_SOC_OVERO
 etc

I thought I'd be clever and just load the module. However, that still didn't fix the issue. I then built my own kernel with OMAP sound selected as built-ins rather than modules and sound started working again.

So there's still some issue with OMAP sound not working as modules. However, for the time being I think we should just make these built-ins so that OMAP3 sound will work again. I've attached a diff of my original .config and my new .config that fixes the issue.

Changed in linaro-ubuntu:
assignee: Kurt Taylor (kurt-r-taylor) → John Rigby (jcrigby)
milestone: 11.08 → 11.09
Fathi Boudra (fboudra)
tags: added: omap3
summary: - speaker-test fails on Xm, Beagle C
+ speaker-test fails on OMAP3 based boards
Revision history for this message
Mans Rullgard (mansr) wrote :

I get no errors using kernel linux-linaro-3.0-2011.08-0 plus a few unrelated patches.
Relevant kernel config options:

CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_JACK=y
CONFIG_SND_VERBOSE_PROCFS=y
CONFIG_SND_VERBOSE_PRINTK=y
CONFIG_SND_SOC=m
CONFIG_SND_OMAP_SOC=m
CONFIG_SND_OMAP_SOC_MCBSP=m
CONFIG_SND_OMAP_SOC_OMAP3_BEAGLE=m
CONFIG_SND_SOC_I2C_AND_SPI=m
CONFIG_SND_SOC_TWL4030=m

I had to manually modprobe snd-soc-omap, snd-soc-omap3beagle, and snd-soc-omap-mcbsp.
With these modules loaded, everything works normally.

Something probably needs to change so these modules get loaded automatically.
Is that what this bug is really about?

Revision history for this message
Tom Gall (tom-gall) wrote :

We want sound to work out of the box. No fiddling.

So whatever we need to change to at least get speaker-test doing what it should is a good first step.

Revision history for this message
Christian Reis (kiko) wrote :

Andy, did you perhaps miss a module when trying the manual modprobing?

Revision history for this message
Mans Rullgard (mansr) wrote :

Two of the modules seem to be simply missing a MODULE_ALIAS() for auto-loading to work. The third, snd-soc-omap3beagle, I'm not sure how to handle, investigating.

Revision history for this message
Andy Doan (doanac) wrote :

Kiko is right. I must have missed something. I just tried what Mans mentioned (changed beagle to overo equivalent) and everything worked again.

Revision history for this message
John Rigby (jcrigby) wrote :

Pending an upstream approved fix I am adding this patch to the packaged kernel:

http://lists.linaro.org/pipermail/linaro-dev/2011-September/007408.html

Fathi Boudra (fboudra)
tags: added: patch
Revision history for this message
Mans Rullgard (mansr) wrote :
Changed in linaro-ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers