The input characters can't be shown in serial console on Arndale Linaro ubuntu trusty image.

Bug #1314175 reported by Botao on 2014-04-29
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Medium
Unassigned

Bug Description

On Samsung Arndale board with both developer and server image:

http://snapshots.linaro.org/ubuntu/pre-built/arndale/636/arndale-trusty_developer_20140428-636.img.gz

http://snapshots.linaro.org/ubuntu/pre-built/arndale/636/arndale-trusty_server_20140428-636.img.gz

The characters typed in serial console can't be shown on screen. The behaviour is same as when user types password. However, the command typed there can be executed successfully.

This issue doesn't exist until build #636. My settings in minicom is 115200 8N1, without hardware & software flow control.

Same issue is observed on ARM Versatile Express ubuntu build #635 and TI Panda build #636:
http://snapshots.linaro.org/ubuntu/pre-built/vexpress/635/vexpress-trusty_developer_20140428-635.img.gz
http://snapshots.linaro.org/ubuntu/pre-built/panda/636/panda-trusty_developer_20140428-636.img.gz

Botao (botao-sun) on 2014-05-07
description: updated
Changed in linaro-ubuntu:
importance: Undecided → Medium
status: New → Confirmed
Botao (botao-sun) wrote :

This issue has gone on Linux Linaro ubuntu build 651.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers