Ethernet is unavailable on TI Panda 4430 and 4460 in v3.10-based linux-linaro kernel.

Bug #1185798 reported by Botao on 2013-05-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Medium
Andrey Konovalov

Bug Description

On TI Panda 4430 and 4460 board with Linux Linaro ubuntu image:

http://snapshots.linaro.org/raring/pre-built/panda/347/panda-raring_developer_20130529-347.img.gz

Ethernet is unavailable:

root@localhost:~# ifconfig -a
lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:65536 Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1280 (1.2 KB) TX bytes:1280 (1.2 KB)

sit0 Link encap:IPv6-in-IPv4
          NOARP MTU:1480 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@localhost:~#

The Ethernet automatically enablement has been added to file "/etc/network/interfaces":

auto eth0
iface eth0 inet dhcp

But it still shows output above.

###########################################
This issue is observed on following images:
http://snapshots.linaro.org/raring/pre-built/panda/347/panda-raring_developer_20130529-347.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/354/panda-raring_developer_20130604-354.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/363/panda-raring_developer_20130613-363.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/370/panda-raring_developer_20130618-370.img.gz

I bet this is duplicate of bug 1185793. On Pandas the onboard ethernet is USB device. No USB host - no onboard ethernet.

Changed in linaro-ubuntu:
assignee: nobody → Andrey Konovalov (andrey-konovalov)
summary: - Ethernet is unavailable on TI Panda 4430 and 4460 ubuntu.
+ Ethernet is unavailable on TI Panda 4430 and 4460 in v3.10-based linux-
+ linaro kernel.
Botao (botao-sun) on 2013-06-06
description: updated
Fathi Boudra (fboudra) on 2013-06-07
Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → 13.06
Botao (botao-sun) on 2013-06-13
description: updated
Botao (botao-sun) on 2013-06-19
description: updated
Botao (botao-sun) wrote :

On both TI Panda 4430 and 4460, with Linux Linaro ubuntu Raring image:

http://snapshots.linaro.org/ubuntu/pre-built/panda/376/panda-raring_developer_20130623-376.img.gz

Ethernet now works well.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers