Reboot failed on ARM Versatile Express A9 with Linux Linaro ubuntu Raring build.

Bug #1177788 reported by Botao on 2013-05-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Undecided
Unassigned

Bug Description

On ARM Versatile Express A9 board with Linux Linaro ubuntu Raring hardware pack 323:

http://snapshots.linaro.org/raring/hwpacks/vexpress/323/hwpack_linaro-vexpress_20130508-323_armhf_supported.tar.gz

And rootfs 360:

http://snapshots.linaro.org/raring/images/developer/360/linaro-raring-developer-20130508-360.tar.gz

"Reboot" test failed. The board can be powered off and powered on but then it shows:
#####################################################
The default boot selection will start in 8 seconds
[1] uImage (local FDT) on SD card
        - VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(1,MBR,0x00000000,0x3F,0x41FC0)/uImage
        - Initrd: VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(1,MBR,0x00000000,0x3F,0x41FC0)/uInitrd
        - Arguments: console=tty0 console=ttyAMA0,38400n8 root=/dev/mmcblk0p2 rootwait ro androidboot.console=ttyAMA0 mmci.fmax=12000000
        - FDT: VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(1,MBR,0x00000000,0x3F,0x41FC0)/v2p-ca9.dtb
        - LoaderType: Linux kernel with Local FDT
-----------------------
Global FDT Config
        - VenHw(09831032-6FA3-4484-AF4F-0A000A8D3A82)/HD(1,MBR,0x00000000,0x3F,0x19FC0)/v2p-ca9.dtb
-----------------------
[a] Boot Manager
[b] Shell
Start: 1
MciReadBlockData(): TIMEOUT! Response:0xA4040B8 Status:0x48
ERROR: Did not find Linux kernel.
ASSERT /mnt/ci_build/workspace/uefi/uefi/MdeModulePkg/Core/Dxe/Mem/Pool.c(424): CR has Bad Signature
#####################################################

After that, the board hung there.

Ryan Harkin (ryanharkin) wrote :

That's not a bug with reboot, but a bug with UEFI reading the kernel from the SD card.

Botao (botao-sun) wrote :

OK, then since this is a feature test and the failure happened during "Reboot" test, I will still keep the bug under the "reboot" name. We can add comment here for that UEFI issue resolving, which is the root cause of this bug.

Botao (botao-sun) wrote :

On ARM Versatile Express A9 board with Linux Linaro ubuntu image:

http://snapshots.linaro.org/raring/pre-built/vexpress/336/vexpress-raring_developer_20130520-336.img.gz

This issue has gone, "Reboot" now works well.

Changed in linaro-ubuntu:
status: New → Fix Released
Botao (botao-sun) wrote :

On ARM Versatile Express A9 board with Linux Linaro ubuntu image:

http://snapshots.linaro.org/ubuntu/pre-built/vexpress/344/vexpress-raring_developer_20130526-344.img.gz

"Reboot" test failed with a Kernel panic. Please refer to attachment to get full log output.

This bug will be changed to "New" again.

Changed in linaro-ubuntu:
status: Fix Released → New
Botao (botao-sun) wrote :

On ARM Versatile Express A9 board with Linux Linaro ubuntu image:

http://snapshots.linaro.org/raring/pre-built/vexpress/370/vexpress-raring_developer_20130618-370.img.gz

"Reboot" now works well. Please refer to attachment to get full boot log.

Changed in linaro-ubuntu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints