WiFi is unavailable on TI Panda 4460 with Linux Linaro ubuntu image.

Bug #1164329 reported by Botao on 2013-04-04
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Linux Baseline
Fix Released
Medium
Andrey Konovalov
Linaro Ubuntu
Medium
Andrey Konovalov

Bug Description

On TI Panda 4460 board with Linux Linaro ubuntu image:

http://snapshots.linaro.org/quantal/pre-built/panda/280/panda-quantal_developer_20130401-280.img.gz

WiFi is unavailable:

root@localhost:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr e2:df:e5:9d:fc:e5
          inet addr:10.0.0.26 Bcast:10.0.0.255 Mask:255.255.255.0
          inet6 addr: fe80::e0df:e5ff:fe9d:fce5/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:25 errors:0 dropped:0 overruns:0 frame:0
          TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2203 (2.2 KB) TX bytes:2176 (2.1 KB)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:65536 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

sit0 Link encap:IPv6-in-IPv4
          NOARP MTU:1480 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

root@localhost:~#

###########################################
This issue is observed on following images:
http://snapshots.linaro.org/quantal/pre-built/panda/280/panda-quantal_developer_20130401-280.img.gz
http://snapshots.linaro.org/quantal/pre-built/panda/286/panda-quantal_developer_20130408-286.img.gz
http://snapshots.linaro.org/quantal/pre-built/panda/290/panda-quantal_developer_20130414-290.img.gz
http://snapshots.linaro.org/quantal/pre-built/panda/299/panda-quantal_developer_20130423-299.img.gz
http://snapshots.linaro.org/raring/hwpacks/panda/323/hwpack_linaro-panda_20130508-323_armhf_supported.tar.gz and http://snapshots.linaro.org/raring/images/developer/360/linaro-raring-developer-20130508-360.tar.gz
http://snapshots.linaro.org/raring/pre-built/panda/336/panda-raring_developer_20130520-336.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/347/panda-raring_developer_20130529-347.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/370/panda-raring_developer_20130618-370.img.gz
http://snapshots.linaro.org/ubuntu/pre-built/panda/376/panda-raring_developer_20130623-376.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/408/panda-raring_developer_20130723-408.img.gz
http://snapshots.linaro.org/ubuntu/pre-built/panda/443/panda-raring_developer_20130826-443.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/465/panda-raring_developer_20130916-465.img.gz
http://snapshots.linaro.org/ubuntu/pre-built/panda/471/panda-raring_developer_20130922-471.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/500/panda-raring_developer_20131021-500.img.gz
http://snapshots.linaro.org/ubuntu/pre-built/panda/535/panda-raring_developer_20131124-535.img.gz
http://snapshots.linaro.org/raring/pre-built/panda/550/panda-raring_developer_20131209-550.img.gz
http://snapshots.linaro.org/ubuntu/pre-built/panda/611/panda-saucy_developer_20140222-611.img.gz

Botao (botao-sun) on 2013-04-11
description: updated
Botao (botao-sun) on 2013-04-17
description: updated
Botao (botao-sun) on 2013-04-24
description: updated
Botao (botao-sun) on 2013-05-09
description: updated
Botao (botao-sun) on 2013-05-23
description: updated
Botao (botao-sun) on 2013-05-30
description: updated
Botao (botao-sun) on 2013-06-19
description: updated
Botao (botao-sun) on 2013-06-25
description: updated
Botao (botao-sun) on 2013-07-25
description: updated
Botao (botao-sun) on 2013-08-28
description: updated
Botao (botao-sun) on 2013-09-19
description: updated
Botao (botao-sun) on 2013-09-26
description: updated
Fathi Boudra (fboudra) on 2013-10-04
Changed in linaro-linux-baseline:
status: New → Confirmed
Changed in linaro-ubuntu:
status: New → Confirmed
Changed in linaro-linux-baseline:
importance: Undecided → Medium
Changed in linaro-ubuntu:
importance: Undecided → Medium
Changed in linaro-linux-baseline:
milestone: none → 13.10
Changed in linaro-ubuntu:
milestone: none → 13.10
Changed in linaro-linux-baseline:
assignee: nobody → Andrey Konovalov (andrey-konovalov)
Changed in linaro-ubuntu:
assignee: nobody → Andrey Konovalov (andrey-konovalov)
Botao (botao-sun) on 2013-10-23
description: updated
Fathi Boudra (fboudra) on 2013-11-18
Changed in linaro-linux-baseline:
milestone: 13.10 → 13.11
Changed in linaro-ubuntu:
milestone: 13.10 → 13.11
Botao (botao-sun) on 2013-11-27
description: updated
Fathi Boudra (fboudra) on 2013-12-10
Changed in linaro-linux-baseline:
milestone: 13.11 → 13.12
Changed in linaro-ubuntu:
milestone: 13.11 → 13.12
Botao (botao-sun) on 2013-12-11
description: updated
Fathi Boudra (fboudra) on 2014-01-09
Changed in linaro-linux-baseline:
milestone: 13.12 → 14.01
Changed in linaro-ubuntu:
milestone: 13.12 → 14.01
Botao (botao-sun) wrote :

On TI Panda 4460 board with Linux Linaro ubuntu image:

http://snapshots.linaro.org/ubuntu/pre-built/panda/596/panda-saucy_developer_20140126-596.img.gz

WiFi can't be enabled by set parameters in /etc/network/interface

auto wlan0
iface wlan0 inet dhcp
wpa-ssid SSID
wpa-psk PASSWORD

This feature worked well on build 592 at least.

http://snapshots.linaro.org/ubuntu/pre-built/panda/592/panda-saucy_developer_20140120-592.img.gz

Also, this command runs failed:

root@linaro-developer:~# service networking restart
stop: Unknown instance:
start: Job failed to start
root@linaro-developer:~#

And it worked well on build 592 too.

Well, this could be an intermittent failure...

I've just tried the panda-saucy_developer_20140126-596.img.gz on my Panda 4460, and heven't seen these two issues:

1) Changing /etc/network/interfaces to:
-----8<-----
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
# auto eth0
# iface eth0 inet dhcp
auto wlan0
iface wlan0 inet dhcp
wpa-ssid SSID
wpa-psk THE-KEY
-----8<-----
has made wlan0 to come up after 'shutdown -r now':
-----8<-----
root@linaro-developer:~# ifconfig
lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:65536 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr de:ad:be:ef:00:00
          inet addr:192.168.11.164 Bcast:192.168.11.255 Mask:255.255.255.0
          inet6 addr: fe80::dcad:beff:feef:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:26 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3173 (3.1 KB) TX bytes:3202 (3.2 KB)
-----8<-----

2) 'service networking restart' worked too...

3) I has been hit by the following once:
-----8<-----
<no output from the console for quite a while>
[ 300.679901] INFO: rcu_sched self-detected stall on CPU { 1} (t=4389 jiffies
g=644 c=643 q=14)
[ 310.586700] wlcore: ERROR HW watchdog interrupt received! starting recovery.
-----8<-----
But it didn't cause any bad consequences.

So this is not "build 592 is good, and build 596 is bad" unfortunately. Ruther looks like instability.
I'll let the board to run build 596 for a while to see if anything bad happens.

Also builds 592 and 596 are very similar WRT the kernel. The former uses ll-20140120.0, the latter - ll-20140124.0, and *the only* differences between the kernel source trees are just CONFIG_NETFILTER_XT_MATCH_CONNTRACK=m added to distribution.conf, and few changes to beaglebone.conf. The kernel configs from these two builds are slightly different, but it shouldn't matter in this case:
-----8<-----
 BRIDGE_EBT_T_FILTER n -> m
 NETFILTER_NETLINK_LOG n -> m
 NETFILTER_XT_MATCH_CONNMARK n -> m
 NETFILTER_XT_MATCH_CONNTRACK n -> m
 NETFILTER_XT_MATCH_MAC n -> m
 NF_CT_NETLINK n -> m
+NETFILTER_NETLINK m
+NETFILTER_XT_MATCH_OSF n
+NF_TABLES n
-----8<-----

Fathi Boudra (fboudra) on 2014-02-22
Changed in linaro-ubuntu:
milestone: 14.01 → 14.03
Fathi Boudra (fboudra) on 2014-02-22
Changed in linaro-linux-baseline:
milestone: 14.01 → 14.03
Botao (botao-sun) wrote :
Download full text (3.2 KiB)

Just tried on TI Panda 4460 with Linux Linaro ubuntu build #611:

http://snapshots.linaro.org/ubuntu/pre-built/panda/611/panda-saucy_developer_20140222-611.img.gz

WiFi still doesn't work after manually set the configuration file /etc/network/interfaces to:

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
# auto eth0
# iface eth0 inet dhcp
auto wlan0
iface wlan0 inet dhcp
wpa-ssid SSID
wpa-psk MYPASSWORD

root@linaro-developer:~# ifconfig -a
eth0 Link encap:Ethernet HWaddr 4e:65:26:dd:f2:45
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:65536 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

sit0 Link encap:IPv6-in-IPv4
          NOARP MTU:1480 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wlan0 Link encap:Ethernet HWaddr de:ad:be:ef:00:00
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
                           ...

Read more...

description: updated
Botao (botao-sun) wrote :

On TI Panda 4460 with Linux Linaro ubuntu image:

http://snapshots.linaro.org/ubuntu/pre-built/panda/616/panda-saucy_developer_20140323-616.img.gz

WiFi now works well after manually set the SSID and password in file "/etc/network/interfaces". And it also works well with Ethernet at the same time.

Test log has been attached.

But there may still be a minor issue as described in comment #5 of Bug 1274057

Fathi Boudra (fboudra) on 2014-04-07
Changed in linaro-linux-baseline:
milestone: 14.03 → 14.04
Changed in linaro-ubuntu:
milestone: 14.03 → 14.04
Botao (botao-sun) wrote :

On TI Panda 4460 with Linux Linaro ubuntu image:

http://snapshots.linaro.org/ubuntu/pre-built/panda/627/panda-saucy_developer_20140414-627.img.gz

WiFi works well.

The issue described in comment #5 of Bug 1274057 is not observed this time.

This bug now can be considered as "Fix Released".

Botao (botao-sun) wrote :

On TI Panda 4460 with Linux Linaro ubuntu image:

http://snapshots.linaro.org/ubuntu/pre-built/panda/630/panda-saucy_developer_20140417-630.img.gz

Now the Ethernet can't work with WiFi together again, and both are unstable:

root@linaro-developer:~# ping www.google.com -I 192.168.1.12 -c 5
PING www.google.com (74.125.237.114) from 192.168.1.12 : 56(84) bytes of data.
64 bytes from www.google.com (74.125.237.114): icmp_seq=1 ttl=57 time=157 ms
64 bytes from www.google.com (74.125.237.114): icmp_seq=2 ttl=57 time=158 ms
64 bytes from www.google.com (74.125.237.114): icmp_seq=3 ttl=57 time=150 ms
^C
--- www.google.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2003ms
rtt min/avg/max/mdev = 150.910/155.589/158.051/3.310 ms
root@linaro-developer:~# ping www.google.com -I 192.168.1.27 -c 5
PING www.google.com (74.125.237.114) from 192.168.1.27 : 56(84) bytes of data.

--- www.google.com ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4121ms

root@linaro-developer:~#

Let's just keep this bug alive for a while.

Botao (botao-sun) wrote :

On TI Panda 4460 with Linux Linaro ubuntu image:

http://snapshots.linaro.org/ubuntu/pre-built/panda/654/panda-trusty_developer_20140525-654.img.gz

Now WiFi interface can't obtain IP address again, after manually set SSID and password in /etc/network/interfaces:

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d
auto wlan0
iface wlan0 inet dhcp
wpa-ssid MY_SSID
wpa-psk MY_PASSWORD

Botao (botao-sun) wrote :

WiFi now backs to work on TI Panda 4460 with Linux Linaro ubuntu image:

http://snapshots.linaro.org/ubuntu/pre-built/panda/664/panda-trusty_developer_20140617-664.img.gz

Changed in linaro-linux-baseline:
status: Confirmed → Fix Released
Changed in linaro-ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints