[REGRESSION] kernel package/perf ftbfs caused by missing python-dev

Bug #1158139 reported by Fathi Boudra
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Linux Baseline
Fix Released
Critical
Andrey Konovalov
Linaro Ubuntu
Critical
Wookey

Bug Description

the changes introduced in http://lkml.indiana.edu/hypermail/linux/kernel/1301.1/00382.html
are causing perf to ftbfs:

cd /build/buildd/linux-linaro-omap-3.9-3.9.0/debian/build/tools-perarch/tools/perf && \
  make HAVE_CPLUS_DEMANGLE=1 CROSS_COMPILE=
    CHK -fstack-protector-all
    CHK -Wstack-protector
    CHK -Wvolatile-register-var
    CHK bionic
    CHK libelf
    CHK libdw
    CHK -DLIBELF_MMAP
    CHK libaudit
make[1]: Entering directory `/build/buildd/linux-linaro-omap-3.9-3.9.0/debian/build/tools-perarch/tools/perf'
Makefile:657: No libaudit.h found, disables 'trace' tool, please install audit-libs-devel or libaudit-dev
    CHK libnewt
    CHK gtk2
Makefile:693: GTK2 not found, disables GTK2 support. Please install gtk2-devel or libgtk2.0-dev
    CHK perl
Makefile:750: The path '/usr/bin/python-config' is not executable.
Makefile:750: *** Please set 'PYTHON_CONFIG' appropriately. Stop.

looks like they've introduced a build-dep on python-dev but not listed it.
the get-executable-or-default macro in config/utilities.mak has changed subtly so now it gives an error if python-config is not found instead of a warning as it should.

Fathi Boudra (fboudra)
Changed in linaro-ubuntu:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Wookey (wookey)
milestone: none → 13.03
Changed in linaro-linux-baseline:
importance: Undecided → Critical
assignee: nobody → Andrey Konovalov (andrey-konovalov)
milestone: none → 13.03
Revision history for this message
Fathi Boudra (fboudra) wrote :

patch to put the behaviour back to the same as 3.8 but is still make 3.80 compatible.

Changed in linaro-linux-baseline:
status: New → In Progress
Revision history for this message
Andrey Konovalov (andrey-konovalov) wrote :

linux-3.9-perf-config-test-fix.patch has been added to linux-linaro tree, ll-20130321.0 tag, via ynk/ll-v3.9-misc-fixes topic.

Changed in linaro-linux-baseline:
status: In Progress → Fix Committed
Fathi Boudra (fboudra)
Changed in linaro-linux-baseline:
status: Fix Committed → Fix Released
Changed in linaro-ubuntu:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers