1080p h.264 video can't be played on ubuntu Panda 4430.

Bug #1028876 reported by Botao on 2012-07-25
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Ricardo Salveti
linaro-landing-team-ti
Fix Released
Undecided
Unassigned

Bug Description

On Panda 4430 board, for test:

https://wiki.linaro.org/Platform/QA/TestCases/Ubuntu#HwMM_-_Hardware_accelerated_video_decoding_support

The package "ubuntu-omap4-extras-multimedia" can be installed successfully, but after that the 1080p h.264 video totally can't be played. Before this package installed, the Totem can play the video, but looks like a slide show; now the monitor is whole black, nothing shows up.

Observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/197/hwpack_linaro-lt-panda-x11-base_20120723-197_armhf_supported.tar.gz

with ubuntu rootfs:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/305/linaro-precise-ubuntu-desktop-20120723-305.tar.gz

Botao (botao-sun) wrote :

On Panda 4460, after install package "ubuntu-omap4-extras-multimedia", reboot board, click the Totem movie player, the player can't be launched. Refer to attachment to get snapshot.

Ricardo Salveti (rsalveti) wrote :

Here the broken behavior is because the kernel is missing a few kernel patches still (omapdce, drm, etc), which should be integrated by Andy soon.

Targeting this bug for 12.08, hopefully to be fixed in the next few days.

Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → 12.08
Botao (botao-sun) wrote :

For Panda 4460 board with Unity 2D enabled and DVI-D display output, before install "ubuntu-omap4-extras-multimedia" package, the 1080p video can be played, but likes a slide show. However, after install "ubuntu-omap4-extras-multimedia" package, the video can't be played at all, black screen in movie player shows.

Totem movie player can be launched and exit successfully this time, and I think it because I run it under the DVI-D + Unity 2D mode.

In serial console, repeated error information continuously shows:

omapdss DISPC error: SYNC_LOST on channel tv, restarting the output with video overlays disabled

Observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/201/hwpack_linaro-lt-panda-x11-base_20120725-201_armhf_supported.tar.gz

with ubuntu rootfs image is:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/313/linaro-precise-ubuntu-desktop-20120725-313.tar.gz

Botao (botao-sun) wrote :

For Panda 4460 board, observed same behaviour as comment #3 on DVI-D display mode, with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

Botao (botao-sun) wrote :

For Panda 4430 board, observed same behaviour as comment #3 on HDMI display mode, except this error information in serial console:

omapdss DISPC error: SYNC_LOST on channel tv, restarting the output with video overlays disabled

It doesn't appear on HDMI display mode, however, 1080p video still can't be played. The pre-built image is as same as I used for Panda 4460 board:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

Amit Khare (amit-khare) wrote :

observed with panda4430 build
http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/242/lt-panda-x11-base-precise_ubuntu-desktop_20120812-242.img.gz

The 1080p video can be played after installing "ubuntu-omap4-extras-multimedia" package and on small screen it runs fine but on full-screen it breaks.

Amit Khare (amit-khare) wrote :

same observation on panda 4460 with same build as comment #7

Ricardo Salveti (rsalveti) wrote :

Tested with the latest hwpack (using latest updates from TI's tree), and I'm able to play 1080p using full screen (not with a perfect performance still, but way better already).

Changed in linaro-ubuntu:
status: Confirmed → Fix Committed
Changed in linaro-landing-team-ti:
status: New → Fix Released
Botao (botao-sun) wrote :

Without package "ubuntu-omap4-extras-multimedia", the 1080p video now can be played well under HDMI+Unity 2D mode on Panda 4460 board, full screen.

observed on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/256/lt-panda-x11-base-precise_ubuntu-desktop_20120819-256.img.gz

Amit Khare (amit-khare) wrote :

observed on Panda 4430 board with image
http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/279/lt-panda-x11-base-precise_ubuntu-desktop_20120830-279.img.gz

after installing ""ubuntu-omap4-extras-multimedia"" video runs fine in small screen but with full screen its still distorted.

@Ricardo should we consider it fixed as you have already tested ??

Ricardo Salveti (rsalveti) wrote :

I believe this issue happens once you install the extras-multimedia package and don't reboot your board. Please re-open in case it's still happening with latest daily images.

Changed in linaro-ubuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers