unrecognizable insn in arm-linux-gnueabihf-gcc

Bug #1189445 reported by Christopher Covington
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Toolchain Binaries
Fix Released
Undecided
Zhenqiang Chen

Bug Description

We encounter the following error in 436.cactusADM from SPEC2006 with the 2013.05 32-bit toolchain when NEON is used. The error message is similar to that of bug #1163942.

gcc-4.8.1-linaro13.05/bin/arm-linux-gnueabihf-gcc -c -o lin48BLD2013-05_neon/PUGHSlab/Mapping.o -DSPEC_CPU -DNDEBUG -Iinclude -I../include -DCCODE -mfpu=neon -O3 PUGHSlab/Mapping.c
PUGHSlab/Mapping.c: In function ‘Hyperslab_DefineGlobalMappingByIndex’:
PUGHSlab/Mapping.c:499:1: error: unrecognizable insn:
 }
 ^
(insn 933 932 934 113 (set (reg:V4SI 1027)
        (unspec:V4SI [
                (const_vector:V4SI [
                        (const_int 0 [0])
                        (const_int 0 [0])
                        (const_int 0 [0])
                        (const_int 0 [0])
                    ])
                (reg:V4SI 1023 [ vect_var_.49 ])
                (const_int 1 [0x1])
            ] UNSPEC_VCGE)) PUGHSlab/Mapping.c:567 -1
     (nil))
PUGHSlab/Mapping.c:499:1: internal compiler error: in extract_insn, at recog.c:2150

Revision history for this message
Zhenqiang Chen (zhenqiang-chen) wrote :

Thank you for the bug report. I had confirmed it with 2013.05.

The root cause is similar to that of bug #1163942. I will create a patch to fix it.

Changed in linaro-toolchain-binaries:
status: New → In Progress
assignee: nobody → Zhenqiang Chen (zhenqiang-chen)
Changed in linaro-toolchain-binaries:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers