pmu_cci_test_scn11 failed when it is running in full execution

Bug #1274474 reported by Naresh Kamboju on 2014-01-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Stable Kernel (LSK)
Incomplete
Medium
Unassigned

Bug Description

pmu_cci_test_scn11 failed when it is running in full execution. passed independently.

Test failed in full run:
------------------------------
Hotplugging off CPU=4 for test.
../../common/perf stat -o 1000.dat -x, -a -C 0 -e CCI/config=0xFF,name=cci_cycles/,CCI/config=0x63,name=cci_a15_cacheable_read/,CCI/config=0x6c,name=cci_a15_any_write/,CCI/config=0x6f,name=cci_a15_shareable_write/,CCI/config=0x72,name=cci_a15_evict_write/,CCI/config=0x80,name=cci_a7_read/,CCI/config=0x8c,name=cci_a7_write/ ../../common/taskset 0x18 ../../common/cache -w -l 1000
../../common/perf stat -o 5000.dat -x, -a -C 0 -e CCI/config=0xFF,name=cci_cycles/,CCI/config=0x63,name=cci_a15_cacheable_read/,CCI/config=0x6c,name=cci_a15_any_write/,CCI/config=0x6f,name=cci_a15_shareable_write/,CCI/config=0x72,name=cci_a15_evict_write/,CCI/config=0x80,name=cci_a7_read/,CCI/config=0x8c,name=cci_a7_write/ ../../common/taskset 0x18 ../../common/cache -w -l 5000
../../common/perf stat -o 10000.dat -x, -a -C 0 -e CCI/config=0xFF,name=cci_cycles/,CCI/config=0x63,name=cci_a15_cacheable_read/,CCI/config=0x6c,name=cci_a15_any_write/,CCI/config=0x6f,name=cci_a15_shareable_write/,CCI/config=0x72,name=cci_a15_evict_write/,CCI/config=0x80,name=cci_a7_read/,CCI/config=0x8c,name=cci_a7_write/ ../../common/taskset 0x18 ../../common/cache -w -l 10000
Hotplugging back CPU=4.
FAIL: RATIO=1.407 should be 1+/-0.15 for EVENT=cci_a15_shareable_write at SCALE=5000
MP_CCI_TEST_SCN11 Failed

Test passed independently
--------------------------------------
Hotplugging off CPU=4 for test.
../../common/perf stat -o 1000.dat -x, -a -C 0 -e CCI/config=0xFF,name=cci_cycles/,CCI/config=0x63,name=cci_a15_cacheable_read/,CCI/config=0x6c,name=cci_a15_any_write/,CCI/config=0x6f,name=cci_a15_shareable_write/,CCI/config=0x72,name=cci_a15_evict_write/,CCI/config=0x80,name=cci_a7_read/,CCI/config=0x8c,name=cci_a7_write/ ../../common/taskset 0x18 ../../common/cache -w -l 1000
../../common/perf stat -o 5000.dat -x, -a -C 0 -e CCI/config=0xFF,name=cci_cycles/,CCI/config=0x63,name=cci_a15_cacheable_read/,CCI/config=0x6c,name=cci_a15_any_write/,CCI/config=0x6f,name=cci_a15_shareable_write/,CCI/config=0x72,name=cci_a15_evict_write/,CCI/config=0x80,name=cci_a7_read/,CCI/config=0x8c,name=cci_a7_write/ ../../common/taskset 0x18 ../../common/cache -w -l 5000
../../common/perf stat -o 10000.dat -x, -a -C 0 -e CCI/config=0xFF,name=cci_cycles/,CCI/config=0x63,name=cci_a15_cacheable_read/,CCI/config=0x6c,name=cci_a15_any_write/,CCI/config=0x6f,name=cci_a15_shareable_write/,CCI/config=0x72,name=cci_a15_evict_write/,CCI/config=0x80,name=cci_a7_read/,CCI/config=0x8c,name=cci_a7_write/ ../../common/taskset 0x18 ../../common/cache -w -l 10000
Hotplugging back CPU=4.
MP_CCI_TEST_SCN11 Passed

Linux kernel version:
-----------------------------
Linux version 3.10.28-00393-g0f3550b (jenkins-build@ip-10-13-133-105) (gcc version 4.8.3 20140106 (prerelease) (Linaro GCC 4.8-2014.01) ) #1 SMP Mon Jan 27 20:06:02 UTC 2014-

LSK Android build:
--------------------------
https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk-14.01-release/#build=4

Tags: lsk Edit Tag help
Naresh Kamboju (naresh-kamboju) wrote :
Fathi Boudra (fboudra) wrote :

Naresh, is it still reproducible?

Naresh Kamboju (naresh-kamboju) wrote :

This test cases failed in full execution and passed when running test independently.
This is reproducible issue.

description: updated
Alex Shi (alex-shi) wrote :

Naresh,

If case fail/pass in different testing mode, Do we need to confirm if one of testing mode is not appropriate before file a bug?

Alex Shi (alex-shi) on 2014-06-13
Changed in linaro-stable-kernel:
status: New → Incomplete
Naresh Kamboju (naresh-kamboju) wrote :

This test was executed on same build which is having same kernel and rootfs.
The problem with this test was it failed on full test suite execution and to debug this i have re-run the test independently where reported as pass.

If this bug re-occurs i will file a new bug. we can close this bug now.

Alex Shi (alex-shi) wrote :

I am OK to close this bug.

But for this situation, we need to know what happened in full suite execution and kick out the unstable issue. :)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers