Test script should skip cpuidle tests in case the kernel doesn't support it

Bug #1017014 reported by Ricardo Salveti
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro PMWG QA
Fix Released
Medium
Rajagopal Venkat

Bug Description

Currently the full cpuidle test set will be executed, even if cpuidle is not available at the kernel, making the test cases to fail.

The first test case already checks for cpuidle availability at sysfs, so others shouldn't be executed if the first one fails. The right test result would be 'skipped' instead of 'fail' as you can't consider that the test case has failed if the support wasn't even available.

One example:
LAVA: (stdout) make[1]: Entering directory `/root/.local/share/lava_test/installed-tests/pwrmgmt/pm-qa/cpuidle'
LAVA: (stdout) cc -g -Wall -pthread cpuidle_killer.c -o cpuidle_killer
LAVA: (stdout) ###
LAVA: (stdout) ### cpuidle_01:
LAVA: (stdout) ### test the cpuidle files are present in the sysfs
LAVA: (stdout) ### https://wiki.linaro.org/WorkingGroups/PowerManagement/Doc/QA/Scripts#cpuidle_01
LAVA: (stdout) ###
LAVA: (stdout) cpuidle_01.0: checking 'current_driver' exists... fail
LAVA: (stdout) ###
LAVA: (stdout) ### cpuidle_02:
LAVA: (stdout) ### Run a cpuidle program killer
LAVA: (stdout) ### https://wiki.linaro.org/WorkingGroups/PowerManagement/Doc/QA/Scripts#cpuidle_02
LAVA: (stdout) ###
LAVA: (stdout) cpuidle_02.0: checking cpuidle program runs successfully (120 secs)... Test duration exceeded
LAVA: (stdout) fail
LAVA: (stderr) make[1]: *** [cpuidle_02.log] Error 1
LAVA: (stdout) make[1]: Leaving directory `/root/.local/share/lava_test/installed-tests/pwrmgmt/pm-qa/cpuidle'
LAVA: (stderr) make: *** [check] Error 2
LAVA: Command 'cd pm-qa && make check ' returned non-zero exit status 2

Amit Kucheria (amitk)
Changed in linaro-power-qa:
assignee: nobody → Rajagopal Venkat (rajagopalvenkat)
importance: Undecided → Medium
Changed in linaro-power-qa:
status: New → In Progress
Changed in linaro-power-qa:
status: In Progress → Fix Released
Revision history for this message
Botao (botao-sun) wrote :

For Panda 4460 board, I get another failure:

LAVA: (stdout) cpuhotplug_07.0/cpu1: checking offline event was received... fail

Is it an expected behavior?

observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/lt-panda-x11-base/201/hwpack_linaro-lt-panda-x11-base_20120725-201_armhf_supported.tar.gz

with ubuntu rootfs image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/313/linaro-precise-ubuntu-desktop-20120725-313.tar.gz

Revision history for this message
Botao (botao-sun) wrote :

On Panda 4460 board, 2 failure observed on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

LAVA: (stdout) cpufreq_05.4: checking 'ondemand' directory exists... fail

LAVA: (stdout) cpuhotplug_07.0/cpu1: checking offline event was received... fail

Is it an expected behaviour? If so, then we can consider this test passed.

Please refer to attachment to get the log output.

tags: added: linaro-ubuntu powermanagement qa-services
Revision history for this message
Rajagopal Venkat (rajagopalvenkat) wrote : Re: [Bug 1017014] Re: Test script should skip cpuidle tests in case the kernel doesn't support it

Hongbo,

Would the patch you have submitted for review fix this issue?

On 8 August 2012 05:10, Botao Sun <email address hidden> wrote:

> On Panda 4460 board, 2 failure observed on Linaro ubuntu pre-built
> image:
>
> http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-
> panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz
>
> LAVA: (stdout) cpufreq_05.4: checking 'ondemand' directory exists...
> fail
>
> LAVA: (stdout) cpuhotplug_07.0/cpu1: checking offline event was
> received... fail
>
> Is it an expected behaviour? If so, then we can consider this test
> passed.
>
> Please refer to attachment to get the log output.
>
> ** Attachment added: "Panda_4460_Power_Management_2_Failures_Log.txt"
>
> https://bugs.launchpad.net/linaro-power-qa/+bug/1017014/+attachment/3251858/+files/Panda_4460_Power_Management_2_Failures_Log.txt
>
> ** Tags added: linaro-ubuntu powermanagement qa-services
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1017014
>
> Title:
> Test script should skip cpuidle tests in case the kernel doesn't
> support it
>
> Status in Linaro Power Management QA testsuite:
> Fix Released
>
> Bug description:
> Currently the full cpuidle test set will be executed, even if cpuidle
> is not available at the kernel, making the test cases to fail.
>
> The first test case already checks for cpuidle availability at sysfs,
> so others shouldn't be executed if the first one fails. The right test
> result would be 'skipped' instead of 'fail' as you can't consider that
> the test case has failed if the support wasn't even available.
>
> One example:
> LAVA: (stdout) make[1]: Entering directory
> `/root/.local/share/lava_test/installed-tests/pwrmgmt/pm-qa/cpuidle'
> LAVA: (stdout) cc -g -Wall -pthread cpuidle_killer.c -o
> cpuidle_killer
> LAVA: (stdout) ###
> LAVA: (stdout) ### cpuidle_01:
> LAVA: (stdout) ### test the cpuidle files are present in the sysfs
> LAVA: (stdout) ###
> https://wiki.linaro.org/WorkingGroups/PowerManagement/Doc/QA/Scripts#cpuidle_01
> LAVA: (stdout) ###
> LAVA: (stdout) cpuidle_01.0: checking 'current_driver' exists...
> fail
> LAVA: (stdout) ###
> LAVA: (stdout) ### cpuidle_02:
> LAVA: (stdout) ### Run a cpuidle program killer
> LAVA: (stdout) ###
> https://wiki.linaro.org/WorkingGroups/PowerManagement/Doc/QA/Scripts#cpuidle_02
> LAVA: (stdout) ###
> LAVA: (stdout) cpuidle_02.0: checking cpuidle program runs successfully
> (120 secs)... Test duration exceeded
> LAVA: (stdout) fail
> LAVA: (stderr) make[1]: *** [cpuidle_02.log] Error 1
> LAVA: (stdout) make[1]: Leaving directory
> `/root/.local/share/lava_test/installed-tests/pwrmgmt/pm-qa/cpuidle'
> LAVA: (stderr) make: *** [check] Error 2
> LAVA: Command 'cd pm-qa && make check ' returned non-zero exit status 2
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-power-qa/+bug/1017014/+subscriptions
>

--
Regards,
Rajagopal

Revision history for this message
Hongbo Zhang (hongbo-zhang) wrote :

Rajagopal,
I fixed this one:
LAVA: (stdout) cpufreq_05.4: checking 'ondemand' directory exists... fail

didn't fix others.

Revision history for this message
Botao (botao-sun) wrote :

For Panda 4430 board, observed same behaviour as comment #2 on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/lt-panda-x11-base/219/lt-panda-x11-base-precise_ubuntu-desktop_20120803-219.img.gz

LAVA: (stdout) cpuhotplug_07.0/cpu1: checking offline event was received... fail

LAVA: (stdout) cpufreq_05.4: checking 'ondemand' directory exists... fail

Looks like this is not an expected behaviour, then this bug status should be changed to "confirmed".

Revision history for this message
Rajagopal Venkat (rajagopalvenkat) wrote :

I dont think above failures are related to this bug. Please check with Honbo Zhang and raise new bug if required.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers