Some email addresses collected aren't valid

Reported by James Tunnicliffe on 2012-03-28
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro patch metrics
Medium
Unassigned

Bug Description

I fetched email from the linaro patches account, passing each one to patchwork/apps/patchwork/bin/parsemail-linaro.py using getmail. The full list of email addresses stored in the database contains at least one string that isn't an email address. Need to investigate.

James Tunnicliffe (dooferlad) wrote :

This seems to be the email that was parsed to insert (address hidden) into the database.

From: Linus Walleij <(address hidden)>

The localtimer's clock changes with the cpu clock. After a
cpufreq transition, update the clockevent's frequency and
reprogram the next clock event.

Adds a clock called "smp_twd" that is used to determine the
twd frequency, which can also be used at init time to
avoid calibrating the twd frequency.

Clock changes are based on Rob Herring's work. The
necessary changes in the clockevents framework was done by
Thomas Gleixner in kernel v3.0.

Signed-off-by: Colin Cross <(address hidden)>
Cc: Russell King <(address hidden)>
Acked-by: Thomas Gleixner <(address hidden)>
Acked-by: Rob Herring <(address hidden)>
Acked-by: Santosh Shilimkar <(address hidden)>
[ifdef:ed CPUfreq stuff for non-cpufreq configs]
Signed-off-by: Linus Walleij <(address hidden)>

James Tunnicliffe (dooferlad) wrote :

Subject: [PATCH 5/6] smp_twd: Reconfigure clockevents after cpufreq change
Date: 14/12/11 04:31:27
To: <email address hidden>

James Tunnicliffe (dooferlad) wrote :

This has only happened once, so I am not sure if it is worth updating the code to handle it. Seems that the above fields are grabbed from the email and, quite rightly, no attempt is made to look up an email address of a person based on their name because the email address is a unique identifier, but the name isn't.

Changed in linaro-patchmetrics:
status: New → Won't Fix
Milo Casagrande (milo) wrote :

Adding a comment here, since we are getting again the same error. Copying the output:

WARNING:root:Launchpad rejected email lookup and returned HTTPError. Offending email address: tarmac
WARNING:root:Launchpad rejected email lookup and returned HTTPError. Offending email address: dp583@stebjsxu0119.(none)
WARNING:root:Launchpad rejected email lookup and returned HTTPError. Offending email address:

The second one looks like is an SSH key in Launchpad, the first one I have no idea (there is a ~tarmac team in Launchpad, and also a tarmac project.

Had a brief email exchange with James on this issue this morning, and we might need to add a little bit of email-parsing magic.
I'm reopening this issue, and setting it as lower priority for now.

Changed in linaro-patchmetrics:
status: Won't Fix → Confirmed
importance: Medium → Low
assignee: James Tunnicliffe (dooferlad) → nobody
James Tunnicliffe (dooferlad) wrote :

Just to clarify there are two parts to this. The email parsing logic has inserted invalid email addresses in the database and when we encounter these, we should delete the user. The second part is the email parsing logic that fished out these email addresses in the first place needs to be updated to not re-insert garbage.

Deepti B. Kalakeri (deeptik) wrote :

There are frequent cron mails that we are getting these days with above issue. It needs to be looked at ASAP.

Changed in linaro-patchmetrics:
importance: Low → Medium
Milo Casagrande (milo) on 2013-09-13
Changed in linaro-patchmetrics:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers