problem with run automate test cases in OE image on Lava

Reported by Soumya Basak on 2013-03-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
LAVA Dispatcher
High
Antonio Terceiro
Linaro OpenEmbedded
High
Marcin Juszkiewicz

Bug Description

In pre-built minimal images of OE,
http://snapshots.linaro.org/openembedded/pre-built/vexpress64/256/vexpress64-openembedded_minimal-armv8_20130224-256.img.gz

there is a problem on automated test suite run into LAVA

the details boot log with the above image have a look

http://validation.linaro.org/lava-server/scheduler/job/49258/log_file

log file shows *lava-test-runner* package is not present into the build.

Soumya Basak (soumya-basak) wrote :

on [14-Mar-2013, hrw]: submit OE job on Lava

with boot log details:

http://validation.linaro.org/lava-server/scheduler/job/49673

the problem is fixed. all the automated test cases run on Lava.

Changed in linaro-oe:
status: New → Fix Released
Fathi Boudra (fboudra) on 2013-03-14
Changed in linaro-oe:
assignee: nobody → Marcin Juszkiewicz (hrw)
milestone: none → 13.03
status: Fix Released → Confirmed
Fathi Boudra (fboudra) wrote :

Reopening. After a discussion with Antonio, it isn't the proper fix.
The proper fix is discussed in bug #1154583 - we shouldn't ship the scripts in the image but the scripts should be installed by lava-dispatcher.

Changed in linaro-oe:
importance: Undecided → High
Marcin Juszkiewicz (hrw) on 2013-03-14
Changed in lava-dispatcher:
status: New → Confirmed
Changed in lava-dispatcher:
importance: Undecided → High
assignee: nobody → Antonio Terceiro (terceiro)
milestone: none → 2013.03
Antonio Terceiro (terceiro) wrote :

All lava-test-shell files should be copied to the target by the lava dispatcher, and if that didn't happen that is a bug that we need to fix.

Please do not include lava-test-runner in the image - otherwise I cannot test properly.

Marcin Juszkiewicz (hrw) wrote :

new builds will get it removed.

Antonio Terceiro (terceiro) wrote :

So, after some investigation, I realized that the "lava-test-runner: not found" is actually caused by bash not being present in that image.

$ ls -1 /lava/bin/lava-test-runner
/lava/bin/lava-test-runner
$ /lava/bin/lava-test-runner
-sh: /lava/bin/lava-test-runner: not found
$ head -n 1 /lava/bin/lava-test-runner
#!/bin/bash
$ /bin/bash
-sh: /bin/bash: not found

The session above was run inside a copy of the above mentioned image after the above mentioned job was run against it, run against the ARMv8 Foundations model simulator.

Antonio Terceiro (terceiro) wrote :

OK, so the build missing bash was 256.

I could not reproduce this on build 264, because it does have /bin/bash

Any reason for build 256 not having bash, and build 264 having it? Maybe that was a problem in the build? I could not find any mentions of bash in the meta-linaro git log ...

Anyway, this is not a problem in LAVA.

Changed in lava-dispatcher:
status: Confirmed → Invalid
Marcin Juszkiewicz (hrw) wrote :

All future builds will have bash.

Marcin Juszkiewicz (hrw) on 2013-03-22
Changed in linaro-oe:
status: Confirmed → In Progress
Fathi Boudra (fboudra) wrote :

According to the manifest available in Linaro OpenEmbedded 13.03 release, bash is now available.
Marking the bug fix-released

Changed in linaro-oe:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers