Missing rpc.h header in Linaro AArch64 Cross Toolchain

Bug #1107659 reported by Van Duc Uy on 2013-01-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro OpenEmbedded
Invalid
Undecided
Unassigned
Linaro Toolchain Binaries
Fix Released
High
Zhenqiang Chen

Bug Description

Dear All,
During compile AArch64 with Linaro-4.7 external toolchain, busybox can not compile because missing rpc.h header file.
I copied header file from toolchain source, but it missing another header file is rpc/pmap_port.h with not found in source either.

|
linux/busybox/1.20.2-r5/busybox-1.20.2'
| util-linux/mount.c:135:28: fatal error: rpc/pmap_prot.h: No such file or directory
| compilation terminated.
|
| util-linux/mount.c:135:28: fatal error: rpc/pmap_prot.h: No such file or directory
| compilation terminated.
| make[1]: *** [util-linux/mount.o] Error 1
|
| make[1]: *** [util-linux/mount.o] Error 1
| make[1]: Leaving directory `/projects/oe4/build/external-linaro-eglibc/work/aarch64-oe-linux/busybox/1.20.2-r5/busybox-1.20.2'
|
| make[1]: Leaving directory `/projects/oe4/build/external-linaro-eglibc/work/aarch64-oe-linux/busybox/1.20.2-r5/busybox-1.20.2'
| make: *** [util-linux] Error 2
|
| make: *** [util-linux] Error 2
| + die 'oe_runmake failed'
|
| + die 'oe_runmake failed'
...
build$

Marcin Juszkiewicz (hrw) on 2013-01-28
summary: - Missing rpc.h header in Linaro Toolchain
+ Missing rpc.h header in Linaro AArch64 Cross Toolchain
Changed in linaro-toolchain-binaries:
status: New → Confirmed
Marcin Juszkiewicz (hrw) on 2013-01-28
Changed in linaro-oe:
status: New → Opinion
Changed in linaro-toolchain-binaries:
assignee: nobody → Zhenqiang Chen (zhenqiang-chen)

Bug or feature?

AFAIK (e)glibc intentionally removed the sunrpc bits so they could be replaced with tirpc (which does provide rpc.h).

Most distributions tend to hack those headers back into (e)glibc, but it may be better to start telling people to use tirpc...

Zhenqiang Chen (zhenqiang-chen) wrote :

Yip. Eglibc-2.16 by default does not include the RPC functions and include files in favour of TI-RPC.

I have local patch to enable RPC in our build scripts (will commit after 2013.01 release). A local build is shared at:
http://people.linaro.org/~zhenqiangchen/

Please try it.

Marcin Juszkiewicz (hrw) wrote :

cross toolchain is still at eglibc 2.16????? Please update to 2.17 in 13.02 - there were far too many userspace problems with 2.16.

In reference to comment #2 - I don't think we should be enabling the deprecated RPC features, especially as upstream GLIBC is also deprecating these features.

I think we should be providing TI-RPC somewhere, but am not convinced that the binary toolchain is the right place.

Van Duc Uy (uvan) wrote :

@Zhengqiang: compiled OK with your toolchain.

Marcin Juszkiewicz (hrw) on 2013-03-19
Changed in linaro-oe:
status: Opinion → Invalid
Marcin Juszkiewicz (hrw) wrote :

Ok, the problem re-appears with OpenEmbedded due to it's use of RPC from eglibc. If we want to use Linaro cross toolchains with OE then we have to provide RPC headers.

Switching OE to use libtirpc would cost us more engineering time.

Marcin Juszkiewicz (hrw) wrote :

OK. We have to enable RPC in eglibc. TI RPC is not mature enough for OpenEmbedded guys - for example it lacks NIS support which is required by people working with networking devices.

Changed in linaro-toolchain-binaries:
importance: Undecided → High
Changed in linaro-toolchain-binaries:
milestone: none → 2012.04
status: Confirmed → Fix Committed
milestone: 2012.04 → 2013.04
Marcin Juszkiewicz (hrw) wrote :

Zhenqiang: can I get test versions of both toolchains?

Please get from:

s3://linaro-toolchain-builds/gcc-linaro-aarch64-linux-gnu-4.7-2013.03-20130318_linux.tar.xz

Marcin Juszkiewicz (hrw) on 2013-04-22
Changed in linaro-toolchain-binaries:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers