ICE: libvpx

Bug #1060219 reported by Marcin Juszkiewicz on 2012-10-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro OpenEmbedded
Fix Released
Undecided
Unassigned

Bug Description

    [CC] vpx_scale/generic/gen_scalers.c.o
vpx_scale/generic/gen_scalers.c: In function 'vp8cx_horizontal_line_1_2_scale_c':
vpx_scale/generic/gen_scalers.c:650:1: internal compiler error: in change_address_1, at emit-rtl.c:1996
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
make[1]: *** [vpx_scale/generic/gen_scalers.c.o] Error 1
make: *** [.DEFAULT] Error 2
ERROR: oe_runmake failed
ERROR: Function failed: do_compile (see /home/hrw/HDD/devel/canonical/aarch64/build/tmp-eglibc/work/aarch64-oe-linux/libvpx-0.9.5-r3.0/temp/log.do_compile.30609 for further information)

Found out that it was due to -O3 used.

This should be resolved on aarch64-4.7-branch by upstream commit:

---
r191987 | belagod | 2012-10-02 17:07:05 +0100 (Tue, 02 Oct 2012) | 3 lines

[AARCH64-4.7] Apply Ulrich's reload fix.
---

Marcin Juszkiewicz (hrw) wrote :

Confirmed - bug got fixed with new compiler.

Changed in linaro-oe:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints