Linaro Multimedia WG project

Linaro Ubuntu on Samsung Origen freezes after booting

Reported by Mahanth Gouda on 2012-02-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Linaro Multimedia WG project
High
Unassigned
Linaro Ubuntu
Critical
Ricardo Salveti
linaro-landing-team-samsung
Fix Released
High
Tushar Behera
Ubuntu Linaro Evaluation Build
Undecided
Unassigned

Bug Description

Tried Linaro Ubuntu 12.01 on Samsung Origen. The kernel boots fine and brings up the command prompt and then after 8-10 secs freezes. The serial terminal does not respond to any mouse activies(copy or paste) and keyboard inputs.

I'm not sure if this is the intended behaviour, I mean the CPU going to idle/sleep mode.
If it does, it would be good to have some steps documented about how to bring back the CPU from sleep mode or to avoid the CPU going into sleep.

Also, I found a couple of other issues regarding the sd card. The board does not identify the micro sd card when used with the normal sd card adapter. But when used with the one that's shipped with the board, it boots correctly. Not sure if this is a bug but thought of reporting it.

The board I'm using are
------------------------------
V310 CPU board
Origen base board ISC-A

affects: openstack-ci → ubuntu-leb
Feng Wei (b34248) wrote :

Also exists in 12.02.
I have no video devices connected to origen and I want to test audio functions, but this issue blocks me.

Tom Gall (tom-gall) on 2012-03-08
tags: added: linaro-ubuntu lt-origen
Ilias Biris (ibiris) on 2012-03-08
Changed in linaro-multimedia-project:
importance: Undecided → High
Matt Waddel (mwaddel) wrote :

I recreated this failure using these specific images:

http://releases.linaro.org/12.02/ubuntu/leb-origen/

 hwpack_linaro-leb-origen_20120221-1_armel_supported.tar.gz
 linaro-o-ubuntu-desktop-tar-20120223-1.tar.gz

Ricardo Salveti (rsalveti) wrote :

Can confirm the issue from my side, will be debugging it to see if I can trace what caused it.

Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Ricardo Salveti (rsalveti)
milestone: none → 12.03
Feng Wei (b34248) wrote :

When I connect the board with TV by hdmi cable, the uart console are always active. Seems like a HDMI driver issue?

Usman Ahmad (usman-ah) on 2012-03-09
Changed in linaro-landing-team-samsung:
assignee: nobody → Tushar Behera (tusharbehera)
Tushar Behera (tusharbehera) wrote :

Can you please confirm the case when you connect an USB device to the board?

Changed in linaro-landing-team-samsung:
milestone: none → 2012.03
importance: Undecided → High
Tushar Behera (tusharbehera) wrote :

There was an existing issue with earlier hwpacks where it used to hang when no USB device is connected to the board.

With current source code based on v3.3-rc5 ([1] and [2]), I was able to boot up till Ubuntu Homescreen without any issues. So we might re-check this issue with 12.03 release.

[1] git://git.linaro.org/landing-teams/working/samsung/kernel.git (tracking)
[2] git://git.linaro.org/landing-teams/working/samsung/kernel.git (packaging-origen-3.3)

Changed in linaro-landing-team-samsung:
status: New → Fix Committed
Tom Gall (tom-gall) on 2012-03-13
Changed in linaro-multimedia-project:
status: New → Fix Committed
milestone: none → 2012.03
Changed in linaro-landing-team-samsung:
status: Fix Committed → Fix Released
Ricardo Salveti (rsalveti) wrote :

Fixed with hwpack_linaro-leb-origen_20120327-1_armel_supported.tar.gz.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
Fathi Boudra (fboudra) on 2012-03-29
Changed in linaro-multimedia-project:
status: Fix Committed → Fix Released
Changed in ubuntu-leb:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers