remove click-through for snowball pinned_manifest.xml

Bug #959369 reported by Andy Doan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linaro-license-protection
Fix Released
Medium
Georgy Redkozubov

Bug Description

We have files such as:

 http://snapshots.linaro.org/android/~linaro-android/snowball-ics-gcc46-igloo-stable-blob/207/pinned-manifest.xml

that are requiring a click-through to access. This is screwing up work for:

  https://blueprints.launchpad.net/linaro-android/+spec/create-build-script-from

because that script needs to be able to download the pinned manifest in order to set up the user's android repo.

Changed in linaro-license-protection:
assignee: nobody → Georgy Redkozubov (gesha)
importance: Undecided → High
Revision history for this message
Данило Шеган (danilo) wrote :

I believe we should go a different route: make the script in lp:linaro-license-protection testing/filefetcher.py usable by others when an explicit --accept-license=yes parameter is passed in. Would that be sufficient for your purposes, Andy?

Changed in linaro-license-protection:
importance: High → Medium
assignee: Georgy Redkozubov (gesha) → nobody
status: New → Incomplete
Revision history for this message
Andy Doan (doanac) wrote : Re: [Bug 959369] Re: remove click-through for snowball pinned_manifest.xml

On 03/21/2012 10:20 AM, Данило Шеган wrote:
> I believe we should go a different route: make the script in lp:linaro-
> license-protection testing/filefetcher.py usable by others when an
> explicit --accept-license=yes parameter is passed in. Would that be
> sufficient for your purposes, Andy?

That doesn't really work for my script because its supposed to be a
simple standalone shell script that end-users grab to reproduce an
android build from scratch.

Revision history for this message
Alexander Sack (asac) wrote :

I am not really positive about writing an official linaro tool that bypasses the EULA.

On this bug: I don't think the problem is pinned-manifest.xml not being wget'able ... it's really that for all builds that rightly display the EULA, it is almost 100% certain that you will not be able to get all sources without going through click through in browser loops manually anyway. I know that opening up manifest.xml might improve this world a bit, but it will certainly not be a cure.

Options to ease developer convenience really seems to be a tool that can wget linaro bits with displaying proper EULA accept. Can't we make our website w3m/elinks compatible and use that for downloading and then get a nice EULA accept page?

Revision history for this message
James Tunnicliffe (dooferlad) wrote :

It should be very easy to get the download script to cache the license
text of accepted licenses so they can be auto-accepted on subsequent
runs. I was working on this but had a higher priority interrupt :-)

I have been working on this in the context of linaro-fetch-image,
which will need to download some license protected files if it is
going to have full support for all our hardware so the library of
image fetching functions I have written give you an API that gives the
calling function a license text file and a way of accepting it. Yes,
it can be used to download files without ever reading a license, but
writing a script to do that is trivial anyway. The point is we have 1
set of functions that are maintained along with any changes to the
license pages.

Really, the ideal would be to do more of this server side, so every
automated download does something like:

dl.linaro.org/request?url=<url>
gets back a license (may be an empty string for no license)

dl.linaro.org/request?url=<url>&licnese=<md5sum>
performs the actual download.

This way if the license changes the application won't send the correct
md5sum and will be returned an appropriate error code.

--
James Tunnicliffe

Revision history for this message
Andy Doan (doanac) wrote :

I think this thread is moving in a different direction than the core problem I'm facing. The pinned_manifest has no need of being protected by the EULA. In order to run this specific script they must pass a command line option to the overlay.tar.gz file which they *must* download separately from the script and accept the EULA.

The script has two options:

1) build from the tip of manifest branches. This works, because the manifests are just in git.

2) (default option) reproduce an exact android build using the pinned manifest. This is a build artifact that used be on android-build so everything worked. However, when we moved the artifacts over to snapshots, everything broke.

That said, if we can't just wget this file. I'm sure we could alter the script to do some sort of text-based EULA agreement. Its just adding logic to a script that was intended to be very minimal.

Revision history for this message
Andy Doan (doanac) wrote :

I think we can close this out now. Zach and I agreed on a way to work around this in my script

Revision history for this message
Fathi Boudra (fboudra) wrote :

Closing since per file eula is deployed.

Changed in linaro-license-protection:
milestone: none → 2012.04
status: Incomplete → Fix Released
assignee: nobody → Georgy Redkozubov (gesha)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers