[regression] No DVI output on the PandaBoard with kernel 3.1.0-1402-linaro-lt-omap

Bug #894073 reported by Jean-Yves Lefort on 2011-11-23
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Ricardo Salveti
linaro-landing-team-ti
Fix Released
Medium
Unassigned

Bug Description

Just upgraded my packages, this pulled in linux-image-3.1.0-1402-linaro-lt-omap. After a reboot, there is no output on the DVI monitor. After restoring the boot partition from yesterday's backup (switching back to 3.1.0-1401-linaro-lt-omap), the DVI output works again.

Ricardo Salveti (rsalveti) wrote :

I can confirm the issue on my side. This kernel is the one used from the 11.11 TI LT release.

Changed in linaro-ubuntu:
status: New → Confirmed
summary: - No DVI output on the PandaBoard with kernel 3.1.0-1402-linaro-lt-omap
+ [regression] No DVI output on the PandaBoard with kernel 3.1.0-1402
+ -linaro-lt-omap
Changed in linaro-ubuntu:
importance: Undecided → High
assignee: nobody → Ricardo Salveti (rsalveti)
Ricardo Salveti (rsalveti) wrote :

My boot log with debug: http://paste.ubuntu.com/747352/

Seems this is the issue:

Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.005645] omapdss DSS: context saved
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008270] omapdss CORE: bus_match. dev display0/hdmi_panel, drv generic_dpi_panel
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008300] omapdss CORE: bus_match. dev display1/generic_dpi_panel, drv generic_dpi_panel
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008361] omapdss CORE: driver_probe: dev display1/generic_dpi_panel, drv generic_dpi_panel
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008361] omapdss DPI: init_display
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008422] omapdss DISPC: dispc_runtime_get
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008453] omapdss DSS: dss_runtime_get
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008605] omapdss DSS: dss_restore_context
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008636] omapdss DSS: context restored
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008636] omapdss DISPC: dispc_restore_context
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008666] omapdss DISPC: dispc_runtime_put
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.008697] omapdss CORE error: driver probe failed: -22
Nov 22 19:02:59 linaro-ubuntu-desktop kernel: [ 2.009765] generic_dpi_panel: probe of display1 failed with error -22

warmcat (andy-warmcat) wrote :

At request of Seb, we backported Tomi's hdmi patches that went upstream after 3.1 release from tracking to tilt-3.1. They provide some good architectural improvements but expose a big problem with two heads on dss, there is no mediation about who owns the common pll. Result is that i had to disable the new dvi "panel" driver to stop hdmi workability getting destroyed by dvi resetting the pll to something else.

I discussed with Tomi he says he may add support for pll management but 'no promises'. In themeanwhile best way is deconfigure dvi panel (i guess you didn't configure it) and just use hdmi.

On Wed, Nov 23, 2011 at 8:01 PM, warmcat <email address hidden> wrote:
> At request of Seb, we backported Tomi's hdmi patches that went upstream
> after 3.1 release from tracking to tilt-3.1.  They provide some good
> architectural improvements but expose a big problem with two heads on
> dss, there is no mediation about who owns the common pll.  Result is
> that i had to disable the new dvi "panel" driver to stop hdmi
> workability getting destroyed by dvi resetting the pll to something
> else.

Marking as confirmed at the LT side then.

> I discussed with Tomi he says he may add support for pll management but
> 'no promises'.  In themeanwhile best way is deconfigure dvi panel (i
> guess you didn't configure it) and just use hdmi.

With previous kernel the DRM driver would probe and enable the DVI
panel if detected, don't know if the behavior has changed for this
kernel.

tags: added: linaro-ubuntu lt-panda secondary-video-out
Changed in linaro-landing-team-ti:
status: New → Confirmed
warmcat (andy-warmcat) wrote :

Yeah there is a new CONFIG for a new logical DVI panel. It should be disabled at I guess it will have been defaulting to disabled in your case with your own config.

If you enable it, DVI takes the approach to default to 640 x 480 even with nothing plugged in and trashes HDMI output by setting the shared pll.

Tom Gall (tom-gall) wrote :

Just did an install with the oneiric hwpack from 20111211 for panda. I'm not getting output via HDMI or DVI, it would appear this issue still exists.

warmcat (andy-warmcat) wrote :

Tom there was a boot race about runtime_pm for hdmi and dss I just fixed on tilt-3.1, tilt-linux-linaro-3.1 and tilt-tracking. That should solve the problem of HDMI sometimes not coming up at boot.

The DVI problem still remains.

Anmar Oueja (anmar) wrote :

Andy: Any news from Tomi regarding the PLL management? an ETA would be nice.

warmcat (andy-warmcat) wrote :

I wrote him about it a few weeks ago. His reply was that he might look at it but (literally) "no promises".

For DRM / Ubuntu case I think we can make a workaround by fixing hotplug detect and just allow one head or the other, but we have no spare time for it either right now.

Anmar Oueja (anmar) wrote :

Snowball has a similar issue. There is a patch (#898650) that might provide ideas for a solution.

warmcat (andy-warmcat) wrote :

Anmar thanks for the thought, but the issue for panda is different since we use a drm video driver already with good edid parsing.

Our problems revolve around connector detection being reliable at boot for hdmi, which I think may just mean sleep 2s after hdmi chip powered; dvi head wants to set a default mode when enabled, drm enables dvi to check connector presence, since they share a pll with hdmi that overwrites hdmi clock with dvi default mode clock even if nothing is in dvi connector if dvi is even configured in kernel; and post-boot hotplug framebuffer setting works but gets a mismatched raster, eg, 1080p fb later sets 576p raster.... works ok when set initially.

We're looking at this already since tuesday but it looks like it will take a while.

Anmar Oueja (anmar) on 2012-02-01
Changed in linaro-landing-team-ti:
importance: Undecided → Medium
warmcat (andy-warmcat) wrote :

Last time I tested tilt-3.3, it was willing to come up with DVI connector okay if that was plugged in from powerup. Dynamic hotplug was still broken. What's your actual testing procedure?

Ricardo Salveti (rsalveti) wrote :

DVI is working again with 3.4. Marking as fix commited for 12.06.

Changed in linaro-landing-team-ti:
status: Confirmed → Fix Committed
Changed in linaro-ubuntu:
status: Confirmed → Fix Committed
milestone: none → 12.06
warmcat (andy-warmcat) on 2012-06-27
Changed in linaro-landing-team-ti:
status: Fix Committed → Fix Released
Changed in linaro-ubuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers