HDMI not working with tilt linux 3.1

Bug #880073 reported by Ricardo Salveti on 2011-10-22
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
High
Ricardo Salveti
linaro-landing-team-ti
Invalid
Undecided
Unassigned

Bug Description

The monitor turns itself on, but nothing appears on the screen. The issue just happens with HDMI, as with DVI it works just fine.

Attached you can find the dmesg.

Hwpack: hwpack_linaro-lt-panda-x11-base_20111021-1_armel_supported.tar.gz
Rootfs: linaro-o-ubuntu-desktop-tar-20111021-0.tar.gz

Ricardo Salveti (rsalveti) wrote :
visibility: private → public
Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Critical
milestone: none → 11.10
Ricardo Salveti (rsalveti) wrote :

Same monitor works fine with the 3.0 series. Panda tested is a 4430 ES2.1 A2.

warmcat (andy-warmcat) wrote :

I can't reproduce this.

1080p is coming on HDMI on both 4430 and 4460 with both tracking-topic-drm and tracking-topic-syslink-k3u (aka tilt-tracking), and I additionally updated tilt-linux-linaro-3.1 and confirmed it there as well in case that's the tree you are testing.

On Sun, Oct 23, 2011 at 6:26 AM, warmcat <email address hidden> wrote:
> I can't reproduce this.
>
> 1080p is coming on HDMI on both 4430 and 4460 with both tracking-topic-
> drm and tracking-topic-syslink-k3u (aka tilt-tracking), and I
> additionally updated tilt-linux-linaro-3.1 and confirmed it there as
> well in case that's the tree you are testing.

Probably related with my monitor then (I had some issues in the past
with the LG monitors that could not get the EDID when the monitor was
still probing all inputs).

Used your tilt-linux-linaro-3.1 with omap4_defconfig. The boot log
with omapdss.debug=1 and drm.debug=14: http://paste.ubuntu.com/717006/

It gives me invalid timing and then it can't set the overlay properly.

Changed in linaro-ubuntu:
importance: Critical → High
Ricardo Salveti (rsalveti) wrote :

Tested with another monitor and it worked fine, even after giving a lot of "omapdss HDMI error: Invalid timing entered", so it's probably just related with the one I have at home (LG).

Once I'm back from Connect I'll try to debug it again.

Anmar Oueja (anmar) wrote :

Marked as invalid for now. If the issue persists please reopen.

Changed in linaro-landing-team-ti:
status: New → Invalid
Fathi Boudra (fboudra) on 2011-11-11
Changed in linaro-ubuntu:
milestone: 11.10 → 11.11
Ricardo Salveti (rsalveti) wrote :

I'm unable to reproduce this issue with the tilt-linux-linaro-3.1 from the 11.11 release.

Changed in linaro-ubuntu:
status: Confirmed → Fix Released
assignee: nobody → Ricardo Salveti (rsalveti)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments