Microphone doesn't work on Origen ubuntu image.

Bug #988977 reported by Botao on 2012-04-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Undecided
Unassigned
linaro-landing-team-samsung
Fix Released
Medium
Tushar Behera

Bug Description

On 12.04 build:

http://snapshots.linaro.org/precise/hwpacks/leb-origen/45/hwpack_linaro-leb-origen_20120426-45_armhf_supported.tar.gz

with ubuntu image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/119/linaro-precise-ubuntu-desktop-20120426-119.tar.gz

Microphone doesn't work. Plugged in a 3.5mm microphone, and no any response on the sound setting -> Input tab when I knock it, and the audio recorder can't record any voice either.

#################################################################
This feature doesn't work on following images:

http://snapshots.linaro.org/precise/hwpacks/leb-origen/45/hwpack_linaro-leb-origen_20120426-45_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/leb-origen/109/hwpack_linaro-leb-origen_20120524-109_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/leb-origen/175/hwpack_linaro-leb-origen_20120626-175_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/leb-origen/200/hwpack_linaro-leb-origen_20120708-200_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/leb-origen/213/hwpack_linaro-leb-origen_20120714-213_armhf_supported.tar.gz

https://snapshots.linaro.org/precise/hwpacks/leb-origen/232/hwpack_linaro-leb-origen_20120723-232_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/leb-origen/245/hwpack_linaro-leb-origen_20120729-245_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/259/leb-origen-precise_ubuntu-desktop_20120805-259.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/273/leb-origen-precise_ubuntu-desktop_20120812-273.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/287/leb-origen-precise_ubuntu-desktop_20120819-287.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/312/leb-origen-precise_ubuntu-desktop_20120828-312.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/316/leb-origen-precise_ubuntu-desktop_20120830-316.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/336/leb-origen-precise_ubuntu-desktop_20120909-336.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/349/leb-origen-precise_ubuntu-desktop_20120916-349.img.gz

https://snapshots.linaro.org/precise/pre-built/leb-origen/365/leb-origen-precise_ubuntu-desktop_20120924-365.img.gz

http://snapshots.linaro.org/precise/hwpacks/leb-origen/377/hwpack_linaro-leb-origen_20120928-377_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/395/leb-origen-precise_ubuntu-desktop_20121007-395.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/409/leb-origen-precise_ubuntu-desktop_20121014-409.img.gz

https://snapshots.linaro.org/precise/pre-built/leb-origen/424/leb-origen-precise_ubuntu-desktop_20121021-424.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/453/leb-origen-precise_ubuntu-desktop_20121105-453.img.gz

http://snapshots.linaro.org/precise/pre-built/leb-origen/480/leb-origen-precise_ubuntu-desktop_20121119-480.img.gz

Usman Ahmad (usman-ah) on 2012-04-30
Changed in linaro-landing-team-samsung:
importance: Undecided → Medium
Tushar Behera (tusharbehera) wrote :

I tested using a line-in cable.

Sound Recorder -> Record ...

I was able to record and playback the audio.

Can you check with a line-in cable (inserted in blue port) with an high-volume audio input?

Changed in linaro-landing-team-samsung:
assignee: nobody → Tushar Behera (tusharbehera)
status: New → Opinion
status: Opinion → Triaged
Tushar Behera (tusharbehera) wrote :

The microphone port (blue one) seems to be connected to LINE_IN of audio codec, hence the input signal strength is expected to be more. Verified audio recording with a line-in input.

Changed in linaro-landing-team-samsung:
status: Triaged → Invalid
Botao (botao-sun) on 2012-05-29
visibility: private → public
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :

Observed on hardware pack:

http://snapshots.linaro.org/precise/hwpacks/leb-origen/175/hwpack_linaro-leb-origen_20120626-175_armhf_supported.tar.gz

with ubuntu rootfs image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/247/linaro-precise-ubuntu-desktop-20120626-247.tar.gz

Hear nothing when playback. Is there anyone can verify this? Or if it's caused by the over low volume input, then could anyone can modify the code to set a higher default value?

Botao (botao-sun) wrote :

Observed on Samsung Origen board with Linaro ubuntu hardware pack:

http://snapshots.linaro.org/precise/hwpacks/leb-origen/200/hwpack_linaro-leb-origen_20120708-200_armhf_supported.tar.gz

and rootfs:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/274/linaro-precise-ubuntu-desktop-20120708-274.tar.gz

I don't think it's caused by the low voice signal strength because in the sound settings, there is no any response in "Input" section, whatever I speak or hit my microphone.

Botao (botao-sun) wrote :
Botao (botao-sun) wrote :

Same behavior as comment #7, observed on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/leb-origen/259/leb-origen-precise_ubuntu-desktop_20120805-259.img.gz

Please refer to attachment to get boot log in serial console.

Botao (botao-sun) wrote :

Same behavior as comment #7, observed on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/leb-origen/273/leb-origen-precise_ubuntu-desktop_20120812-273.img.gz

Please refer to attachment to get boot log in serial console.

Changed in linaro-landing-team-samsung:
status: Invalid → New
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :

On Samsung Origen board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/leb-origen/312/leb-origen-precise_ubuntu-desktop_20120828-312.img.gz

The sound input device shows in "Input" section in Sound settings, but whatever I speak to my microphone, no any response. The microphone port is that blue one.

Botao (botao-sun) wrote :

Same behaviour as comment #12, observed on Samsung Origen board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/leb-origen/316/leb-origen-precise_ubuntu-desktop_20120830-316.img.gz

Tushar Behera (tusharbehera) wrote :

Issue reported in #10 has been fixed and the fix has been committed.

Changed in linaro-landing-team-samsung:
status: New → Fix Committed
milestone: none → 2012.09
Botao (botao-sun) wrote :

The fix for comment #7 & #10 has been confirmed, however, microphone still doesn't work. Observed on Samsung Origen board with Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/leb-origen/336/leb-origen-precise_ubuntu-desktop_20120909-336.img.gz

Botao (botao-sun) on 2012-09-18
description: updated
Botao (botao-sun) on 2012-09-26
description: updated
Botao (botao-sun) on 2012-10-04
description: updated
Botao (botao-sun) on 2012-10-08
description: updated
Botao (botao-sun) on 2012-10-17
description: updated
Tushar Behera (tusharbehera) wrote :

As per #2, landing team won't be fixing this issue any more.

Changed in linaro-landing-team-samsung:
status: Fix Committed → Fix Released
Botao (botao-sun) wrote :

@Tushar, Let's check it when we meet in LCE12.

Botao (botao-sun) on 2012-10-24
description: updated
description: updated
description: updated
Fathi Boudra (fboudra) on 2013-03-29
Changed in linaro-ubuntu:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers