Origen: HDMI Audio not working

Bug #938495 reported by Ricardo Salveti on 2012-02-22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Fix Released
Giridhar BM

Bug Description

With Ubuntu LEB 12.02 RC image, there's no way to select HDMI audio from the sound settings application.

With alsa-mixer there's also not clear option on how to enable sound support with HDMI.

Ideally at the sound-settings application it'd give an option to select the jack or the HDMI output as the default one, so people can easily select it while using the Ubuntu LEB.

visibility: private → public
Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → High
Changed in linaro-landing-team-samsung:
assignee: nobody → Tushar Behera (tusharbehera)
Changed in linaro-landing-team-samsung:
importance: Undecided → Medium
Changed in linaro-landing-team-samsung:
status: New → Confirmed
Changed in linaro-landing-team-samsung:
milestone: none → 2012.04
Ricardo Salveti (rsalveti) wrote :

Still the case with the 12.03 RC image.

Changed in linaro-landing-team-samsung:
assignee: Tushar Behera (tusharbehera) → nobody
assignee: nobody → Giridhar BM (giridhar-bm)
Changed in linaro-landing-team-samsung:
milestone: 2012.04 → 2012.05
importance: Medium → High
Ricardo Salveti (rsalveti) wrote :

Still happening with 12.04.

Changed in linaro-landing-team-samsung:
status: Confirmed → Fix Committed
Changed in linaro-landing-team-samsung:
status: Fix Committed → Fix Released
Botao Sun (botao-sun) wrote :

Observed on hardware pack:


with ubuntu image:


There is no option in the output column for HDMI, refer to attachment to get snapshot.

However, I don't plug in a HDMI cable. Is that option only showing up when there is a HDMI cable connected?

There is no specific option for selecting HDMI audio. HDMI audio is
enabled when HDMI is enabled (manually in Ubuntu, automatically in

Ricardo Salveti (rsalveti) wrote :

@Tushar: this is not the expected behavior at Ubuntu. The user should be able to select either HDMI Audio or Jack, and that should be available via alsa-ucm and the sound-properties screen.

Botao Sun (botao-sun) wrote :
Tushar Behera (tusharbehera) wrote :

For HDMI to work, you need to update /ext/X11/xorg.conf

Can you test whether HDMI audio is working when HDMI display is functional? If so, it would be better to rename this bug as "Origen: Ubuntu: There is no option to select HDMI audio output".

Botao Sun (botao-sun) wrote :

@Tushar, HDMI display is unavailable by default. Do you mean that if someone who wants to use HDMI as his / her display output, then a manually modification on file "/ext/X11/xorg.conf" is required? Is there possible to do this like automatically detect?

As I know, the Panda board can switch between HDMI & DVI-D modes automatically.

Fathi Boudra (fboudra) on 2013-03-29
Changed in linaro-ubuntu:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers