Android Build 33 Does Not Boot

Bug #844041 reported by Zach Pfeffer on 2011-09-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro Android
Fix Released
Medium
Botao Sun
linaro-landing-team-samsung
Fix Released
Medium
Angus Ainslie

Bug Description

I've tried to boot:

https://android-build.linaro.org/builds/~linaro-android/leb-origen/#build=33

...but I get this:

U-Boot 2011.06-01083-g0087ab1 (Sep 07 2011 - 10:12:45) for ORIGEN

CPU: S5PC210@1000MHz

Board: ORIGEN
DRAM: 1 GiB
MMC: SAMSUNG SD/MMC: 0
*** Warning - bad CRC, using default environment

In: serial
Out: serial
Err: serial
Hit any key to stop autoboot: 0
reading uImage

** Unable to read "uImage" from mmc 0:1 **
Wrong Image Format for bootm command
ERROR: can't get kernel image!
ORIGEN #

Zach Pfeffer (pfefferz) on 2011-09-07
Changed in linaro-android:
assignee: nobody → Botao Sun (botao-sun)
importance: Undecided → Critical
status: New → Confirmed
summary: - Android Build 33 Does not Boot
+ Android Build 33 Does Not Boot
visibility: private → public

It looks like the wrong u-boot or linaro-android-media-create is being used

--
Angus Ainslie
Samsung landing team lead
Sent from my Android powered device
On Sep 7, 2011 10:30 AM, "Zach Pfeffer" <email address hidden> wrote:
> Public bug reported:
>
> I've tried to boot:
>
> https://android-build.linaro.org/builds/~linaro-android/leb-
> origen/#build=33
>
> ...but I get this:
>
>
> U-Boot 2011.06-01083-g0087ab1 (Sep 07 2011 - 10:12:45) for ORIGEN
>
> CPU: S5PC210@1000MHz
>
> Board: ORIGEN
> DRAM: 1 GiB
> MMC: SAMSUNG SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In: serial
> Out: serial
> Err: serial
> Hit any key to stop autoboot: 0
> reading uImage
>
> ** Unable to read "uImage" from mmc 0:1 **
> Wrong Image Format for bootm command
> ERROR: can't get kernel image!
> ORIGEN #
>
> ** Affects: linaro-android
> Importance: Critical
> Assignee: Botao Sun (botao-sun)
> Status: Confirmed
>
> ** Affects: linaro-landing-team-samsung
> Importance: Undecided
> Status: New
>
> ** Also affects: linaro-android
> Importance: Undecided
> Status: New
>
> ** Changed in: linaro-android
> Assignee: (unassigned) => Botao Sun (botao-sun)
>
> ** Changed in: linaro-android
> Importance: Undecided => Critical
>
> ** Changed in: linaro-android
> Status: New => Confirmed
>
> ** Summary changed:
>
> - Android Build 33 Does not Boot
> + Android Build 33 Does Not Boot
>
> ** Visibility changed to: Public
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: Samsung, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/844041
>
> Title:
> Android Build 33 Does Not Boot
>
> Status in Linaro Android:
> Confirmed
> Status in Linaro Samsung Landing Team Project:
> New
>
> Bug description:
> I've tried to boot:
>
> https://android-build.linaro.org/builds/~linaro-android/leb-
> origen/#build=33
>
> ...but I get this:
>
>
> U-Boot 2011.06-01083-g0087ab1 (Sep 07 2011 - 10:12:45) for ORIGEN
>
> CPU: S5PC210@1000MHz
>
> Board: ORIGEN
> DRAM: 1 GiB
> MMC: SAMSUNG SD/MMC: 0
> *** Warning - bad CRC, using default environment
>
> In: serial
> Out: serial
> Err: serial
> Hit any key to stop autoboot: 0
> reading uImage
>
> ** Unable to read "uImage" from mmc 0:1 **
> Wrong Image Format for bootm command
> ERROR: can't get kernel image!
> ORIGEN #
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/844041/+subscriptions

Botao Sun (botao-sun) wrote :

Set these boot arguments following the "ORIGEN #":

setenv bootargs "console=ttySAC2,115200n8 root=/dev/ram init=/init rootwait ro"
setenv bootcmd "fatload mmc 0:2 0x40007000 uImage; fatload mmc 0:2 0x42000000 uInitrd; bootm 0x40007000 0x42000000"
saveenv

Then restart the board, it will work. I have tested it on my Origen board.

This is an old issue, I remember it fixed by Angus before, but now it comes out again.

Changed in linaro-android:
importance: Critical → Medium
milestone: none → 11.09

A patch got missed when I updated u-boot.

Should be fixed tomorrow

On Wed, Sep 7, 2011 at 11:33 AM, Botao Sun <email address hidden> wrote:
> Set these boot arguments following the "ORIGEN #":
>
> setenv bootargs "console=ttySAC2,115200n8 root=/dev/ram init=/init rootwait ro"
> setenv bootcmd "fatload mmc 0:2 0x40007000 uImage; fatload mmc 0:2 0x42000000 uInitrd; bootm 0x40007000 0x42000000"
> saveenv
>
> Then restart the board, it will work. I have tested it on my Origen
> board.
>
> This is an old issue, I remember it fixed by Angus before, but now it
> comes out again.
>
> ** Changed in: linaro-android
>   Importance: Critical => Medium
>
> ** Changed in: linaro-android
>    Milestone: None => 11.09
>
> --
> You received this bug notification because you are a member of Linaro
> Landing Team: Samsung, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/844041
>
> Title:
>  Android Build 33 Does Not Boot
>
> Status in Linaro Android:
>  Confirmed
> Status in Linaro Samsung Landing Team Project:
>  New
>
> Bug description:
>  I've tried to boot:
>
>  https://android-build.linaro.org/builds/~linaro-android/leb-
>  origen/#build=33
>
>  ...but I get this:
>
>
>  U-Boot 2011.06-01083-g0087ab1 (Sep 07 2011 - 10:12:45) for ORIGEN
>
>  CPU:    S5PC210@1000MHz
>
>  Board: ORIGEN
>  DRAM:  1 GiB
>  MMC:   SAMSUNG SD/MMC: 0
>  *** Warning - bad CRC, using default environment
>
>  In:    serial
>  Out:   serial
>  Err:   serial
>  Hit any key to stop autoboot:  0
>  reading uImage
>
>  ** Unable to read "uImage" from mmc 0:1 **
>  Wrong Image Format for bootm command
>  ERROR: can't get kernel image!
>  ORIGEN #
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/linaro-android/+bug/844041/+subscriptions
>

--
Angus Ainslie <email address hidden>
Team Lead, Samsung Landing Team

Botao Sun (botao-sun) wrote :

A separated bug has submitted for this issue: https://bugs.launchpad.net/bugs/844380

Changed in linaro-landing-team-samsung:
status: New → Confirmed
Changed in linaro-android:
status: Confirmed → Fix Committed
Changed in linaro-landing-team-samsung:
status: Confirmed → Fix Committed
Changed in linaro-android:
status: Fix Committed → Confirmed
Botao Sun (botao-sun) wrote :

Verified. This bug has been fixed.

Changed in linaro-android:
status: Confirmed → Fix Committed
Changed in linaro-android:
status: Fix Committed → Fix Released
Usman Ahmad (usman-ah) on 2011-09-14
Changed in linaro-landing-team-samsung:
importance: Undecided → Medium
assignee: nobody → Angus Ainslie (angus-akkea)
milestone: none → 2011.09
Changed in linaro-landing-team-samsung:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers