Power Management LAVA test failed on "checking 'ondemand' directory exists".

Bug #1005829 reported by Botao
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Linaro PMWG QA
Fix Released
Medium
Hongbo Zhang
linaro-landing-team-samsung
Invalid
Undecided
Unassigned

Bug Description

On hardware pack:

http://snapshots.linaro.org/precise/hwpacks/leb-origen/109/hwpack_linaro-leb-origen_20120524-109_armhf_supported.tar.gz

with ubuntu image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/179/linaro-precise-ubuntu-desktop-20120525-179.tar.gz

when run the power management LAVA test:

https://wiki.linaro.org/Platform/QA/TestCases/Ubuntu#Power_Management

There is a failed information:

LAVA: (stdout) ###
LAVA: (stdout) ### cpufreq_05:
LAVA: (stdout) ### test 'ondemand' and 'conservative' trigger correctly the configuration directory
LAVA: (stdout) ### https://wiki.linaro.org/WorkingGroups/PowerManagement/Doc/QA/Scripts#cpufreq_05
LAVA: (stdout) ###
LAVA: (stdout) cpufreq_05.0: checking 'ondemand' directory exists... pass
LAVA: (stdout) cpufreq_05.1: checking 'conservative' directory exists... pass
LAVA: (stdout) cpufreq_05.2: checking 'ondemand' directory is not there... pass
LAVA: (stdout) cpufreq_05.3: checking 'conservative' directory is not there... pass
LAVA: (stdout) cpufreq_05.4: checking 'ondemand' directory exists... fail
LAVA: (stdout) cpufreq_05.5: checking 'conservative' directory exists... pass

All the other tests passed.

Botao (botao-sun)
visibility: private → public
Revision history for this message
Inderpal Singh (ips) wrote :

The tests 05.4 and 05.5 are invalid as both cpus can not be run at different freq and hence different governors can not be set.
The same has been mentioned at Bug # 894256

Changed in linaro-landing-team-samsung:
status: New → Invalid
Revision history for this message
Ricardo Salveti (rsalveti) wrote :

Since it's invalid from the LT side, I'm opening a bug at the PWMG QA test project so this can be properly covered there.

Amit Kucheria (amitk)
Changed in linaro-power-qa:
assignee: nobody → Hongbo Zhang (hongbo-zhang)
Revision history for this message
Botao (botao-sun) wrote :

On hardware pack:

http://snapshots.linaro.org/precise/hwpacks/leb-origen/175/hwpack_linaro-leb-origen_20120626-175_armhf_supported.tar.gz

with ubuntu rootfs image:

http://snapshots.linaro.org/precise/images/ubuntu-desktop/247/linaro-precise-ubuntu-desktop-20120626-247.tar.gz

Only "cpufreq_05.4" failed:

LAVA: (stdout) cpufreq_05.4: checking 'ondemand' directory exists... fail

Refer to attachment to get the detailed log.

Revision history for this message
Hongbo Zhang (hongbo-zhang) wrote :

This is not a problem of Linaro PMWG QA, so I change the status to Invalid.
I think such issue should be check by Samsung if needed.

Changed in linaro-power-qa:
status: New → Invalid
Amit Kucheria (amitk)
Changed in linaro-power-qa:
status: Invalid → Confirmed
importance: Undecided → Medium
Revision history for this message
Amit Kucheria (amitk) wrote :

Hongbo, why do you think this is not a PM-QA bug?

As comment #1 correctly states, that the current generation of multi-core ARM SoC don't allow their cpu frequencies to be changed separately. IOW, both cores will change to the same frequency.

So our scripts should be checking the following files in sysfs:
 * affected_cpus : List of CPUs that require software coordination of frequency.
 * related_cpus : List of CPUs that need some sort of frequency coordination, whether software or hardware.

For all cpus in affected_cpus, we shouldn't set different governors.

Revision history for this message
Hongbo Zhang (hongbo-zhang) wrote :

Amit,
I know the truth, I thought that it was due to the CPUs having no such ability to run at different frequencies, so we got fails of course.

But after your reminding, I agree that we should check the abilities before setting parameters to it. I will update it.

Thanks.

Revision history for this message
Botao (botao-sun) wrote :
Revision history for this message
Botao (botao-sun) wrote :
Revision history for this message
Hongbo Zhang (hongbo-zhang) wrote :

This has been fixed, the patch has been pushed into the git server.

Changed in linaro-power-qa:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers