vexpress: android: YouTube video playback fails

Bug #987172 reported by Tixy (Jon Medhurst) on 2012-04-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Android
Won't Fix
Medium
Unassigned
linaro-landing-team-arm
Won't Fix
Undecided
Unassigned

Bug Description

Trying to play any videos in YouTube fails in various ways (this has never worked). Attached is one logcat snippet of a failure.

#########################################################################
YouTube video playback failed on vexpress A9 board with following images:
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open-12.04-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open-12.05-release/#build=3
https://android-build.linaro.org/builds/~linaro-android/vexpress-rtsm-ics-gcc47-armlt-stable-open-12.05-release/#build=4
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open/#build=62
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open/#build=71
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open/#build=78
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open/#build=83
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open-12.07-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open/#build=97
https://android-build.linaro.org/builds/~linaro-android/vexpress-ics-gcc47-armlt-tracking-open/#build=104
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=7
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=16
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.08-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=30
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=37
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=42
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.09-release/#build=3
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=57
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=65
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=71
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.10-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=95
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=99
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.11-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=117
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=126
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.12-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=152
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=158
https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=167
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.01-release/#build=1
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=185
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=191
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=220
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=250
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.04-release/#build=5
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=291
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp-13.05-release/#build=2
https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=325

https://android-build.linaro.org/builds/~linaro-android/vexpress-lsk/#build=52

Tixy (Jon Medhurst) (tixy) wrote :
tags: added: youtube
visibility: private → public
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :
Botao (botao-sun) wrote :

For vexpress A9 board, observed on Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open-12.08-release/#build=1

Only preview pictures show up.

Botao (botao-sun) wrote :

Same behaviour observed as comment #13 on vexpress A9 board with Linaro Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=30

Botao (botao-sun) on 2012-09-25
description: updated
Amit Khare (amit-khare) on 2012-10-01
description: updated
Amit Khare (amit-khare) on 2012-10-08
description: updated
Amit Khare (amit-khare) on 2012-10-15
description: updated
Amit Khare (amit-khare) on 2012-10-23
description: updated
Botao (botao-sun) on 2012-11-09
description: updated
Botao (botao-sun) on 2012-11-13
description: updated
Botao (botao-sun) on 2012-11-26
description: updated
Tixy (Jon Medhurst) (tixy) wrote :

After deselect the 'HQ' option on the YouTube page, it's now possible to play videos and get sound, but videos is blank. 'logcat' shows lots off:

W/SoftwareRenderer( 1926): Surface::dequeueBuffer returned error -22
E/BufferQueue( 2635): [unnamed-2635-1] dequeueBuffer: can't dequeue multiple buffers without setting the buffer count

Changed in linaro-landing-team-arm:
milestone: none → 2012.11
milestone: 2012.11 → none
Botao (botao-sun) on 2012-12-04
description: updated
Botao (botao-sun) wrote :
description: updated
vishal (vishalbhoj) on 2012-12-18
Changed in linaro-android:
importance: Undecided → Medium
assignee: nobody → HariGopal (harigopal-gollamudi)
milestone: none → 13.01
Botao (botao-sun) on 2012-12-19
description: updated
Changed in linaro-android:
status: New → In Progress
Botao (botao-sun) on 2013-01-09
description: updated

Inprogress

Botao (botao-sun) wrote :

On ARM Versatile Express A9 board with Linaro Android Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-jb-gcc47-armlt-tracking-open/#build=158

Only video preview shows on the YouTube main page, none of them can be played back. No sound either.

description: updated
Botao (botao-sun) on 2013-01-24
description: updated
vishal (vishalbhoj) on 2013-01-28
Changed in linaro-android:
milestone: 13.01 → none
assignee: HariGopal (harigopal-gollamudi) → nobody
vishal (vishalbhoj) on 2013-01-28
Changed in linaro-android:
status: In Progress → New
Botao (botao-sun) on 2013-01-30
description: updated
Botao (botao-sun) wrote :

On ARM Versatile Express A9 board with Linaro Android Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=179

Sound backs to work again, but video is still unavailable.

Botao (botao-sun) on 2013-02-14
description: updated
Botao (botao-sun) on 2013-02-19
description: updated
Botao (botao-sun) wrote :

On ARM Versatile Express A9 board with Linaro Android image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=220

After clicking a YouTube video clip, neither video nor audio works.

description: updated
Botao (botao-sun) wrote :

On ARM Versatile Express A9 board with Linaro Android Jelly Bean image:

https://android-build.linaro.org/builds/~linaro-android/vexpress-linaro-mp/#build=250

Sound backs to work again, but video is still unavailable.

description: updated
Botao (botao-sun) on 2013-04-23
description: updated
Anmar Oueja (anmar) wrote :

Botao: Can you mark this bug as "won't fix" because it is of no importance to the VE builds.

Ryan Harkin (ryanharkin) on 2013-04-23
Changed in linaro-landing-team-arm:
status: New → Won't Fix
Botao (botao-sun) on 2013-05-22
description: updated
Botao (botao-sun) on 2013-05-29
description: updated
Ryan Harkin (ryanharkin) on 2013-05-29
summary: - vexpress: YouTube video playback fails
+ vexpress: android: YouTube video playback fails
Botao (botao-sun) on 2013-06-18
description: updated
Soumya Basak (soumya-basak) wrote :

observed with Linaro-Android Panda builds:
https://android-build.linaro.org/builds/~linaro-android-member-ti/panda-linaro/#build=323

on TI-Panda 4460 board,
the issue is not reproduced. Youtube video Playback fine, no regression or issues, audio quality is good.

Changed in linaro-android:
status: New → Won't Fix
Ryan Harkin (ryanharkin) wrote :

ARMLT marked this as "won't fix" because it is due to Versatile Express not having accelerated video hardware.

description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints

Bug attachments