vexpress: ubuntu: Reboot and shutdown don't work

Bug #966373 reported by Tixy (Jon Medhurst) on 2012-03-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Linaro Ubuntu
Low
Unassigned
linaro-landing-team-arm
Won't Fix
Low
Unassigned

Bug Description

The Reboot and Halt QA tests fails (https://wiki.linaro.org/Platform/QA/TestCases/Ubuntu)
Attempting these tests just goes to the login screen.
Seen in 12.03 RC1 build (http://snapshots.linaro.org/oneiric/ build id 20120327)

########################################################################
"halt" doesn't work on following images:

http://snapshots.linaro.org/precise/hwpacks/vexpress/132/hwpack_linaro-vexpress_20120627-132_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/vexpress/138/hwpack_linaro-vexpress_20120630-138_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/vexpress/152/hwpack_linaro-vexpress_20120707-152_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/vexpress/185/hwpack_linaro-vexpress_20120723-185_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/hwpacks/vexpress/197/hwpack_linaro-vexpress_20120729-197_armhf_supported.tar.gz

http://snapshots.linaro.org/precise/pre-built/vexpress/211/vexpress-precise_ubuntu-desktop_20120805-211.img.gz

http://snapshots.linaro.org/precise/pre-built/vexpress/226/vexpress-precise_ubuntu-desktop_20120812-226.img.gz

http://snapshots.linaro.org/precise/pre-built/vexpress/299/vexpress-precise_ubuntu-desktop_20120916-299.img.gz

http://snapshots.linaro.org/precise/pre-built/vexpress/316/vexpress-precise_ubuntu-desktop_20120923-316.img.gz

http://snapshots.linaro.org/precise/pre-built/vexpress/334/vexpress-precise_ubuntu-desktop_20120930-334.img.gz

http://snapshots.linaro.org/precise/pre-built/vexpress/360/vexpress-precise_ubuntu-desktop_20121013-360.img.gz

visibility: private → public
tags: added: halt linaro-ubuntu reboot
Tixy (Jon Medhurst) (tixy) wrote :

From the command-line, "shutdown -h now" works..

Changed in linaro-landing-team-arm:
status: New → Triaged
importance: Undecided → Low
Ricardo Salveti (rsalveti) wrote :

Yes, there's one bug related with lightdm that makes you unable to reboot/halt from UI. Can you also validate if reboot worked for you and mark it as invalid from your side?

I'll also change the test description.

Tixy (Jon Medhurst) (tixy) wrote :

Neither reboot or shutdown work from the GUI they just seem to end the user's X session and drop into s login screen. From the command-line with the 'shutdown' command works to reboot and shutdown. This doesn't look like a fault with the vexpress enablement, so marking as won't fix for linaro-landing-team-arm

Changed in linaro-landing-team-arm:
status: Triaged → Won't Fix
Paul Larson (pwlars) wrote :

fwiw, I tested this on 12.05 and reboot from the command line works well, but halt gets to the point where it says * Deconfiguring network interfaces... [ OK ]
 * Deactivating swap... [ OK ]
 * Unmounting local filesystems... [ OK ]
umount: /run/lock: not mounted
 * Will now halt
[ 490.441986] System halted.
[ 550.514936] INFO: rcu_sched self-detected stall on CPU { 1} (t=6000 jiffies)

...on the serial console, but the screen is still powered on and has what appears to be the end of the boot log on it. Also, the fan is still running, so it doesn't appear to be shutting down completely.

Ricardo Salveti (rsalveti) wrote :

Tixy, shouldn't the board turn itself off completely after halt?

Ryan Harkin (ryanharkin) wrote :

The board will reboot or shutdown if this is done via the command line:

$ reboot

or

$ shutdown -h 0

But doing it from the Ubuntu menus only logs out the user. I suspect there is a power hook missing from the BSP, but I don't know what that hook would be...

Ryan Harkin (ryanharkin) wrote :

This bug is marked "won't fix" so I'd advise skipping this test unless someone fixes it and moves the status to "Fixed".

On Thu, 2012-08-02 at 13:55 +0000, Ryan Harkin wrote:
> This bug is marked "won't fix" so I'd advise skipping this test unless
> someone fixes it and moves the status to "Fixed".

Only, 'won't fix' under ARM LT, because if I remember right we think
it's an Ubuntu bug.

--
Tixy

Fathi Boudra (fboudra) on 2012-08-08
Changed in linaro-ubuntu:
status: New → Confirmed
importance: Undecided → Low

Observed same on Linaro ubuntu pre-built image:

http://snapshots.linaro.org/precise/pre-built/vexpress/211/vexpress-precise_ubuntu-desktop_20120805-211.img.gz

Since ARM landing team won't fix this, @Ricardo, what's the plan on ubuntu platform side?

Botao (botao-sun) on 2012-09-21
description: updated
Botao (botao-sun) on 2012-09-24
description: updated
Botao (botao-sun) on 2012-10-01
description: updated
Botao (botao-sun) on 2012-10-15
description: updated
summary: - vexpress-a9: ubuntu: Reboot and shutdown don't work
+ vexpress: ubuntu: Reboot and shutdown don't work
Botao (botao-sun) wrote :

Now this bug will be marked as "Won't Fix" since we have switched to new command line based Linux Linaro ubuntu image, and we also have separated new bugs for "reboot" and "halt" test:

Reboot: https://bugs.launchpad.net/linaro-ubuntu/+bug/1177788

Halt: https://bugs.launchpad.net/linaro-ubuntu/+bug/1087533

Changed in linaro-ubuntu:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers